Bricked X--HELP


  1. ninefall

    ninefall Member

    was trying to go back to 2.1 from 2.2. RSD flash failed, had to unplug phone. Now the bootloader screen says CODE CORRUPT and Cannot Program. I can only get this message when plugged into the wall charger. If i plug into USB to PC i get just a green light where the power light is.....any help or suggestions would be appreciated

    Advertisement
  2. neoxfl

    neoxfl Active Member

    Hi
    I did the same thing on my moto droid. I tried all the maneuvers finally had to be replaced in vzw store. Just take it in the store and tell them you were trying to install an application when this happened. There is no way they can figure out what happened as boot loader is CORRUPTED. only way to fix that would be a hardware restore. Like restore motherboard in PC. dont worry, you still have 1 year warranty on DX!!
    Hope this helps.

    Neoxfl
  3. D13

    D13 Well-Known Member

    If you are going from 2.2 to 2.1 you have to wipe data and cache first or it will fail
  4. agi$$$

    agi$$$ Member


    This happened to me as well. I tried reflashing the sbf file and it did not work at first. I realized that my battery had drained almost completely. It would not charge either no matter what method I tried, wall charger or the computer. Thankfully I had my wife's droid x and her battery was fully charged so I swapped and reflashed the sbf file and it worked. I hope this helps.
  5. HalfFrozen

    HalfFrozen Well-Known Member

    You should take it to the range and use a .50 cal on it.

    Just one less SkyNet device to fight when they take over.
    topdj likes this.
  6. faber78

    faber78 Guest

    ^you helped
  7. SacNutz

    SacNutz Well-Known Member

    So did you figure this out? If not I just read an article that will solve your problem. It's late and I've gotta go to bed, but if you still need help I'll find it in the morning.
  8. SimsDelt

    SimsDelt Well-Known Member

    I got the "Code Corrupt" on mine... but it was OK TO PROGRAM... so I'm not sure how to help you. I had to get the newest RSD from droider with the right ini file. It worked finally doing that.
  9. itsTee

    itsTee Well-Known Member

    crap i did this too. same thing is going on with my phone.. tried to go back to 2.1 from 2.2 now its code corrupt.. but mine says OK to Program

    *edit* all fixed.. flashed .sbf 2.1 to phone, rooted, and updated to 2.2.. now with rooted froyo
  10. SacNutz

    SacNutz Well-Known Member

Share This Page