Browse the web from a tethered phone


  1. grahamsz

    grahamsz Active Member

    I'm pleased to announce a very quick, hacked together proxy server approach which should let you browse the web (just the web, not the whole internet) from your PC via your tethered device.

    I've tested on Windows & Linux and there's no reason (that I can see) that it wont work from a mac.

    However, this is highly experimental and somewhat tricky to set up. It's also my first ever Android app and was built from scratch in the last few hours.


    http://graha.ms/androidproxy

    Let me know how you get on! I'd love to see how it performs on a 3g network.

    Advertisement
    :
    DannyB likes this.
  2. ScoobyDooby

    ScoobyDooby New Member

    Hi,

    I can't get the app to install on my G1, all I get is "application install unsuccessful". No other error messages. I have enabled the option to install non marketplace apps.

    Any thoughts?
  3. grahamsz

    grahamsz Active Member

    My phone made me save it to the SD card and then install it from there. It doesn't do anything very unusual, perhaps you need the USB Debugging thing turned on too.

    Someone over on t-mobile forums got it to work but said it was still pretty slow, even on 3g :(
  4. Manacit

    Manacit Well-Known Member

    I've tried to get this working - but I don't seem to be able to. When I plug my phone in there is no "proxy" application, I've tried reinstalling it twice and nothing shows up, there's nothing in the application manager either. No errors or anything when installing but I can't find anything.

    on another note, if nothing shows up, will this have a negative affect on my phone? Just wanna make sure because I don't see a way to un install it.
  5. ScoobyDooby

    ScoobyDooby New Member

    Yeah, I'm a tad concerned about that too. It appears that it may have overwritten an existing file (or so it warned me upon installation), so I'm curious what exactly it did...
  6. grahamsz

    grahamsz Active Member

    Hmm, the impression i have is that the application is entirely self contained. There's nothing unusual about the way the app is designed. It's really quite a simple app that doesn't do anything it's not supposed to do.
  7. Manacit

    Manacit Well-Known Member

    Yeah, I got the warning too... This is starting to worry me a bit. OP: any chance you can tell us how to remove this, or at least release the source?
  8. grahamsz

    grahamsz Active Member

    Sure, here's the source:

    http://graha.ms/androidproxy/proxysrc.tar.gz

    In testing i've loaded and unloaded it dozens of times and never seen any such warning - does anyone have the exact text?
    DannyB likes this.
  9. atek3

    atek3 Well-Known Member

    Hey Graham, I'm connected to the forum right now on my laptop through my G1. I must say, impressive work on short notice. As far as speeds, it's very very rapid in throughput, but the latency is bad... i'm getting approximately a ping of 300 ms.

    Also, not every webpage works, for example, when I try going to "facebook.com" it takes me to:
    http://ww23.rr.com/index.php?origURL=http://www.facebook.comhttp//facebook.com/

    "Sorry, we couldn't find www.facebook.comhttp"

    Right now t-mo is down so I'm using a wifi connection (phone) with the wifi disabled on my laptop.
  10. jj224

    jj224 Member

    Haven't gotten my phone yet, TMO says it's in the mail. Really Glad to See Somebody is working on this problem. Thanks
  11. Manacit

    Manacit Well-Known Member

    I would like to sincerely apologize for suspecting you - after I upgraded my phone to RC29 and re downloaded the app, it worked like a charm aland didn't tell me it was going to overwrite android system like it did.

    Edit: I'm posting this from my phone tethered to my laptop - it works, but it is _really_ slow (on EDGE). Thanks for this though, in a pinch it would work :D Sorry again for suspecting you.
  12. jj224

    jj224 Member

    what kind of speeds are you getting?
  13. grahamsz

    grahamsz Active Member

    No worries, although its good to know i didnt break your phone.

    i get decent speeds on wifi (2mbit or so) but on edge it seems to be several times slower than it should be. my gut feeling is that the debug bridge is only forwarding 1 connection at a time, then it has to wait for that page component to come back before getting the next image.

    if i get time tomorrow then ill try a straight port bounce and use ssh to tunnel my traffic, that should put less stress on the phone but will need people to have a home server to connect to
  14. grahamsz

    grahamsz Active Member

    I think the overhead of creating connections is very high. I also got good throughput on my home wifi but also noticed the latency. I've got a few ideas on how to improve it, but it's most likely going to involve either software on the PC that collects the different requests and forwards them through a single connection to the android, or to simply provide a conduit for some kind of vpn software.

    The latter is probably easier, but it'll require that you have some server to connect to on the other end
  15. grahamsz

    grahamsz Active Member

    Thanks!

    Right now it doesn't appear to support https which i think does cause issues for facebook.

    How did you measure the latency? typical ping tools won't work because they wont run the ICMP packets through the proxy. It'd be nice if we had lower level network access to the device because they we might be able to build a NAT implementation, as it stands the best it can do is relay traffic.

    I do concur that the latency is awful. I need to do more digging and find out where that bottleneck is. I *think* it's a limitation of the android debug bridge but we can likely work around it somehow!
  16. Minigig

    Minigig New Member

    I used it in southern san diego with 3g and I get 1.5 megabits down and 300 kilobits up. on some sites I have to refresh a few times for it to come up right but a connection is made it works great.
  17. atek3

    atek3 Well-Known Member

    i used speedtest.net

    I got 1500kpbs down and 150 kpbs up which is good... but the latency as I said before, sucked ;)
  18. Manacit

    Manacit Well-Known Member

    you could try setting " network.http.max-connections-per-server " in firefox to 1
  19. obijohn

    obijohn New Member

    grahamsz, you should also post about this on xda-developers forum (lots of exciting development going on there with the G1). There's a thread about working on a tethering app, and someone posted a link to your Proxy app. The link to the thread is http://forum.xda-developers.com/showthread.php?t=430038
  20. grahamsz

    grahamsz Active Member

  21. jdaddin

    jdaddin Member

    I updated to the RC29 and am still getting the message about the application install was unsuccessful. Any clues?
  22. grahamsz

    grahamsz Active Member

    I'm unfortunately still on RC19 and can't test this problem.

    Someone on xda-developers was able to use the adb utility to actually install the proxy app. Try "adb install Proxy.apk" from a directory on your PC that has the proxy installer.
  23. jdaddin

    jdaddin Member

    That did it! The adb app loaded it right up. I too am replying using my G1's connection. Thanks!
  24. porear

    porear New Member

    Excellent work Graham! Thanks for the app.

    I first tried it browsing my laptop with my phone connected to my home wifi and the page load speeds were impressive. Unfortunately when I subsequently tried turning off the wifi on the phone and went to Edge, the pages would not load at all. However, the browser would simply hang instead of going to an "unavailable" page.

    I tried stopping and restarting both the adb forward and the proxy app on the phone after switching to Edge, but with the same results.

    I am in the Houston area. Anyone else here had success with Edge tethering? Even a slim chance there is packet sniffing going on to find headers that the network could use to identify tethering and block?
  25. porear

    porear New Member

    OK nix the silly sniffing hypothesis. I got connected via Edge, although its about as painful as visiting mom and pop on the holidays and their 56K.

    I had restarted the laptop, so apparently just killing and restarting the adb.exe process was not good enough to reset the forwarding app on the PC side. Any insight into this, or a more direct method to truly shut down the adb forwarding daemon? Thanks
Loading...

Share This Page