Browse the web from a tethered phone

Last Updated:

  1. wizang

    wizang New Member

    This method was the only way to successfully install for me. I am running rc29. When installing via the normal method I would get the system overwrite warning and then an unsuccessful installation... I seriously don't think anything went wrong, but I'll knock on wood anyway.

    The connection is really uneven for me, going from pleasantly fast (considering), to gut wrenchingly slow. I'm unable to keep it stable enough to get a proper speedtest done before it times out. I'm on the Portland, Oregon 3G network.

    This app is somewhat cumbersome at the moment, but its a great sign of things for the future! Thanks so much for you work on this, and any future development to come.

  2. travisjb

    travisjb New Member

    First, thank you for building this app !

    I too was unable to install the app directly on my production G1... have enabled USB, enabled 3rd party apps etc

    So, I tried to install it by connecting the G1 via USB to my winxp machine and running command "adb install Proxy.apk" from directory with both adb and your proxy.apk... but it tells me that "error:device not found"

    How do i get adb to 'find' the G1 ?

    THANKS !
  3. l3wis

    l3wis Well-Known Member

    I Don't get this part.

    Move to the directory that has the adb utility, using inside the Sdk Tools folder and run Windows: adb forward tcp:8080 localabstract:proxy
    Linux/Mac: ./adb forward tcp:8080 localabstract:proxy

    When i run the adb application it exits right away..
  4. digitalman2112

    digitalman2112 New Member


    First, thanks for building this - what a great way to use the existing adb.

    Second, I have it installed and running and like others have noticed a need to hit refresh a few times on large pages. After reviewing the source, I'm wondering if the ProxyThread timeout threshold is being reached (looks like 20 seconds which is pretty short for 3G / EDGE).

    This should be easy enough to test, my suggestion would be to allow the user to set the timeout when they start the service - this would allow a custom threshold that might be appropriate given wifi testing, 3G service or EDGE service.

    Anyway, just a theory, I'm happy to test & provide results if you make such a modification.

    Thanks again,
  5. Kesey

    Kesey Member

    Works great on the Mac. Seems like I'm getting 3G, but didn't run any speed tests. Nice work.
  6. l3wis

    l3wis Well-Known Member

    How do you run the adb application??
  7. Unitas

    Unitas Member

    First I'd like to say excellent work on this app. This functionality is exactly what I need from this phone.


    It's not working for me.

    I loaded the drivers for the dream, set the G1 to debug mode.

    The proxy app installed fine. (*There's in installer app in the Market that's good for this. Just save the app (proxy) file to the root directory of the G1 in windows and run the installer app on the G1. It should find the file immediately.*) I ran the proxy app on the G1.

    I started the daemon at the command line with the appropriate settings, got the notification that the daemon was started successfully.

    I set Firefox to the proper proxy settings.

    I open a tab, even restarted Firefox, and there's no connection. It's a no go. Thanks for the work you've already put into it, any help would be appreciated. I've quadruple-checked my settings but perhaps there's some silly setting that's I'm missing.

    Thanks in advance!

    P.S. for those wondering how you shut down adb.exe on your laptops, ya gotta go into the task manager-->processes to kill it.
  8. atek3

    atek3 Well-Known Member

    go to start-> run...
    type cmd
    hit enter
    then type
    then type
    cd (directory you put it in)
    then type
    adb forward tcp:8080 localabstract:proxy
  9. l3wis

    l3wis Well-Known Member

    Works but i can't connect i this this error

    Proxy Server Refused Connection

    Firefox is configured to use a proxy server that is refusing connections.

    The browser is configured to use a proxy server, but the proxy refused a connection.

    * Is the browser's proxy configuration correct? Check the settings and try again.
    * Does the proxy service allow connections from this network?
    * Still having trouble? Consult your network administrator or Internet provider for assistance.
  10. Unitas

    Unitas Member

    Just wanted to update, I got it working, although I'm not exactly sure what I did differently this time than last time.

    If I can figure out what kept me from connecting before I'll be sure to post it. Thanks again for this app. Even with the limited capability, any internet access at all is better than zero.
  11. l3wis

    l3wis Well-Known Member

    Okay i got it 2 work
  12. atek3

    atek3 Well-Known Member

    it seems really picky about the order you do stuff. Here's what I do.

    1) turn phone to USB debugging mode
    2) plug into USB
    3) click "don't mount"
    4) turn on proxy app
    5) run adb.exe
    6) adjust proxy settings in Chrome
    7) surf internets

  13. parrothd

    parrothd Member

    Works great, however needs https support..:rolleyes: (any site using https doesn't load,,, etc, etc)
  14. DougN

    DougN New Member

    As many on the blog lists are stating, I am also unable to get past the installation of the Proxy.apk on my new G1 phone. I enabled USB debugging and Allow Unknown Sources. It downloads, is visible, but returns a message 'Application Install Unsuccessful' and does not show as an app. I even used the terminal program and issued the command 'adb install Proxy.apk' after cd-ing to the downloads directory where the file is listed.

    Kernel is 2.6.25-01843-gfea26b0
    android-build@apa27 #6

    Build number:
    kila-user 1.0 TC4-RC28 114235 ota-rel-keys,release-keys

    Can you check your version and let me know what I might need to do to get this running?

  15. grahamsz

    grahamsz Active Member

    I just got the googlephone update and it doesn't work for me. I'll try to investigate this tonight.
  16. dschach

    dschach Active Member

    First, thanks for writing this app and sharing it.

    I have RC29 and the app installed for me using the instructions at However, I am unable to browse with IE7. The browseris set to use localhost and port 8080 but no connection. Has anyone got it working on IE?

    I think there is a typo on your instruction page. It says

    "It looks like the latest google update have stopped by application installing. It seems to be unrelated to what the application actually does and rather something amiss with the installer. If you download the proxy application to your PC, you can install it using the adb tool below
    adb install Proxy.apk"Shouldn't the install command beadb install
  17. grahamsz

    grahamsz Active Member

    I just launched a new version of my proxy app - now called Tetherbot

    I've switched to Socks because it seems to be a bit more flexible than http and now surfing the web is much more tolerable on EDGE. It also means that https now works and it should work with quite a few other applications as long as they support socks proxies.

    I also added a straight port bouncer which makes it really easy to open an ssh tunnel to a linux machine somewhere and route your traffic through that.

    Feedback is very welcome!

  18. l3wis

    l3wis Well-Known Member

    Wooohooo!!!! Cant get to the page we get a time out networks..
  19. grahamsz

    grahamsz Active Member

    First make sure you clicked on the Start Socks button on the application, it should give you a brief message on screen letting you know the service started.

    Then try the following from a dos window

    telnet localhost 1080

    It should connect and then disconnect you again if you hit return.

    Finally make sure your phone has internet access - try bringing up your browser. I spent ages beating my head against the wall before realizing t-mobile were down.
  20. l3wis

    l3wis Well-Known Member

    NOO i meant we cant access
  21. grahamsz

    grahamsz Active Member

    Hmmm - i think the internet might be broken. I can get to that site, but can't reach any of the servers on the east coast that i maintain. Hopefully it'll be accessible again soon.
  22. l3wis

    l3wis Well-Known Member

    Ummm weird.. I'll just try tomorrow cause im looking damn forward for this new app :)
  23. l3wis

    l3wis Well-Known Member

    Okay so I'm working with sockets. I don't get any error such as Proxy Server Refused or nothing like that. But when open a page all it opens is a blank page no content at all. Am i doing something wrong?
  24. grahamsz

    grahamsz Active Member

    So if i'm reading that correctly the basic tunnel worked and you were able to connect through to another socket, but you can't get the socks server to work in firefox?

    Try unplugging your phone and seeing if that causes firefox to report a connection issue - it certainly should. When you replug it, you'll need to rerun both the adb commands.

    Other than that, i'm not totally sure - it just seems to work here. You might want to make sure that you are on Socks v5 in your firefox settings.
  25. parrothd

    parrothd Member

    Firefox (3.0.3) doesn't allow me to enter only a socks 5 server.

    I enter localhost and 1080 and click ok, but when I go back to the proxy settings page the socks settings are gone. Also, if you having anything in the http box you get a blank page when attempting to browse the web.

    However it does work in Internet Explorer, just be sure only the socks fields are filled in..

    :) Great Job!


Share This Page