1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Browse the web from a tethered phone


  1. l3wis

    l3wis Well-Known Member

    Yes you are right. I've tried what you said unplug the phone and i did get the Proxy refuse. Here what my commands looks like. I believe I'm doing something wrong here.

    [​IMG] and Socks v5 are select...
  2. dschach

    dschach Active Member

    Thanks again for the hard work.

    OK. I uninstalled the old version and followed the new instructions, downloading directly to my phone.

    1. When installing it said it was replacing an existing application, yet I had uninstalled the old app.
    2. Application install unsuccessful.

    I went back to manage applications to check for the old app but nothing was there. I tried reseting the phone and installing again but still had the same problem. i.e. App won't install. Install fron unknown sources was enabled.
  3. azrale

    azrale New Member

    I am getting the problem. just a blank page. if i disconnect the phone i get proxy server refused connection. Not really sure what i did wrong. Http Proxy: localhost port: 1080. i have nothin in any other field. should i have something in No proxy for field?
  4. parrothd

    parrothd Member

    Are you using Firefox or IE?

    Try using Internet Explorer:

    Tools/Internet Options/Connections/Lan Settings/

    Check "Use a proxy server for your LAN"

    Click Advanced

    Uncheck "Use the same proxy server for all protocols"

    Clear/Empty all boxes!

    Enter Localhost and 1080 in the socks fields ONLY! (No other fields should have any localhost / ports in them!)

    Click ok.ok.ok..

    Then try it..
  5. parrothd

    parrothd Member

    Read the directions...

    http Proxy: localhost port: 1080 (this should be blank!)

    Socks Proxy: localhost port: 1080
  6. l3wis

    l3wis Well-Known Member


    I was getting the same error so i rename it and uploaded to a different server here it's http://www.zshare.net/download/5096090498935c7b/
    download it using your G1
  7. l3wis

    l3wis Well-Known Member

    When we enter locolhost and the port number on Socks host it disappears once we click ok..
  8. dschach

    dschach Active Member

    OK. I installed the app sucessfully by downloading to my pc and then installing using the adb tool.

    However, IE will not connect. Here's what I did

    1. started the socks on the g1

    2. ran adb forward tcp:1080 tcp:1080

    3. set IE to use the proxy

    socks set to localhost port 1080

    all other fields set to blank and unchecked use server for other protocols
  9. l3wis

    l3wis Well-Known Member

    Any fix for the blank page yet?
  10. azrale

    azrale New Member

    i changed the settings accordingly sorry i wasnt paying attention. I now get page cannot be displayed. if i do a netstat /a in the CMD prompt it says that

    TCP mylaptop:1080 0.0.0.0:0 listening.
  11. parrothd

    parrothd Member

    Which browser are you using? Try IE, My version of mozzilla doesn't allow for socks only connections..
  12. parrothd

    parrothd Member

    Do you have debugging turned on for the usb port?
  13. l3wis

    l3wis Well-Known Member

    Okay i got it to work using an Add on from Firefox

    Download FoxyProxy from mozilla page..
    https://addons.mozilla.org/en-US/firefox/search?q=foxyproxy&cat=all
    -----------------------------------------------------------------------------------------------------
    Open the FoxyProxy Options

    Proxies ----->

    Add New Proxy ------>

    General (Check enable,Proxy Name: Tetherbot, Leave blank Proxy Notes, Select Animation icon & Include this proxy) ---------->

    Proxy Details (Select Manual Proxy Configuration, Host name: localhost Port: 1080, Select Socks proxy?-Socks v5) Click ok a warning message should appear saying "You didn't enter and enable any white....." Hit yes

    Tools/FoxyProxy/Use Proxy "Tetherbot for all URLs

    Now refresh your page and see if you are able to go online..



    ------------------------------------------------------------------------------------------
    Update: Make sure you to Check "Use SOCKS proxy for DNS lookups" Is Under Global Settings.
  14. l3wis

    l3wis Well-Known Member

    Here is my new speed :) I'm not using the build in Proxy on Firefox i had to download FoxyProxy in order to use Socks v5

    [​IMG]
  15. dschach

    dschach Active Member

    Yes. I have (and had) usb debugging turned on. Still no connection with IE. But thanks for the suggestion. I am running IE7 on a windows vista enterprise laptop.
  16. l3wis

    l3wis Well-Known Member


    Just go back to Firefox and download the FoxyProxy Add-on this one does let you use Socks v5 :)

    I'm up and running.

    P.S Reply from Tethering connection...
  17. dschach

    dschach Active Member

    I will try Firefox now.
  18. l3wis

    l3wis Well-Known Member

    Let me know if you have trouble with FoxyProxy
  19. parrothd

    parrothd Member

    I had to enable:

    Use SOCKS proxy for DNS lookups in the globals section for Foxy Proxy to work...

    Thanks for the FoxyProxy find!

    Attached Files:

    • pic.JPG
      pic.JPG
      File size:
      77.1 KB
      Views:
      18
  20. l3wis

    l3wis Well-Known Member

    Yes it has to be check. Not sure why was not check on yours? Your on XP right?
  21. dschach

    dschach Active Member

    Firefox now works. Thanks for the help. I also had to check use proxy for dns lookups. It was off by default and I just did a clean install of Firefox.
  22. l3wis

    l3wis Well-Known Member

    Looks like we have another successful mission :)
  23. dschach

    dschach Active Member

    Still would like to know why IE won't connect. There must be some setting I am missing.
  24. l3wis

    l3wis Well-Known Member

    Umm No clue. I even downloaded Opera but no Socks support at all and Crome uses the same proxy as EI
  25. dschach

    dschach Active Member

    Yeah. Firefox is fine. I am happy to have browser tethering.

Share This Page