Browse the web from a tethered phone

Last Updated:

  1. dschach

    dschach Active Member

    I never got ie7 to work with tetherbot, only Firefox with the foxyproxy. Even then the connection is a bit flaky. I've tried with both edge, 3g and wifi with the same results. The pages initially downloads quickly then the download stops.

  2. parrothd

    parrothd Member

  3. l3wis

    l3wis Well-Known Member

    Well i first i thought it was cause i had installed the OLD app and that's why i was getting a unsuccessful install. So i was like Umm maybe renaming the app and uploading it to a different server might fix the problem which it did.
    But some people who don't have the old can't install it. Maybe you are right FILE NAME BLOCK or IDk lol
  4. metallic9900

    metallic9900 Member

    We sure
  5. atek3

    atek3 Well-Known Member

    mine stopped working when I got RC30.
  6. DaveCC

    DaveCC Member

  7. When connected, my laptop can't ping any server or check mail or contact smtp server.... I assume this is cause I'm connected over socks? Any workaround?

    Who can explain HOW we're tethered?
  8. DaveCC

    DaveCC Member

    The proxying is TCP only - ping uses ICMP. The only workaround right now is to use the single port forwarder to establish a VPN connection (see my post above about SSH tunnels using Linux, maybe someone will post Windows instructions)

    I've exchanged email with Graham about ideas for turning this into a more general NAT proxy but it would be quite a bit of work - the Java environment doesn't let you have access to packet level networking and the layer 4 to 3 translation is non-trivial, especially for TCP.
  9. Mystech

    Mystech New Member

    Me again, still having issues. Although I can't install from the G1, I attempted the install from windows command line method mentioned in this thread.

    Although I can see and access the Android microSD when it is tethered to the computer using Windows Explorer, it cannot be accessed from the command line. I get the error "error: device not found" from the command line when I try the adb install command.

    Really bizarre. I can view, open, add and remove files from the tethered phone through Windows Explorer but no luck even cd'ing to the phone from the command line on windows.
  10. Mystech

    Mystech New Member

    Rebooted both phone and computer and tried again and got a slightly more detailed message:

    C:\>c:\adb install g:\Tetherbot.apk
    * daemon not running. starting it now *
    * daemon started successfully *
    error: device not found

  11. l3wis

    l3wis Well-Known Member

    Same here. Just re-run the adb on the command prompt and it should fix the problem...
  12. ethyr2000

    ethyr2000 Member

    Is the source for adb available? Does it require the sdk? I'd like to tether my G1 to my Zaurus palmtop (arm based).
  13. Beeny

    Beeny New Member

    After spending some time trying to learn how SSH works and how I could use it with Windows and Remote Desktop, I came across a program called proxifier. I entered the socks5 info into it, ran adb, and it seems to let any program that tries to access the internet to work with the G1 socks tethering. I played around for a little bit and it seemed flawless. I don't think anybodys mentioned a solution like this yet...
  14. ethyr2000

    ethyr2000 Member

  15. jdaddin

    jdaddin Member

    For anyone interested, I put together a quick little app that works as a shell for adb and tetherbot. I was really just making it for my ease but I decided to add in a few extras and throw it out here. It also will try and help you install those programs on the computer and phone. (requires internet connection) You will still need to set-up the proxy in the internet settings but Foxy is awesome for that.

    Have fun.
  16. l3wis

    l3wis Well-Known Member

    Wow Nice dude. The only problem is that it crashes a lot on vista and we end up getting Proxy refuse.
  17. Minigig

    Minigig New Member

    I have to say Proxifer is what makes this complete. I have now been using the g1 tether on the road for over a week now and find this completely usable.
  18. jdaddin

    jdaddin Member

    I3wis, I tested it on my Vista VM and could not reproduce any crashes. I noticed that the program must be run with Admin privileges for the pre-requisite portion though. Otherwise UAC won't allow it to write to the necessary locations. I did see one problem with the tetherbot install on the Windows version that I fixed here:
  19. pdms

    pdms Member

    Did you install the driver? Without the diver you can access the SD but not the device.

    Hope this helps
  20. metallic9900

    metallic9900 Member

    Thank you very much!!! Proxifier works and what a find!!! Yes this puts the icing on the cake.
  21. metallic9900

    metallic9900 Member

    Thank you very much!!! Proxifier works and what a find!!! Yes this does puts the icing on the cake.
  22. pdms

    pdms Member

    Well if it is blocking the file name, then we know this has hit a nerve! Plus that would be pretty crappy of them, telling us that we can do it if someone can figure it out and then blocking when someone does.
  23. wnyzfinest

    wnyzfinest Member

    I am running on Vista, When I try to run the Android Driver, it wont install the Driver, I try to force install the INF file but it says not valid 32 bit
  24. Rio-g92

    Rio-g92 New Member

    Can a G1 able to do an online schooling or does it need an application in order to work.
  25. mingsterlbc

    mingsterlbc New Member

    so it says only for 32bit, will it work for 64bit? cuz i got vista64 bit on my laptop i really want to use this for work. Well you get it to work with 64bit anytime soon?

Share This Page