Browse the web from a tethered phone


  1. huh28

    huh28 New Member

    Thanks to everyone for the support and hard work!

    I got it to work in firefox with foxyProxy and can go on all sorts of websites through the G1's 3g connection, but it seems like any page that contains flash requires multiple "refresh" clicks to get it to load completely. i.e. speedtest.net or youtube.com would only load after I click refresh 3 to 4 times. I have no problem with that, but I just tried to go to www.hulu.com but no shows would load but all other content does....?

    Is this normal or am I missing something?

    Thanks!
  2. metallic9900

    metallic9900 Member

    Run Proxifier, then go into options, then Proxy settings
  3. t59ski

    t59ski Member

    When Tetherbot comes up on your phone do you start both the Socks Proxy Server and the Port Bouncer or just Socks Proxy Server; if you start the Port Bouncer what IP Address or Hostname and Port To Forward To are you using
  4. metallic9900

    metallic9900 Member

    Just start SOCKS
  5. atek3

    atek3 Well-Known Member

    any idea why it suddenly would stop working? data on the phone is working. i plug it in, mount, start proxy with tetherbot, run the adb, load firefox w foxyproxy and i get nothing. it worked fine yesterday, now its busted, any ideas?
  6. t59ski

    t59ski Member

    Which proxy servers are you using socks 5, socks 4, or HTTPS or are you using any combinations? What options are you setting for the servers you are using?

    for the adb application are you using the following command; adb forward tcp:1080 tcp:1080?

    under the device manager what ADB Interface shows up, mine is HTC Dream Composite ADB Interface?
  7. t59ski

    t59ski Member

    I know you said you didn't change anything in IE, however could you tell me on the connections page of the internet options dialog are there any dial-up or Virtual Private Networks and could you tell me if any of the check boxes are selected on the LAN Settings dialog and if the Proxy server is selected on that dialog and if it is what the settings are?
  8. metallic9900

    metallic9900 Member

    In IE 7, internet options>connections there is nothing checked, no proxy settings or anything. Under LAN settings, everything is blank as well. If Automatically Detect Settings is checked, uncheck it. I have nothing in the Dial-up, VPN settings as well...
  9. Manacit

    Manacit Well-Known Member

    Just wanted to say thanks a bunch for this - My cable just went out and I was able to tether my laptop to my phone and get internet :D
  10. metallic9900

    metallic9900 Member

    You got it working!! Nice!!!

    This is the closest yet to true tethering. I give it a couple more weeks and the G1 will be able to fully tether.
  11. t59ski

    t59ski Member

    Are you using Vista or XP; if you are using Vista where did you get the drivers?
  12. dishragwhore

    dishragwhore New Member

    Got it working for me! I'm sitting in Starbucks using the t-mobile hotspot connection on the phone. The connection is slow, but it's going through a long series of tubes, so I guess that's why. Thanks for your hard work!

    A tip for people who are having trouble:

    I was unable to get it working using Firefox's default proxy function. Install the foxyproxy add-on, and do the following:

    1. Go to the foxyproxy options, and under the proxies tab, create a new proxy called "Android Tether", or anything you like.

    2. Hit "Add New Proxy", "manual configuration", and under host name put "localhost", and under port name put "1080".

    3. Select the "Socks Proxy" checkbox, and Socks V5 option.

    4. Now hit "Okay" to go back to the main options dialog, and in the "Global Settings" tab, select "Use SOCKS Proxy for DNS Lookup"

    Firefox will restart, now go to the FoxyProxy menu, and select "Android Tether", or whatever you named your connection.

    You should have internets now, at least this is what worked for me.
  13. photomandy

    photomandy New Member

    Okay, I am extremely frustrated. I just got my G1 today. I have done everything suggested in this thread and nothing is working.

    I am on Windows Vista using Firefox 2.0.0.18 (I did "Check for updates" and it says there are no new updates)

    Here's what I do:


    • I've successfully installed Tetherbot.apk on my phone
    • I've successfully installed the Android driver & SDK on my Windows Vista laptop
    • I downloaded the FoxyProxy addon and configured it with the settings from this thread.
    • I turned off my WiFi and made sure that the network.proxy.socks_remote_dns setting from the about:config was set to True
    • I have enabled USB debugging
    • I connect my phone to my laptop with the USB cord
    • I go to the Tetherbot app on my phone and Start Socks
    • I run adb from the cmd line. It says "daemon started successfully"
    • I set FoxyProxy to "Tetherbot".

    I try to load a page and get "The proxy server is refusing connections". I restart Firefox and get the same error.

    I have rebooted and started all over from the beginning several times. I have never gotten it to work.

    Can anyone please please help me? We travel a lot and I use tethering all the time... I was crushed when I found out the G1 didn't support tethering. :( I feel like I am doing everything right and this really should work! Is there something I'm overlooking?

    Thanks so much for your help...
  14. photomandy

    photomandy New Member

    Just wanted to add, I also tried it without using FoxyProxy and in IE7 and couldn't get those to work either... :\
  15. epuck

    epuck New Member

    Yes! Tonight I got socks proxy and tunneling working with Vista & Android RC29. Followed all instructions from http://graha.ms/androidproxy/

    I was able to surf using Proxifier.

    I couldn't get firefox proxy or foxyproxy to work for some reason but with Proxifier it started right up. Very little hassle! Proxifier is a neat little application and everyone should be using it if they are to tether using tetherbot. It gives you progress while you surf letting you know which addresses it connects to, or lack thereof. Proxifier is a must if you like this form of tethering!

    It is simple to re-establish the connection.
    If I felt the connection was messing up I would go into the task manager and force close adb then unplug and replug my phone's usb. Then start tetherbot socks then again start adb.

    For tunneling I used SSH Secure Shell Client, but I probably could have just used putty.
    In my phone I typed the linux server ip and 22 for the port. SSHD was running on the server. Once adb was closed i started it up with port 4444 just like the settings from the original article. Then typed localhost for hostname and 4444 for the port in the connect to server dialog in SSH Secure Shell Client and voila! Next up X forwarding. Haha

    PROPS to Graham Stewart and androidforums.


    Proxifier - I'm not sure if anyone has posted up the how to on Proxifier. It is really simple. Just click the first icon 'proxy settings' and 'add' the hostname and port. Socks5 of course and it will automatically use local and then remote to resolve your dns hostnames. Otherwise you can click on the 'dns' icon and the options are there. You will know its working when you go to a site in firefox and the firefox icon will appear in proxifier and tell you what its trying to download. For some sites it just failed for some reason and no icon appeared and I had to refresh the page or try to 'reestablish connection' as I stated above.

    Good Luck
  16. Krazyone

    Krazyone New Member

    I am receiving the following message in Proxifier:

    I get the same message on Windows XP, 2000 and Vista Home Premium. The only constant is i am running RC30 patch (Google Approved). I ran ADB w/ multiple commands, started tetherbot on my device, fixed the socks dns issue in firefox after installing FoxyProxy and configuring, installed firefox 2x and 3x w/ FoxyProxy, restarted adb multiple times. Gave up at this point and installed Proxifier. Anyone have any insight into why this may not be working for me? I tested this at home with Wifi Enabled on the G1 and 3G network. Both come up with the same error. Just to note as well i have the SDK on my laptop i have tested with as well as the stand-alone adb tool.

    Now here is the weird thing... If i enable the "Use SOCKS proxy for DNS" in firefox / foxyproxy and firefox restarts, my google homepage loads. But after that i get connection refused. VERY ODD!! I am going CRAZY with this!!! AHHHHH. lol. Any help would be appreciated. Thanks grahamsz for this wonderful tool. Just hope I am not screwed with the RC30 update... :(
  17. zh1479

    zh1479 New Member

    Hi,
    I believe I can get help here.
    It looks I am not able to install android_usb_windows driver on HP 6910p. I tried a few same models, I got the same issue. I followed the instruction to install android_usb_windows on HP laptop that is running XP with SP3. For some reasons, installation is failure. System show "cannot install this hardware, there was a problem installing this hardware...HTC Dream Composite ADB interface
  18. t59ski

    t59ski Member


    Are you using IE or firefox
  19. t59ski

    t59ski Member


    Did you download Android SDK or did you use the ADB utility
  20. pdms

    pdms Member

    Photomandy, did you try this?

    also in \tools\foxtproxy\more\global settings\, select 'use SOCKS proxy for DNS lookup'








  21. pdms

    pdms Member

    ok tetherbot is working great, now i need a way to use the g1 as a modem for dialup. anyone know a way to do this?
  22. Vintik

    Vintik Member

    Thanks guys, working fine, now posting using tethered phone.
    Worked on RC30 + Arch Linux (2.6.27) + Firefox 3.0.
  23. umbria

    umbria New Member

    Just one issue I ran into with the link on http://graha.ms/androidproxy/ It says "Follow the instructions here to install the Android driver - you'll need to do this on Windows & Linux but apparently not on the Mac. " On the link, I could not find the drivers anywhere on the page. I finally did a Google search and found a cached version of the page that had the USB driver (android_usb_windows.zip)

    It looks like they changed the page recently and the driver link is now missing.
  24. jlotus

    jlotus Member

    Hi. I don't know much about computers, so if someone could please explain this to me like they would a child, that would be super. I'm using Windows XP.

    1. When I click on the adb icon, it pops up for one second and then closes out. What am I doing wrong?

    2. As far as the ports go, how do I even know what port to use? What hostname would I use?

    Thanks in advance!

    Jaime
  25. l3wis

    l3wis Well-Known Member

    Any updates yet for faster connection???

Share This Page