1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Browser apk WILL NOT install


Last Updated:

  1. dtlaluv

    dtlaluv New Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    4
    Likes Received:
    0
    I go the apk from the forum here. I used Root Explorer to move it to the system/ app folder, I changed permissions to match the rest of the apps. IT WON'T INSTALL when I click install or when I reboot either. What am I doing wrong? This is so frustrating :confused:
     

    Advertisement
  2. macjay420

    macjay420 Well-Known Member

    Joined:
    Jun 22, 2011
    Messages:
    352
    Likes Received:
    53
    leave it there...open up terminal type su then enter...then type
    chmod 644 system/apps/browser.apk...its kinda early for me but im pretty sure that will install it..as long as you dnt get any errors your good.reboot and enjoy..
     
  3. Kaiser17

    Kaiser17 Well-Known Member

    Joined:
    Sep 14, 2011
    Messages:
    474
    Likes Received:
    161
    Or you can just remove it, and use Opera or Dolphin. That's what I did.
     
  4. Insanecrane

    Insanecrane Well-Known Member

    Joined:
    Jan 31, 2011
    Messages:
    252
    Likes Received:
    86
    The browser apk is required to use the market with the M. It's been well documented in these forums that you can't remove or replace it with anything and have the market function as it is supposed to do so.
     
  5. p-bOt

    p-bOt Well-Known Member

    Joined:
    Jul 18, 2011
    Messages:
    908
    Likes Received:
    262
    really because mine is working fine and I got rid of the stock browser a long time ago. Im running cm7 now but I was rooted with the stock stock rom and the stock browser removed for a long time and the market was fine.
     
  6. Kaiser17

    Kaiser17 Well-Known Member

    Joined:
    Sep 14, 2011
    Messages:
    474
    Likes Received:
    161
    You don't need the stock browser.
     
  7. dtlaluv

    dtlaluv New Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    4
    Likes Received:
    0
    ok I tried this, but I keep getting a message saying that the file or folder does not exist. The file is IN the system app folder. It just isn't being found or something. grrrr :(
     
  8. dtlaluv

    dtlaluv New Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    4
    Likes Received:
    0
    I got the file using Opera :/
     
  9. dtlaluv

    dtlaluv New Member This Topic's Starter

    Joined:
    Sep 22, 2011
    Messages:
    4
    Likes Received:
    0
    Anyone else having this issue? Im still stuck with this :/
     
  10. BrandonOptimus

    BrandonOptimus Well-Known Member

    Joined:
    Sep 19, 2011
    Messages:
    548
    Likes Received:
    57

    Make sure you have browser.apk and move it with root explorer to the /system/app folder. Then you make sure its in it, don't install it and proceed to terminal emulator. It will show up with a $ with a blank line. Type in such then it changes to # once in that you type in chmod 644 system/app/Browser.apk and click enter
    It should not say anything and start a new line with the # again. From there in terminal you type in reboot and let it load up. If it doesn't work then it could be that you can just simply flash another rom on it.
     
  11. bobdamnit

    bobdamnit Well-Known Member

    Joined:
    Jul 31, 2011
    Messages:
    401
    Likes Received:
    91

    Fixed it for ya Brandon!
     
    BrandonOptimus likes this.
  12. BrandonOptimus

    BrandonOptimus Well-Known Member

    Joined:
    Sep 19, 2011
    Messages:
    548
    Likes Received:
    57

    Oops. The word such was suppose to be su. Stupid auto correct lol
     
  13. tripdoc79

    tripdoc79 Well-Known Member

    Joined:
    May 24, 2011
    Messages:
    630
    Likes Received:
    223
    or you can do a adb push to system/apps either way it should work
     
  14. johngoodin

    johngoodin Active Member

    Joined:
    Mar 18, 2012
    Messages:
    28
    Likes Received:
    0
    Can someone post a link to browser.API for CM7. Somehow mine got corrupted and crashes right after starting. I don't want to reinstall the CM7.2 Stable and lose al my apps and settings. I have several ClockWorkMod backups. Is there any way to just restore the stock browser?
     

Share This Page

Loading...