Bug - WiFi / sleep policy causing wake lock for Android system process & draining batterySupport


Last Updated:

  1. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    Hi all,

    After noticing my battery was draining quickly, and then after reading this thread, I installed Android System Info to see what was draining my battery so fast. I notice that whenever I would turn on WiFi, the phone will never go to sleep , regardless of what I set the WiFi sleep policy to. After turning off WiFi, the battery still drains heavily.

    The WiFi will shut off after 15mins (if you set it to "When screen turns off" or "never when plugged in"). However it seems to keep the CPU on causing it to drain down the battery.

    It would seem that whenever WiFi is enabled, the Android system process creates a partial wakelock that does not go away even if you turn off WiFi. The only way to resolve this is by powering off or rebooting the phone.

    You can verify this in Android System Info by going into Battery-History-Other Usage-Partial Wake usage to see how much time the "Android System" process holding a partial wake.

    I even did a factory reset on the device; and it is still happening so it doesn't appear to be any app that caused the issue. As I said, it works fine as long as I don't enable WiFi.

    I already know of two users having this issue, but I'm wondering if folks having battery problems are going through this as well. Is anyone else having similar issues after using WiFi? I'm hoping someone will be able to identify what exactly is putting the wakelock on and we'll be able to find a fix for it. Other than not using WiFi at all or rebooting the phone after using Wifi.

    Any help would be greatly appreciated.
     

    Advertisement
  2. BookLover

    BookLover Well-Known Member

    Joined:
    Oct 11, 2010
    Messages:
    977
    Likes Received:
    114
    I posted this in your other thread about Edge and Wifi:

    http://androidforums.com/samsung-ca...e-use-more-battery-than-wifi.html#post1939360

    I don't think it's the wifi keeping a wakelock, but something else using wifi that is keeping your wakelock.

    My bf's Captivate lasted over 8days connected to wifi 100%, asleep most of that time except for a few hours of music listening thru headphones: http://androidforums.com/samsung-ca...ur-captivates-battery-life-3.html#post1938646

    Very virgin Captivate. Maybe 5 apps. One is PowerAmp, the other Battery Left, which are used. I don't think he's ever opened the other 3 apps I dl'd for him.
     
  3. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    I am not sure what could be keeping the wifi in a lock and not the hspa or edge connection
     
  4. BookLover

    BookLover Well-Known Member

    Joined:
    Oct 11, 2010
    Messages:
    977
    Likes Received:
    114
    There were a few programs that depleted my battery that I recall, because once I uninstalled them, phone went back to normal:

    Tiny Password
    Missed Message Flasher
    NoLED
    -and a Dog Tips app

    Tiny Password and the Dog Tips app probably connected constantly to the internet in the bkgrd. Not sure, as I didn't know how to check that.

    Missed Msg Flasher and NoLED had wakelocks on my display, so while the screen was dark, I don't think it was ever asleep.

    Maybe you have apps that functions in one of the two ways above and causing probs.

    Just guessing.
     
  5. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    I don't have any of the applications above. Thing is, my battery only goes south once I have enabled the WiFi and thereafter. It works fine on HSPA and EDGE and goes to sleep properly prior to enabling Wifi

    Keep in mind I'm not blaming WiFi for draining the battery, I'm blaming whatever process gets partial wakelocked after you enable it....thus not going to sleep after you're done using the device.
     
  6. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    Anyone else have this issue? Or having poor battery life and use WiFi? Hoping to get a few more people to see if they get a wake lock when/after they use Wifi. Trying to establish a pattern here.
     
  7. jaydee77ca

    jaydee77ca Well-Known Member

    Joined:
    Oct 29, 2010
    Messages:
    116
    Likes Received:
    6
    As you've already noticed I had the same issue. I have not used wifi for a few weeks now and my battery life has improved and I don't see the Android System wake lock and Running times maxed out anymore.
     
  8. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    Update...i have the wifi sleep policy set to never. Also have the time sync disabled. Haven't had the issue since
     
  9. jaydee77ca

    jaydee77ca Well-Known Member

    Joined:
    Oct 29, 2010
    Messages:
    116
    Likes Received:
    6
    Doesn't that cause the wifi to stay on all the time though? I tried that and the battery still drained quickly and when I looked at the JuicePlotter log it showed WiFi as being on constantly. I never checked to see if I had the high wake lock from AndroidSystem though.

    UPDATE: I didn't have the high wake lock from Android System with WiFi sleep policy set to "Never". BUT, the WiFi was on constantly (100%) and that looks like it drained the battery quickly according to JuicePlotter. (20% in just a couple of hours) So that's not really a solution either I don't think.
     
  10. jaydee77ca

    jaydee77ca Well-Known Member

    Joined:
    Oct 29, 2010
    Messages:
    116
    Likes Received:
    6
    So I charged up to 100% last night, set the wifi sleep policy to never, and unplugged this morning. The phone has been sitting on the table not touched for 1.5 hours and the battery has gone from 100% to 93%. That's 4.67% per hour. In fact, looking at the JuicePlotter graph it shows it staying at 100% for about 45 minutes then dropping the 7% in the remaining 45 minutes so that's even higher than 7% per hour.

    When looking at the battery history in Android System Info the Partial wake usage is normal. No high Android System. So that's good. But under "Other usage" it shows Wifi On and Wifi Running at 100% and Running at 30%. So I'm guessing that's what's draining the battery.

    With wifi off and the phone just sitting on the table I only lose about 1-2% per hour, sometimes 3% but that's the highest I've seen. I usually have only lost about 15% by the end of the work day (8 hours) and that's with some use too.

    I supposed what might work is manually disconnecting from Wifi each time I turn the phone off and am not going to use it, then reconnecting when I want to use it. But, that's kind of annoying. It would be nice to be able to just turn wifi on when I get home and then have it be able to sleep properly without causing wake lock issues. *shrug*

    I wonder if this is a Samsung issue or an Android issue?
     
  11. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    At this point we can say that we can establish the same pattern. I wonder if Enhanced is on here and can verify this also....or anyone else for that matter.

    So I wonder what drains more battery -

    A: the partial wakelock caused by WiFi turned on and WiFi sleep policy set to "When Display turns off" or "never on battery"

    B: WiFi on with the WiFi sleep policy set to "Never"

    I suspect B uses less battery from what I've seen.

    For me, I currently leave the policy set to "Never" and just turn off WiFi when I go away from a WiFi spot. However, its wasting battery either way by leaving WiFi on all the time or having the Partial wake lock on!!!

    Does anyone know who we can contact (whether it be Android development, Samsung, Rogers or maybe just a savvy developer that can figure this out?)

    I also wonder if we can leave the policy set to "Never" but use another app to put the WiFi to sleep when not in use....maybe that will get rid of the wakelock?
     
  12. Enhanced

    Enhanced Member

    Joined:
    Sep 19, 2010
    Messages:
    17
    Likes Received:
    1
    If I remember correctly, and I'm not sure if I do since it was a while ago, turning the WiFi sleep policy to "Never" didn't really alleviate any battery drain. It drained pretty quickly as well because WiFi would never shutoff. I believe the Running time increased as well because the phone would spend less time sleeping with WiFi on in the background constantly.

    I'm not sure if it being on "Never" would prevent the wakelock bug though but I'd just say that changing the WiFi policy isn't the solution if you want a better battery life.

    I have been following some of the threads on here and I apologize that I couldn't be of better help. With my practically unlimited data (6GB), I never turn on WiFi and therefore I have no had any new findings. If you guys want me to help test certain methods (since you know I have the same bug as you guys), I'll try to help.
     
  13. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    We need to trackdown someone who can figure out what process is holding the wake lock. I also wonder if it's a rogers thing only as the three of us are on that model. We should all submit tickets with rogers maybe that may bring some awareness. I'm not getting any traction at xda either. Maybe you could reply to one of the threads there as well maybe an expertcan chime in. I agree that this is not an acceptable workaround at this point.
     
  14. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    Update: While this may not be a fix (still want to see what is causing the wake lock), I have found an app called "Green Power" which manages both the WiFi and Mobile Data on the Captivate...and its free!

    I have it managing WiFi only so that it turns off WiFi after 5 seconds when the screen turns off , and automatically comes on when the screen turns on. The only thing I noticed that you also need to set is that you need to specify intervals to turn on the WiFi....so I set the max limit which will automatically turn on WiFi for 1 minute every 60 minutes...which isn't a big deal. Note this won't happen if you manually disable WiFi, which is exactly what I want for even more savings!

    You can also manually disable WiFi if you want as well which is really handy since I only use WiFi at home to surf.

    I also have the phone set to "GSM Only" to save battery when not on WiFi.

    Make sure to leave the WiFi sleep policy set to "Never" and then give "Green Power" a try, it seems to be working so far w/o the wake locks.
     
  15. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    Update:

    I decided to leave the phone on last night and left WiFi enabled. I also had the Mobile data set to "GSM Only". Battery seems to be working well.


    • stopped using phone yesterday at 9:30pm battery was at 90%
    • got up at 6:00am battery was at 80%
    • just checked with light usage and at 1:30pm battery is at 66%

    I think that is pretty darn good. Like I said I have the WiFi sleep policy set to "Never" and am using Green Power free version to switch on/off the WiFi when I'm at home and not using the device. Here's my settings for Green Power free:


    1. Manage WiFi - On
    2. Enforce WiFI - Off
    3. Manage Mobile Network - Off
    4. Screen Off Wireless Delay - 10s
    5. Wireless On Duration - 1min
    6. Wireless Off Duration - 60min
    7. Screen On Setting - On
    8. Power On Setting - On
    9. Notification - On
    10. Startup at Boot - On
     
  16. fldude99

    fldude99 Well-Known Member

    Joined:
    Oct 10, 2010
    Messages:
    872
    Likes Received:
    69
    I put my wifi setting back to turn off "when screen goes off" last night as well. I lost about 10% during the night. So it could be that a constant wireless "on" is not good for the battery.

    Question: Is that wifi setting on Green Power all the time or just at night? In any event, why would you have a 1 min on and 60 min off? Why not just have it go off when the screen is off?
     
  17. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    Its on all the time, except when you manually disable WiFi. The paid version has a night mode though. Maybe the paid version allows you to not put anyting in for the duration on/off

    You have to set something for the Wireless On Duration and
    Wireless Off Duration if you manage WiFi. Keep in mind if you shut off WiFi manually, Green Power won't use those settings.

    I don't see it as a big deal, but maybe a newer version will let you disable the on/off intervals. Give it a try but remember to set the WiFi sleep policy to never.
     
  18. opflame

    opflame Member This Topic's Starter

    Joined:
    Nov 20, 2010
    Messages:
    24
    Likes Received:
    0
    19.5hrs up-time and the battery is at 59%.
     
  19. adroid2.0

    adroid2.0 Member

    Joined:
    Nov 4, 2010
    Messages:
    10
    Likes Received:
    0
    I just started to have this problem a few nights ago. I always have my Wifi policy sleep set to NEVER and overnight would loose about maybe 7-10% max previously.

    Now with my phone asleep overnight its draining all the way from 100% to 15% left by morning. If I turn Wifi off at night the problem goes away!! I've had this phone for months and it just started to happen a few days ago. What is causing the Wifi to stay active and use up the battery?? Again I always had the Wifi set to sleep policy Never and did NOT have this problem. :confused:

    ..on captivate 2.1
    no new apps installed or running in background.
    only recently updated Google maps. GPS is off though.
     
  20. BookLover

    BookLover Well-Known Member

    Joined:
    Oct 11, 2010
    Messages:
    977
    Likes Received:
    114
    Some app is draining your battery at night. Especially if it didn't happen at first but now is. OR you have a weak wifi signal. Sounds like it may be constantly searching to lock onto your wifi signal. (Just guessing).

    Maybe you installed an app before this problem, but didn't actually start using the app until recently. Now that app is active and is using wifi all night, thus draining your battery.

    Maybe a weather app gone haywire?

    Something is using data while you're asleep or your wifi signal is weak.

    If you install Data Counter Widget, it'll give you a reading of wifi and mobile data used. It will show you Monthly, Weekly, and Daily use. The daily usage zeros out at midnight. So if you check the data in the morning and shows you massive amounts of data being transferred at night, it can help you narrow your search down to the app responsible. If low-no usage, then maybe you need to check out if you have a weak wifi signal where you sleep. Wifi Analyzer might help you with that.
     
  21. sting187d

    sting187d New Member

    Joined:
    Dec 20, 2010
    Messages:
    4
    Likes Received:
    0
    Hi, I just registered today so I can add my experience.

    I purchased the Samsung Capitvate(AT&T) in September and rooted it shortly after. Doing some brief research, I have read that wifi takes less energy to operate than 3G. It definitely held true for me.

    I was using wifi profile to never sleep and my battery life has been phenomenal... until recently. I was going 3 days before I had to charge the battery again. Now with wifi, my battery drains 75% in less than 6 hours. Battery Usage also showed cell standby 70%.

    Basically, the problem ALL started (for me) when AT&T pushed an OTA update to my phone at the end of November. It was very late. After the update, my battery has drained exponentially from before. Now I'm not even using wifi just to have batteries for the day. I get 0-1 bar reception on 3G, hence why I prefer wifi when I'm at home.

    I have been using Advance Task Killer. I don't have a lot of applications and removed the AT&T bloatware. Some back end process is draining my battery and I blame AT&T for that. Hopefully someone can find a conclusive answer to wake-lock and/or the battery issue.
     
  22. adroid2.0

    adroid2.0 Member

    Joined:
    Nov 4, 2010
    Messages:
    10
    Likes Received:
    0

    Thanks for reply. It actually does it during the day also was just pointing out during the night as that is really getting 0 use of the phone by me. Its not an app as last night I had Wifi off and my account on att reports no data usage at all last night, none at all. Even with my Wifi on there is no data transfer being detected by my router so its not an app. No weather apps. I'll check into Wifi signal thats a good point, however I'm in the next room and the router is a wireless N long range, my captivate shows the signal strength as excellent right now in settings by tapping on the wifi network name. I'm gonna keep looking into this and maybe I'll find the root cause. :cool:

    Its really a pain cause for the past few months wifi sleep has been set to never with no battery brain and now its a constant brain unless I shut off my wifi. Froyo for my Captivate cant some soon enough so I can start with a new OS install, or a working ROM of Gingerbread would be very yummy too.
     
  23. adroid2.0

    adroid2.0 Member

    Joined:
    Nov 4, 2010
    Messages:
    10
    Likes Received:
    0
    What does your Captivate show in Settings > About Phone when you have this update. In other words what version do you show?
    Don't you have to allow the update to install? They dont just push it to your phone do they
     
  24. sting187d

    sting187d New Member

    Joined:
    Dec 20, 2010
    Messages:
    4
    Likes Received:
    0
    Phone details: Firmware 2.1Update1
    Baseband: I897UCJH7
    Kernel: 2.6.29
    Build: ECLAIR.UCJH7

    I unrooted my phone prior to the update. Then I did a factory reset after the update finished. The update was released in September but AT&T only uses OTA update. So once they give you the option you have update at some point or else the data management process stays there. ATK couldn't stop it. My battery drain started after the update.
     
  25. adroid2.0

    adroid2.0 Member

    Joined:
    Nov 4, 2010
    Messages:
    10
    Likes Received:
    0
    Actually looks like you are on a newer baseband version then me and my build just shows eclair:

    firmware: 2.1-update1
    baseband: I897UCJF6
    kernel: 2.6.29
    build: ECLAIR

    Last night I left my phone sleeping with Wifi off and guess what, only 6% battery brain. Also in battery history Running is the highest with only 8.3% then screen with 7.3%. If I turn Wifi sleep to never Running jumps way up and Wifi stays On and also Running at the same %. Something is F up and keeping Wifi on and active when sleeping 100% of the time. Might just factory restore this bitch
     

Share This Page

Loading...