Bugs in firmware I5Support


  1. kam187

    kam187 Well-Known Member

    We should probably keep a list of the few latest firmwares so there's a quick reference for people. Post bugs in this thread, and if possible the coresponding thread dealing with the issue.

    - The wierd lock button thing is back. You press it and it doesnt always unlock. You have to press it again, then wait and hold it down again. It wasnt there in H7

    Advertisement
    :
  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    - weird drops when on calls at random intervals
  3. Shayko

    Shayko Well-Known Member

    - doesn't work properly with OpenGL. all 3D games are not playable.
    (worked on G8)
  4. kam187

    kam187 Well-Known Member

    - Sound dropout in the middle of a call, which comes back after a few seconds. Its not reception related. (Old bug since first firmware)
  5. z0mbi3

    z0mbi3 Well-Known Member

    Phone function seems to freeze, the device still works fine but calls will fail to connect and you can't recieve them either. Trying to reboot the phone part by cylcing it in and out of flight mode makes no difference, and just hangs grey once you've selected that option from the menu (the menu you get when you press and hold the power button). The device continues to operate otherwise as normal, so you'd have no inclination this has happened until you try to make the call.

    Only solution is to reboot the device entirely.

    Interestingly I have also had the above scenario where the call will fail to connect (that is the phone just beeps at you) but trying it again it works fine. This isn't signal related as the signal is not low when this occurs.

    Also suffered the same issues mentioned so far, except I'm not sure about the audio dropping in and out, as on the odd occurence I have had this it could possibly of been due to signal. I'm not dismissing it as a possibility though.
  6. Bozzy

    Bozzy Well-Known Member


    I second that its pissing me off.
  7. Bomberman

    Bomberman Well-Known Member

    OT possibly, but this is prevalent in the I4 firmware too :rolleyes:
  8. Shayko

    Shayko Well-Known Member

    - When receiving calls the ringtone plays a few seconds after the phone starts to vibrate, and sometimes not at all.
  9. kam187

    kam187 Well-Known Member

    The only firmware I saw it working properly was H7 (but I havnt tried H8). So did they fix it them break it again? :-/
  10. kam187

    kam187 Well-Known Member

    - Phone powers off. It doesnt reboot, its just shut down and off. I noticed this yesterday but thought maybe I had powered it off at some point and forgot to switch it back on. Today it was on a desk out of the case all day, and after about 4 hours it was off.
  11. ressu

    ressu Well-Known Member

    I'm thinking that there are 2 separate bugs at play here. Yesterday I reported the reboot bug to samsung (it's still present in I5) with instructions to reproduce it. Apparently it is hidden somewhere in the Location API... In any case, your bug sounds more like a power failure than software bug, mostly because the phone appears to reboot after a crash and power failure wouldn't really count as a crash.

    Of course this is just guesswork :)
  12. hollowroom

    hollowroom Member

    Just out of interest: What makes you trace it to the location API? Mine rebooted yesterday after listening to voicemails over the speaker. I listened to five voicemails then pressed the end call button, put the phone down and walked away. A couple of seconds later, I heard the Samsung start tune. It's the first time I have had a reboot for ages. Admittedly I'm not I5, I'm still H8, but I just wondered.
  13. ressu

    ressu Well-Known Member

    After the reports from other users that their problems have disappeared or at least become less frequent I started to think about why my phone was still constantly restarting. After a bit of tinkering, I figured out that I had locale installed and it kept polling my location once in a while. After disabling locale the reboot problem got significantly less frequent.

    Next logial step was to poke locale to poll the location more often and since locale updates its location every time you alter a profile, I started poking the profile. After a few iterations the phone restarted. After a while it was pretty easy to get the phone to reboot within a minute of starting to play with locale. The only thing I had set in locale was the location polling, so I'm blaming Location API ;)

    Sure enough, it could be somewhere else. It could be somewhere in various other APIs as well, but since I haven't had the time to create a proper test case app, I'm leaving it to Samsung to figure it out.
  14. z0mbi3

    z0mbi3 Well-Known Member

    Just had a call on my landline from the other half to tell me my mobile was going straight to voice mail again. Had to reboot it to get it work again :mad:
  15. ressu

    ressu Well-Known Member

    That is yet another bug. Unrelated to the other reboot bugs, i think it was described in some earlier post and if i remember correctly, there is even an app to poll that the GSM subsystem is actually online...

    I thought it was repaired already though.
  16. z0mbi3

    z0mbi3 Well-Known Member

    Woah I missed the polling app bit, got a link?
  17. ressu

    ressu Well-Known Member

  18. z0mbi3

    z0mbi3 Well-Known Member

  19. vit

    vit Member

    Not a bug but a question: did you notice any change in battery life with I5 version?
  20. kam187

    kam187 Well-Known Member

    I only just started removing the phone from the case and putting it on the desk (to get over the camera button problem), and now it drops to 50 to 60% pretty quick (battery widget, but the bar in the status bar looks like 90%), but then stays there for ageeeeeeeeeeeesssssss. Its been on 58% all day.
  21. hollowroom

    hollowroom Member

    Did a bit of investigative tinkering here and I think you're right about the location API. I have Locale installed too, and it does seem to happen after the phone figures out where it is (either with GSM masts or GPS) Hmm. Also: the losing the phone function issue has been around with my phone since I got it, and the "one ring and straight to voicemail" issue too. I'm on I5 now and they still happen, albeit less often.
  22. talldom

    talldom Member

    Upgraded to I5 and I'm still getting the dialpad lockout defect we reported in H6 (with the same fix working) I understand that this is not easily reproduced on all handsets, but there are at least 5 people in the dedicated thread reporting it.

    Battery life is still piss poor too, but I'm not expecting this to change...

    TallDom
  23. Rastaman-FB

    Rastaman-FB Well-Known Member

    as stated, i do not believe this issue is device software related. its happened to the same people on all versions of software and the people that dont have this bug have also been on the same software versions
  24. benzi

    benzi Member

    if you mean the lockout during out call where you are asked to press 1 or # etc' key - i had this problem but it was solved once i have changed "use touch feedback" (hope this is correct translation from hebrew menu...) to set it on and reboot.
  25. kam187

    kam187 Well-Known Member

    Hmm i have touch feedback on too - no problems here.

    Ok so i'm getting really fed up with this 'voice' black out for a second or two in calls. I'm in the same place most of the day with FULL reception, so i know its not that. I'm going to switch to 3G and hope it goes away, otherwise i'm about to throw this phone out of the window.

    EDIT: No problems in 3G so far. Todays a good test day, my phone wont stop ringing!
Loading...

Share This Page