Build.prop Performance Tweaks - Updated 04.14.2012


Last Updated:

  1. Whyzor

    Whyzor Well-Known Member

    Yeah that's fine, also note if it slows down or breaks other functions related to the 3G or wifi.

    Advertisement
  2. Chairshot215

    Chairshot215 Well-Known Member Developer


    Allot of these had been included in the 3g tweaks I have been testing and they seem to make a difference. I have been trying different values and have seen some big improvements in speed but unfortunately the values that make the most difference in speed also seem to brake synchronizing with Google or some other strange little quarky bugs.
    Whyzor likes this.
  3. Chairshot215

    Chairshot215 Well-Known Member Developer

    Love the screen name, was the name of a band I was in during high school. lol
  4. weddle

    weddle Well-Known Member

    ok so i just tried the ro.ril.hsxpa=5 line and this is what i got...

    before i did the tweak
    -from the "wifi settings" menu i turned on wifi and counted the time it took until it was connected.(5 times)
    it was 16, 13, 11, 10, and 12 seconds respectively.
    -3g speed before tweak according to speedtest.net:
    ping:433ms download:30kbps upload:78kbps server in ashburn, VA
    -wifi speed before tweak:
    ping:46ms download:3563kbps upload:775kbps server:ashburn, VA

    after i did the tweak
    wifi time to connect:
    9, 9, 10, 8, and 10 seconds respectively
    -3g speed after tweak (it switched servers for some reason...)
    ping:392 download:60kbps upload:146kbps server:frederick maryland
    -wifi speed:
    ping:87 down:2516kbps up:718kbps server: frederick maryland

    so it looks like my 3g is faster, but my wifi is slower. i dunno if the tweak changed the server or what, but it was different afterwards. i loaded a few pages in the browser and idk if it was my imagination or not, but they did seem to load very quickly
    aricblunk likes this.
  5. ziggy46

    ziggy46 Well-Known Member Developer

    Alot of these tweaks are gonna be added to me and Mobstergunz roms soon. Just gotta get more time away from school :(
  6. aricblunk

    aricblunk Well-Known Member

    Nice to see I wasn't imagining the faster wifi connect speed, though the servers do need to be held constant to get reliable data results. Interesting possible improvements, though.
  7. Whyzor

    Whyzor Well-Known Member

    I wouldn't call the 3G test conclusive, it only had 1 data sample, and it was with a different server. So that result could easily be due to VM's network flakiness. I would consider at least 5x2 tests with the same server in a short timespan to make a better judgement.

    There's a lot of placebo effects with these tweaks, I don't want to perpetuate them, so that's why I'm very cautious with any of these settings unless they demonstrate a clear improvement.
  8. Chairshot215

    Chairshot215 Well-Known Member Developer

    I also tried out the same value last night and the only thing I found noticeable is that it took a few minutes longer than normal for the color to change on the Wifi icon. Just hard to verify or measure these things. Don't know if it's just my area but 3G speed tests are all over the place and inconsistent regardless of any type of tweak. Also found lots of little bugs playing with these 3G tweaks. On more than one occasion I was about to post a set I thought made things undeniably faster but then found YouTube or Google sync had been broke. Increase in speed in that case probably do to no resources spent synchronizing and not the tweak.
  9. weddle

    weddle Well-Known Member

    ^^^^ I don't think I've tried absolutely everything but I did check all my syncing and YouTube and they both work. I haven't tried GPS yet and I'm on my way to work now. I guess the best way to test would be a side by side of the same phone, one tweaked one not. But even then that still leaves variables...
  10. Chairshot215

    Chairshot215 Well-Known Member Developer


    Agreed,

    For the most part I did not find bugs with the 3g tweaks using the most common values found around the web for the lines, just did not see any difference or slower speeds. I have been running into the bugs experimenting with values assoceated with the lines in an attempt at getting a noticeable difference using with the Triumph.
  11. aricblunk

    aricblunk Well-Known Member

    You're right, I jumped to conclusions too early in that post and have edited.

    On an unrelated note, my battery drained much more quickly today than it usually does, as I got home with only 32% battery when I usually have more than 70%+. I'm going to see if this keeps up, and if so, manipulate the HS[DUX]PA settings and see if one of those is causing it, or perhaps some other modification I did recently. Anyone else notice any real change in battery life after using any of these?
  12. millenium

    millenium Well-Known Member

    *NOTE* i use the Affiliated Networks for the cdma roaming mode, for me I get better 3g perfomance.

    Settings >>Wireless & Networks >>Mobile Networks >>System Select [HOME, AFFILIATED, AUTOMATIC] ive notice if i set it to automatic and i go to a bad service area [inner city] it takes me back to home network]
  13. weddle

    weddle Well-Known Member

    I didn't think to keep an eye on that today...ill note it tomorrow after I charge.
    I think it was a little lower than usual after work today, but I left wifi on for a while too when I usually don't. So that explains that part.
  14. Chairshot215

    Chairshot215 Well-Known Member Developer

    Have been using,

    ro.ril.hsxpa=5



    without any other tweaks for the past two days and although for the most part everything seemed to work ok except an extra minute or two connecting with Google servers I just looked at my phone and was in airplane mode. I turned off Airplane and all my radios turned on including Bluetooth and GPS. I had to reboot before I was able to turn them off without them immediately turning back on. Has anyone else who is testing run into this?
  15. weddle

    weddle Well-Known Member

    I tried that to see what happened and everything turned off fine for me after I turned airplane mode off. Everything turned back on normally and stays off when I turn it off
  16. millenium

    millenium Well-Known Member

    the format of the forum makes that space for some reason not me
  17. aricblunk

    aricblunk Well-Known Member

    Like weddle, I haven't experienced that particular issue with the tweak, and in fact my earlier battery concerns may have been due to irresponsible use of WiFi since my phone has been on battery for nearly 17 hours now today and it still has 55%, which is on par with pre-build.prop tweaking battery usage.

    Yeah, I've seen various vbulletin forums randomly add spaces in some posts in long lines of text without a space in them, seemingly completely at random and yet perfectly consistently in the same strings.
    AndroidSureDo likes this.
  18. Chairshot215

    Chairshot215 Well-Known Member Developer


    I noticed the same thing, if you just put up the numbers its fine but puts the spaces in the same exact spot every time when entering the complete line.

    My normal daily schedule is that I turn off Wi-Fi why at work if I’m not using the phone from like 7am - 6pm. usually have about 70% when I leave the office and will then let JD control Wi-Fi for the rest of the night. It will drain twice as fast doing this but I will have a good amount of juice left when it comes time to plug it into my computer and charge for the night without needing to charge at all during the day. With that said though I am running CM7 on my Kindle Fire (Best $200 I have ever spent by the way, the thing is sweet once either CM7, CM9 or Miui have been installed along with hidden volume slider) and tend to do more battery draining processes like games or video on the tablet. I have contacted the Juice Defender developer and have sent them a few logcat to see if anything can be done on their end to help with the will not sleep when JD turns off Wi-Fi bug and have been sent 2 beta versions for testing that unfortunately have not done the trick. At first I thought these beta versions had something to do with the Google Sync issues I have had as these versions have a nice feature that allows controlling the sync schedule for each Google app. So for example currents, contacts & Picasa can be set to sync only once every 24 hours and others that are used more often can be set any ware from always on, 15min, 1h or every five hours, I noticed a substantial increase in battery life adjusting these based on how often I actually use them. Otherwise I only allow apps to sync in general during a 5 minute window every 2 hours and 1minut window every half hour scheduled from 6PM to 11 and also anytime the device is active(Screen on). I’m getting way off topic but without Juice Defender installed I still had the issue. Otherwise regardless of what tweak has been applied why on CM7 reloaded I can’t say I have ever had a moment ware I said to myself Wow, look at how much power I have left, it seems to be around the same regardless. I did however spend 2 days on stock after finally changing my PRL with most of the tweaks from the op applied and was able to make it through the day without a charge which seemed very good compared to what I remember from the few weeks I spent on the stock Rom back in August. Used to have to keep my Triumph plugged into my work laptop all day or it would have otherwise been dead or very close around the end of my shift. So from what I can tell any difference made by applying these tweaks is more noticeable using stock then a Rom that already has very good performance like CM7 Reloaded.


    End Rant
  19. Chairshot215

    Chairshot215 Well-Known Member Developer

    Edit: Just wanted to bring up that after this issue I changed the value back to ro.ril.hsxpa=1 and after doing so my Triumph would reboot anytime I turned on Wifi, I did a system wipe and re-flashed the Rom and the reboots persisted. I then restored my last backup before messing with the line and all is working fine. With all this said I feel I should bring up that I have not wiped data since probably TickerGuys second or third beta build on my daily CM7. I probably should start clean for more accurate testing when it comes to CM7.
  20. AndroidSureDo

    AndroidSureDo Well-Known Member

    Okay my 3g broke but no worries its back as well as most the other mods
    but this time i left out the chunk if commands under "media
    streaming performance" any idea what i did wrong? Lots of codr...lots of toom
    for error i guess.

    I also stumbled upon the link below. I heard these phones are
    simular. My first guess is if it were this easy it would already be stickied but
    im hard pressed to hope for a smoother stock solution to tethering.
    I already have this on stock via mtu workaround any chance
    I can enable it natively from witgin the buildprop without being
    a coding genious? I already checked for this line and its non existent in triumph

    [Guide] How to enable the native tether option on the Huawei Ascend 2
  21. AndroidSureDo

    AndroidSureDo Well-Known Member

    I havnt had responsiveness this good since cyanogen. Awesome :)
  22. Chairshot215

    Chairshot215 Well-Known Member Developer

    sometimes depending on the order of the lines you will need to turn 3g on manually after rebooting. Not sure if it's the same issue but if so every thing will work okay after turning 3g on manually the first reboot after adding the lines.
    AndroidSureDo likes this.
  23. millenium

    millenium Well-Known Member

    ro.ril.hep=1 found this line while looking around the net for CDMA data tweaks, testing now
    Chairshot215 likes this.
  24. Chairshot215

    Chairshot215 Well-Known Member Developer

    Let me know what you find? At some point over the next few days I would like to clean up the OP and change a few values I have found to work out better then what was originally posted.
  25. millenium

    millenium Well-Known Member

    it seems to do nothing :mad:, testing speeds @ home where i get outstanding signal strength speeds stay the same, and @ work they still stay around 7Kb per second VM/Sprint CDMA network must not use this value

Share This Page