Buzzing in earpieceSupport


Last Updated:

  1. avatar1983

    avatar1983 Member This Topic's Starter

    Joined:
    Mar 2, 2010
    Messages:
    6
    Likes Received:
    0
    I've been lurking around for a while and have greatly appreciated information on here about flashing firmware on the i7500, so thanks for that.

    I do now have a weird problem with my Galaxy. A buzzing in the earpiece has appeared. More precisely, it's not a buzzing that happens all the time, but only when there is a sound - it's really distorted. I can hear it immediately when I make a call, it's really obvious on the ringing sounds. It makes it really hard to understand people.

    First I thought that it had to do with flashing to IK5 as it appeared around that time, but I have since tried both IK4 and JC6, and the issue persists.

    My guess is the speaker is broken / breaking, and it's a case for the service centre. Thoughts?

    Thanks in advance for any help.
     

    Advertisement
  2. buntoid

    buntoid Well-Known Member

    Joined:
    Nov 1, 2009
    Messages:
    48
    Likes Received:
    2
    Had exactly the same problem when I got my Galaxy - a buzzing noise from the earpiece when ringing and talking to someone, as you say "only when there is a sound" from the other end.

    I noticed it after a couple of days of use, so took it back to the o2 shop and they replaced it.
    Hadn't rooted the phone by then, so did not flash any newer firmware on it.
    I was on II4.
    The new phone was also on II4 and I haven't had any speaker problems with this one.

    Take it back and demand a new one.
     
  3. avatar1983

    avatar1983 Member This Topic's Starter

    Joined:
    Mar 2, 2010
    Messages:
    6
    Likes Received:
    0
    So I guess it's not a unheard of problem with the galaxy. Thanks for that, will see about getting it fixed / replaced.
     

Share This Page

Loading...