1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Calendar sync option missing


Last Updated:

  1. DXDX

    DXDX Member This Topic's Starter

    Joined:
    Nov 9, 2010
    Messages:
    6
    Likes Received:
    0
    Hi Everyone,

    I have a Droid X 2.2. I noticed that the option to sync with google calendar is missing on my phone. I have done quite a bit of research and tried what others have suggested. Here's what I've tried so far:

    - Clearing the "Calendar Storage" and then creating another google dummy account as many suggested.
    - Adding an event to the Calendar. I couldn't - it kept asking me to sync with a calendar account first. In the settings within the Calendar, when I checked Accounts, there was no accounts to add, neither could I add one.

    The weirdest thing I found is that I don't have the same phone options as many online posts say I should have. At the Home > Settings > Accounts & Synchronization, I have only Accounts but no Synchronization.

    Has anyone encountered this issue? Is there an alternative to this issue, like not using Google calendar but some other online calendar to sync?

    Thanks.
     

    Advertisement
  2. staffsmatt

    staffsmatt Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    153
    Likes Received:
    9
    Hi, what options do you get if you tap on accounts? Is Google listed? If it is what do you get if you tap on that?

    If not you may be better off posting in the Hardware specific forum (down the bottom of the forum list)...
     
  3. DXDX

    DXDX Member This Topic's Starter

    Joined:
    Nov 9, 2010
    Messages:
    6
    Likes Received:
    0

    Thanks for the follow up. If I tap on the Google accounts, I see "Sync Contacts" and "Sync Gmail" but not "Sync Calendar" - which is what led to my post here. I have done quite extensive research on this and tried the common suggestion with creating another dummy account.
     
  4. dawnierae

    dawnierae Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    1,260
    Likes Received:
    875
    And you've already got a Google calendar set up in your Google account?
     
  5. DXDX

    DXDX Member This Topic's Starter

    Joined:
    Nov 9, 2010
    Messages:
    6
    Likes Received:
    0
    Yes I do. I even have active appointments in Google calendar. It's really important I that I can sync my DX with Google calendar as I already have my work meetings sent to Google calendar.

    Sad thing is work is still using the stone age GroupWise for email. If they used an Exchange server, all my problems can be solved as I can use Motorola TouchDown to sync the calendar info and bypass Google altogether.
     
  6. Shine 52

    Shine 52 Well-Known Member

    Joined:
    Oct 26, 2010
    Messages:
    66
    Likes Received:
    7
    I have a similiar issue. I'm a fairly new Droid X user. When I bought my phone I established a new gmail account. My calender synchs and works fine. However, since then, I have created another gmail account and really want to synch my calender w/ this gmail account. I can't find that option anywhere similiar to DHDX's issue. Any help would be greatly appreciated.

    Absolutely love the phone btw.
     
  7. staffsmatt

    staffsmatt Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    153
    Likes Received:
    9
    Do you have a gmail.com user account?

    If you go into your google calendar settings (log into gmail then go to calendar and settings > Calendar settings) what are the settings in there. For me calendar owner is set to my email address....

    If these settings don't help you could try the following: Might be a bit annoying / long winded but it might be worth setting a brand new gmail account up and re-setting your phone to factory and then set it up with the new account (a right pain I know) but it would show if the prolem was your phone or your Google account...
     
  8. DXDX

    DXDX Member This Topic's Starter

    Joined:
    Nov 9, 2010
    Messages:
    6
    Likes Received:
    0
    I've got the same setting in Google calendar. I just performed a factory reset to no avail. This is SOOOOOO weird! :confused:
     
  9. staffsmatt

    staffsmatt Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    153
    Likes Received:
    9
    when you did the factory re-set did you use the same gmail account on set up?

    If you use a different account it may help to isolate where the problem lies....
     
  10. staffsmatt

    staffsmatt Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    153
    Likes Received:
    9
  11. DXDX

    DXDX Member This Topic's Starter

    Joined:
    Nov 9, 2010
    Messages:
    6
    Likes Received:
    0
    Yes, after the factory reset, I created a brand new gmail account and used that one as my default google account. And still having the same issue.
     
  12. staffsmatt

    staffsmatt Well-Known Member

    Joined:
    Jun 7, 2010
    Messages:
    153
    Likes Received:
    9
    Very strange! Have you tried adding the 2 accounts at the same time as per the link I posted?

    If you have then I'm out of ideas I'm afraid!

    If I were you my next step(s) would be to try and get help from the Droid X forums on this site (either message a moderator to get this one moved or link to this one so people can see what you've tried so far), your phones manufacterer, and google (probably in that order!)

    Sorry I can't be of more help.

    Matt
     
  13. DXDX

    DXDX Member This Topic's Starter

    Joined:
    Nov 9, 2010
    Messages:
    6
    Likes Received:
    0
    ***** RESOLUTION ******

    This is to everyone who reads this post and is having the same issue. If adding the second account does not work, an alternative will be to apply the Rubix 0.3 Blurry Mod. It did it for me! I think there's something unstable in the Froyo 2.2 architecture.

    **********************
     
  14. vijay11

    vijay11 New Member

    Joined:
    Nov 2, 2012
    Messages:
    1
    Likes Received:
    1
    if u have Super User access(rooted) then download GoogleCalendarSyncAdapter.apk and paste it in ur system/app dir by RootExplorer and permission root and change access.
     
    Millzez likes this.
  15. Millzez

    Millzez New Member

    Joined:
    Nov 7, 2012
    Messages:
    1
    Likes Received:
    0
    Been searching HOURS to get that fixed!!!!!... worked perfect for me! THANK yoU SO MUCH!
     

Share This Page

Loading...