1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Calendar Syncing Issues


Last Updated:

  1. sduncan343

    sduncan343 New Member This Topic's Starter

    Joined:
    Jun 8, 2009
    Messages:
    2
    Likes Received:
    0
    Hello,

    I just recently picked up an HTC Dream that was just released here in Canada.

    I have been loving it thus far, but I have noticed something a bit annoying with the calendar.

    The Calendar in Dream is receiving all of my events that enter online gmail calendar fine, but the events that I enter via the Dream don't appear in my online calendar. I checked the sync settings and it seems to be syncing properly. I have turned on and off syncing for the calendar and online still doesn't receive the events that I enter on the Dream. Is there something I am missing ? Anyone have any thoughts on how can have both the phone's calendar and the online calendar show the same events.

    I noticed on my phone calendar, the events I have entered online are green and register as my name, and the events I enter on the phone are blue. If that means anything.

    Thanks.
     

    Advertisement
  2. happyally

    happyally Active Member

    Joined:
    Jun 8, 2009
    Messages:
    36
    Likes Received:
    0
    I don't have my android device yet, but based on what i read, i might know the problem. if the events are showing up as different colours then that means you're likely storing it to different databases. do you have any other calendars synced to the phone like exchange? if so, it seems like your new events that you input on the phone are syncing to the other calendar other than google... i don't have the phone yet (still negotiating with Rogers) but once I do i'll post on how to default new entries to the google calendar...

    i hope that helps for now at least, maybe you can take it the rest of the way and figure out the solution? let me know
     
  3. sduncan343

    sduncan343 New Member This Topic's Starter

    Joined:
    Jun 8, 2009
    Messages:
    2
    Likes Received:
    0
    I don't think I have any other calendars synced to it, at least I haven't intentionally. Can you think of an easy way to check ?
     
  4. punkzanyj

    punkzanyj Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    1,012
    Likes Received:
    72
    If they're showing up as different colors, then yes, you have different calendars. Do you have more than one gmail account?

    Or, log into your google calendar on your PC/Mac, on the left you should see a box labeled "My calendars" and it will show all the calendars tied to your account by color coding. Your phone is attached to the blue account and you're logging in online to the green one.

    You can also check out your phone to see what's up.
    If you open the calendar
    use the menu button
    tap "more"
    tap "My Calendars"
    you should see a list of color coded calendars on your phone. The checkboxes determine which ones sync to your device, and which ones don't appear on your device.
     
  5. JayB

    JayB Member

    Joined:
    Jun 8, 2009
    Messages:
    7
    Likes Received:
    0
    When you are adding the events to your phone you must specify your gmail account as the 'Calendar' option. Its just below 'Description'. The options you'll see are 'My Calendar' (which is local to the phone only, not synced), 'Exchange', and 'yourname@gmail.com'. pick the 'yourname@gmail.com'.
     
  6. happyally

    happyally Active Member

    Joined:
    Jun 8, 2009
    Messages:
    36
    Likes Received:
    0
    I wish there was a way it could be defaulted to particular account, rather than just defaulting to the phone only
     
  7. punkzanyj

    punkzanyj Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    1,012
    Likes Received:
    72

    something's up with your gmail account. If you signed in with your gmail account when you set up your phone, then that should be the default phone calendar. Perhaps your mobile calendar setup wasn't done right on the PC Browser version of Google Calendar before you signed into your phone, thus it had no calendar to connect to and created one for the phone.

    My guess would be for you to do a factory reset on the phone, and BEFORE you sign into the phone with your google account, go on your PC, open up google calendar and DELETE the other calendar (after you've got your events on your primary calendar). Hopefully since everything is right on the Google server side, when you sign into your phone after the reset it will just directly connect and not create a separate phone calendar.
     
  8. badabing

    badabing Well-Known Member

    Joined:
    Jul 7, 2009
    Messages:
    47
    Likes Received:
    0
    I have the same "problem" with "My Calendar" being the default one even if my Google Calendar (online) was already setup before I started my phone for the first time.

    Any hack to change the default calendar ??
     
  9. KlaymenDK

    KlaymenDK Well-Known Member

    Joined:
    May 29, 2009
    Messages:
    1,217
    Likes Received:
    130
    Sorry for butting in, but are you saying that you can view several calendars on the phone, but everything that's created on the phone goes into one calendar? :eek:

    On my Palm I rely heavily on different 'layers' on my calendar (for work, personal, etc.) and I'd hate to not be able to take this habit with me to Android. :(
     
  10. mjschmidt

    mjschmidt Well-Known Member

    Joined:
    Jun 27, 2009
    Messages:
    1,272
    Likes Received:
    113
    Does anyone know if there is a way to _force_ the android calendar to sync when Background Syncing is turned off? I don't see anything in the options.

    I prefer having Background Sync turned off most of the time, and I'd like to be able to make the calendar sync when I want, like with my email.
     
  11. justjimjpc

    justjimjpc Premium Member VIP Member

    Joined:
    Nov 3, 2008
    Messages:
    10,543
    Likes Received:
    210
    Just go into Sync and check auto-sync ON touch each item individually if it doesn't update ... then uncheck auto-sync ... DONE !
     
  12. punkzanyj

    punkzanyj Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    1,012
    Likes Received:
    72
    Not quite. When you set up new events from the phone, there's a drop down that's defaulted to whatever calendar is your default. For most people this will be your default gmail/gcalendar calendar. If you want to save to a different calendar, you need to specify that when you're setting up the event. It's very easy, like I said, just a drop down.
     
  13. KlaymenDK

    KlaymenDK Well-Known Member

    Joined:
    May 29, 2009
    Messages:
    1,217
    Likes Received:
    130
    Excellent. For once a straight answer, even one that's entirely on par with what I'm used to from Palm. :)

    Thanks!
     

Share This Page

Loading...