Calibre doesn't see ErisGeneral


Last Updated:

  1. notaguru

    notaguru Well-Known Member This Topic's Starter

    Joined:
    Apr 22, 2010
    Messages:
    302
    Likes Received:
    7
    Calibre 0.7.13
    W XP SP2
    Firefox 3.6.8
    Android phone: HTC ERIS
    Android OS: 2.1
    ebook readers: Aldiko, Laputa, Tulip
    Eris is set up as a disk drive
    I've tried disabling AV, etc. with no difference

    An ebook can be "manually" moved from the PC to the correct folder in the Android's SD card, and Aldiko (for one) can find and read it on the device. Also, I can load an ebook into Calibre, and it can be read there.

    HOWEVER, when I right-click on the ebook and try to send it to my device, the SEND TO STORAGE CARD A (etc.) options are grayed out. I cannot find a way to get the book onto the phone's microSD card, and into my Library.

    Preferences > Advanced > Debugging device detection, I see a lot of "looking for" including Android, but no finding. The phone's SDcard is seen as a disk drive that CAN be accessed as such, so connectivity is ok.

    What part of this IQ test have I failed?

    ??
     

    Advertisement
  2. garrettehall

    garrettehall Member

    Joined:
    Apr 14, 2010
    Messages:
    6
    Likes Received:
    0
    I just use Caliber's built-in web server .

    In Calibre, Preferences > Content Server > Check "Run server automatically on startup".
    Make sure port 8080 is open in your firewall.
    Browse to http://your.computers.ip.address:8080/ to use the web interface. There you can browse, search, and sort your entire collection and download them in whichever format you want. On the browser's download screen, tap the completed download and Aldiko will automatically install the ebook to your bookshelf.

    If you know which book you want and its Calibre database number, you can directly download the epub by typing a URL into your browser's address bar like this: http://your.computers.ip.address:8080/get/epub/Title of The Book_CalibreDBNumber.epub
     
  3. notaguru

    notaguru Well-Known Member This Topic's Starter

    Joined:
    Apr 22, 2010
    Messages:
    302
    Likes Received:
    7


    This would be great, but with the Server running, my computer won't connect to (my IP):8080.

    Annoying.
     
  4. garrettehall

    garrettehall Member

    Joined:
    Apr 14, 2010
    Messages:
    6
    Likes Received:
    0
    You browse there on your phone, not your PC.
     
  5. notaguru

    notaguru Well-Known Member This Topic's Starter

    Joined:
    Apr 22, 2010
    Messages:
    302
    Likes Received:
    7
    Thanks. Should have known that.
    But I'm still getting "web page not available" - it's entered correctly, AV and firewall are OFF, but...
     
  6. garrettehall

    garrettehall Member

    Joined:
    Apr 14, 2010
    Messages:
    6
    Likes Received:
    0
    Weird.

    Check the port number for the content server in your Calibre preferences. It might be something other than 8080. I don't remember if that is default or if I changed mine to that.

    Double check that you are using your current IP address as well. They tend to change on you at the most inconvenient times.

    Also... Calibre is actually running on your PC while you try to access it, right?
     
  7. notaguru

    notaguru Well-Known Member This Topic's Starter

    Joined:
    Apr 22, 2010
    Messages:
    302
    Likes Received:
    7
    Thanks...
    Still no-go with Calibre.

    I've been pulling books from the net and material from our business operations, editing/optimizing in MSWord, saving as .txt, then using an online converter to produce epubs, which are then manually stored on my SD card.

    It works.
    It takes too much time.
     
  8. Podivin

    Podivin VIP Member VIP Member

    Joined:
    Nov 29, 2009
    Messages:
    3,679
    Likes Received:
    881
    I use the 'save to disk' function of Calibre and save the file to the drive that the Eris has been assigned. Doing it that way seems to work just fine.
     

Share This Page

Loading...