Caller ID/SMS Issues?


Last Updated:

  1. brucehvn

    brucehvn New Member This Topic's Starter

    Joined:
    Nov 8, 2009
    Messages:
    3
    Likes Received:
    0
    My phone has caller id blocking on for outgoing calls. For my friends and family that I want to see my number, I store their contacts with a *82 prefix (i.e. *821112223333). I've never had a problem sending SMS messages to any of those contacts before, but it seems with the Droid, I cannot get the default messaging app to send any text messages to my contacts with the *82.

    I installed Handcent and when I tried to send an SMS, it said "No valid recipient specified". It allowed me to edit the number manually and remove the *82 after which the message sent fine. So that's my workaround for now, but I think these apps should be smart enough to strip that common prefix before trying to send an SMS. Even my previous dumbphones could handle that ok.

    Anyone else run into this issue?
     

    Advertisement
  2. NewDroidGuy

    NewDroidGuy Member

    Joined:
    Nov 7, 2009
    Messages:
    16
    Likes Received:
    1
    I know as a former Verizon Tech Support Coord, that any * numbers will not send, because they are being transmitted just like that for sms, which will fail most def, we would usually tell our customers to have 2 entries, have one for sms and the other for unblocking your number....
     
  3. brucehvn

    brucehvn New Member This Topic's Starter

    Joined:
    Nov 8, 2009
    Messages:
    3
    Likes Received:
    0
    Well, I tried adding a second number without the *82. This works for the first SMS I send to the person, but only from Handcent. When I try to compose a new message in the standard messaging app, it will only allow me to choose the number with the *82. From Handcent, I can send the first SMS ok, but if the person replies to me and I try to reply back, it tells me "No valid recipient specified" again, so it seems to have reverted back to the *82 number. I think these messaging apps just need an option to say "Strip caller id prefixes from number" and that would fix everything.
     
  4. brucehvn

    brucehvn New Member This Topic's Starter

    Joined:
    Nov 8, 2009
    Messages:
    3
    Likes Received:
    0
    My previous dumbphones must have been smart enough to strip these prefixes off before sending SMS messages because I never had a problem with it. The phone is smart enough to match up an incoming caller id with my contacts even with the *82, so it seems SMS apps could be smart about it as well.
     

Share This Page

Loading...