Camera app crashes with too many apps


Last Updated:

  1. wvufan

    wvufan Active Member This Topic's Starter

    Joined:
    Jun 7, 2010
    Messages:
    29
    Likes Received:
    2
    Got the Evo (first android phone for me) and promptly started installing apps. At some point, my camera stopped working. When launching the camera app, the screen would go black for a second, then back to home screen.

    Installed the OTA update (also had the security error on SD card), then installed apps again. Same problem after so many apps installed. I don't know the app limit, but it's not out of internal storage. If I uninstall enough apps, camera works again. All other apps worked normally throughout.

    Any ideas?

    Thanks!
     

    Advertisement
  2. ScorpDX

    ScorpDX Well-Known Member

    Joined:
    Feb 7, 2010
    Messages:
    1,642
    Likes Received:
    375
    How many apps do you have when it works and doesn't work?
     
  3. wvufan

    wvufan Active Member This Topic's Starter

    Joined:
    Jun 7, 2010
    Messages:
    29
    Likes Received:
    2
    I didn't count the exact number, but I had probably installed around 20-30 apps. I can't imagine that's too many, since I'm sure there are folks with many more apps installed. It could be the specific apps. I did confirm that at one point, the camera worked, then after installing about 10 games and not even running any, the camera stopped working. After removing several games the camera started working again. When it was not working, reboots did not fix it, and I did not have to reboot between not working and working, just uninstall a few apps.
     
  4. ScorpDX

    ScorpDX Well-Known Member

    Joined:
    Feb 7, 2010
    Messages:
    1,642
    Likes Received:
    375
    Just wondered. There was an ongoing problem with the Hero's having major issues when hitting 70 apps. Not sure anyone ever figured out a real solution other than to stay under 70 apps. I have right at 40 on my EVO now and don't have any trouble with it at all, camera included.
     
  5. tech411

    tech411 Active Member

    Joined:
    Apr 5, 2010
    Messages:
    25
    Likes Received:
    0
    My camera is crashing also when launching from the camera icon, but if I launch Qik or Fring first, then after that launching from the camera icon works.
     
  6. marctronixx

    marctronixx Moderator Moderator

    Joined:
    Oct 12, 2009
    Messages:
    5,699
    Likes Received:
    3,503
    are you guys who are having camera issues rooted /custom ROM'ed?

    im experiencing zero issues and i have probably at least 20 apps on board. no rom , not rooted.
     
  7. tech411

    tech411 Active Member

    Joined:
    Apr 5, 2010
    Messages:
    25
    Likes Received:
    0
    Mine is factory stock.
     
  8. BlackDynamite

    BlackDynamite Well-Known Member

    Joined:
    May 6, 2010
    Messages:
    899
    Likes Received:
    221
    I had this issue when mine was stock (with the first OTA installed), but rooting it and flashing a custom ROM corrected it.
     
  9. iamtybaby

    iamtybaby Banned

    Joined:
    Jun 27, 2010
    Messages:
    77
    Likes Received:
    7
    Advanced Tasked Killer
     
  10. tech411

    tech411 Active Member

    Joined:
    Apr 5, 2010
    Messages:
    25
    Likes Received:
    0
    I did a battery pull and left it out for 15 minutes and ever since then the camera has worked fine.
     
  11. aznmode

    aznmode Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    424
    Likes Received:
    38
    I too just use advanced task killer to end all task which fixes this camera issue although not a permanent fix but it does the job.
     
  12. Shift.Evolve

    Shift.Evolve Active Member

    Joined:
    Jul 1, 2010
    Messages:
    30
    Likes Received:
    17
    That works for me too. I have 87 apps on the stock rom. On a fresh boot the camera app wont open so I have to use ATK to close stuff then it works. Kinda annoying but whatever, I rarely reboot my phone.
     

Share This Page

Loading...