Camera app non functional


Last Updated:

  1. sega dude

    sega dude Well-Known Member This Topic's Starter

    Joined:
    Oct 17, 2011
    Messages:
    69
    Likes Received:
    3
    Whilst taking a video with my Triumph, it decided to go into a boot loop (I didn't wait for it to fully start up.) I had to pull the battery and when I restarted, my camera app was non-functional. The camera previews fine, but I can't take pictures or switch to video. Whenever I try to do anything, I get an error that says "Activity Camera (in Application Camera) is not responding." I tried clearing the data (there was no cache to clear) but it still does the same thing. I also tried deleting the video, thinking it was corrupted, but it still doesn't work. I am running MTDEV-CM7 2012-12-28. Other camera apps, such as HDR camera, still take pictures fine. What happened? Am I going to have to do a factory reset and reflash?
     

    Advertisement
  2. dsmryder

    dsmryder Well-Known Member Contributor

    Joined:
    May 28, 2011
    Messages:
    2,418
    Likes Received:
    502
    You can try pulling the camera app from the ROM and see what happens
     
  3. sega dude

    sega dude Well-Known Member This Topic's Starter

    Joined:
    Oct 17, 2011
    Messages:
    69
    Likes Received:
    3
    What do you mean?
     
  4. dsmryder

    dsmryder Well-Known Member Contributor

    Joined:
    May 28, 2011
    Messages:
    2,418
    Likes Received:
    502
    Go into the ROM's .zip and grab the camera app under /system/app/

    Before you do that, clear the dalvik cache.
     
  5. faisal sajjad

    faisal sajjad New Member

    Joined:
    Feb 1, 2013
    Messages:
    1
    Likes Received:
    0
    Hi everyone
    can anyone guide me regarding my s2 camera????
    actually em using galaxy s2.its frnt and back camera stopped working.when i on the camera it hangs the mobile for some time with black screen appearing and then gives the error of "application failed".
    i am using android "ginger bread(2.3.3)".can anyone tell me is this hardware or software issue???
    and how can i solve it???
     
  6. sega dude

    sega dude Well-Known Member This Topic's Starter

    Joined:
    Oct 17, 2011
    Messages:
    69
    Likes Received:
    3
    Unfortunately, wiping the dalvik cache didn't work. You want me to replace the camera apk on the phone with the one from the ROM?
     
  7. dsmryder

    dsmryder Well-Known Member Contributor

    Joined:
    May 28, 2011
    Messages:
    2,418
    Likes Received:
    502
    Yeah, it's easier than reflashing the whole ROM and if the problem is in the .apk, then moving a fresh copy might fix it.

    The next couple of steps would envlolve making a nandroid backup and flashing. Maybe to another ROM to test for a hardware issue.
     
  8. bob-st

    bob-st Well-Known Member

    Joined:
    Dec 30, 2010
    Messages:
    372
    Likes Received:
    95

    I would suggest that you ask this question in the S2 forum.
     
  9. rebel69ization

    rebel69ization Well-Known Member

    Joined:
    Jun 23, 2012
    Messages:
    193
    Likes Received:
    27
    Agree
     

Share This Page

Loading...