Camera app not workingSupport


Last Updated:

  1. herminio67

    herminio67 Member This Topic's Starter

    Joined:
    Oct 31, 2012
    Messages:
    11
    Likes Received:
    1
    Well I tried to take a picture today and tried to open the camera app but it stays in black screen and force closes. I am rooted with Megatron 6.0.4 rom don't know what could be causing this problem any answers would be appreciated thank you.
     

    Advertisement
  2. niteNarmor

    niteNarmor Well-Known Member Contributor

    Joined:
    Jun 28, 2012
    Messages:
    804
    Likes Received:
    242
    This is a known issue in the MegaTron ROM. It deals with the quick panel settings and the flashlight.

    To get the camera to work:

    1. Open Quickpanel app.
    2. Select widgets.
    3. Scroll down to Toggle Flashlight.
    4. If checked, uncheck it.

    Your camera app will now work. If you really need a flashlight on your phone then download an app from the play store.
     
    gdesigner1 and herminio67 like this.
  3. gdesigner1

    gdesigner1 Member

    Joined:
    Jan 17, 2012
    Messages:
    13
    Likes Received:
    1
    Oh my god, I have been trying to fix this for a month. You just saved my ass. Thank you very much sir.
     
    niteNarmor likes this.
  4. niteNarmor

    niteNarmor Well-Known Member Contributor

    Joined:
    Jun 28, 2012
    Messages:
    804
    Likes Received:
    242
    Not a problem. Also if for some reason the above solution does not work, download camera ics from play store. Keep both apps on hand. I know it is weird to have the same type of app but while the flashlight works with the original app, you can use the camera ics for your camera needs.

    I have done this with much success. No issues with camera nor flashlight.
     
  5. dmcjr22

    dmcjr22 Well-Known Member

    Joined:
    Jul 13, 2012
    Messages:
    818
    Likes Received:
    309
    one solution i found for the camera flashlight is i use notification toggle its just like quick panel for megatron allows you to have flashlight toggle and use camera
     

Share This Page

Loading...