Camera Error and Flash Light App not workingSupport


  1. craley1

    craley1 Active Member

    A couple weeks ago my camera stopped working. When starting the camera app on CM 10.1.3 I get a message that says "Camera Error. Can't connect to the camera" and then the app closes. Thinking this was a software issue, I reflashed CM 10.1.3 stable and 10.1.3 nightly 20130922 with no luck. I then flashed a stock v7 ROM with no luck. I am on CM 10.1.3 nightly 20131007 with no working camera.

    Just last night I tried to the use the flashlight (Torch) app and was having similar problems. The app will initialize but when I tap the lightbulb, the app closes and I get a "Unfortunately, Torch has stopped" message.

    I've done a little research and found issues with the camera app and the gallery app. My gallery app seems to work fine. I do have two gallery apps though (gallery4.apk and gallery2.apk). Also, I do not see a camera.apk however I am unsure if that exists or if the camera works under another process.

    I am about to order a replacement camera module on eBay for $10 but I was wondering if anyone else has had any issues like this. I haven't found anyone with the same problem that wasn't solved by reflashing (or flashing a stock ROM). Any help here is appreciated.

    Advertisement
  2. Neph81

    Neph81 Well-Known Member

    I've had that happen once and it was from another camera app not releasing control over the camera once the app had closed. If you rebooted and had the same issue immediately, I would try doing a nandroid backup, then wipe your phone and start fresh. If you still have the same issue, I'd say it's your phone dieing. If the issue goes away, you have some app not letting go of the camera. You can then restore your nandroid and figure out which app may be doing it.
    craley1 likes this.
  3. craley1

    craley1 Active Member

    Thanks for the reply. There is only one other app that uses the camera and I just FCed it, cleared cache and uninstalled. No luck. Also, my wife has the same app and her camera works fine.

    I was a little afraid this phone might be on the way out after I noticed the camera module and LED module are separate. I was hoping they were physically connected but it looks like fixing one may not fix the other.
  4. Neph81

    Neph81 Well-Known Member

    That's not exactly what I suggested, but if you want to spend the money, go for it. If you haven't done a full reset, you'll never know if it was the hardware or the software.
  5. craley1

    craley1 Active Member

    I'm not sure what you mean by a "full reset." I've already wiped data, flashed stock and had no luck. Each time I put on CM or stock described in the original post, I wiped the phone in CWM recovery (6.0.1.1, I think).

    Is there another wipe process?
  6. Yoinx

    Yoinx Well-Known Member


    Actually... no.. what you said you did was "just FCed it, cleared cache and uninstalled"

    In your OP, you state that you wiped and reinstalled.

    Typically, to do a real full wipe... You should try CAB flashing. it restores files that aren't modified by wiping/flashing anything through recovery. Before I call the hardware bad, I'd cab flash.
    craley1 likes this.
  7. Neph81

    Neph81 Well-Known Member

    That is useful information. I don't assume people wipe between ROM flashes even though they should. If you wiped between each one, then you're probably at a hardware issue.

    If you have the ability, I would take Yoinx suggestion and do a .cab flash. At this point it shouldn't hurt and always has the chance of fixing it.
  8. craley1

    craley1 Active Member

    Thanks for the advice. However, I'm stumped on downloading the .cab. I went to your rootzwiki post for flashing LG signed firmware, Neph, and when I try the link to 8.10, I get an access denied response. Is there something I need to do to download from the LG site?
  9. Neph81

    Neph81 Well-Known Member

    No, they broke the download links again. If you're just flashing V8, you can use the "recovery phone" option in the LG tool. If you want to use the .cab flash method, here is the correct link to the V8 cab.

    http://csmgdl.lgmobile.com/dn/downl...3210987654321/VS920ZV8_10.S8_10.P58017.R5.cab
    craley1 likes this.
  10. craley1

    craley1 Active Member

    So after all that work, it appears my camera is busted. I went through the whole .cab full wipe process and tried to pull up the camera but got the same error message. Thanks Neph and Yoinx for the support.
  11. bones420la

    bones420la Well-Known Member

    Did you get the phone new from Verizon? If so you should be able to send it in for another one if its serious hardware failure. Just make sure its 100% stock before sending it in.
    Its worth a try. Save a few dollars. And the replacement will come in before you have to send out the broken one

Share This Page