1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

camera flash not working.....General


Last Updated:

  1. Dennis384

    Dennis384 Member This Topic's Starter

    Joined:
    Jul 12, 2012
    Messages:
    11
    Likes Received:
    0
    hey everyone...i was messing around with my camera and i noticed that my flash does not work when set to "on" or "auto". i have a app called power toggles and the flash works when i turn it on through the power toggles widget. so i know it does work. i am rooted and have rom toolbox. i have only deleted the bloatware that we know is safe to do. yesterday i tried to install google now through the steps posted by diego1593 but could not complete the process bcause of me deleting bloatware. i merged the files i needed to with /system/, but after realizing i couldnt go any further, i deleted ONLY the new files i had merged into "system", basically reversing the process like it never happened. i didnt mess with anything else. i wonder what the problem is? should i uninstall the app "power toggles"? or did rom toolbox disable it somehow? any help would be greatly appreciated..thanks in advance!
     

    Advertisement
  2. Diego1593

    Diego1593 Well-Known Member

    Joined:
    Jun 3, 2012
    Messages:
    491
    Likes Received:
    46


    That happened to me and google now doesnt messes with your flash and it the power toggels flash does mess it up because i used to have a flashflight app and everytime i used it my camera flash wouldnt function till i delete the app so you can delete power toggles and re do google now if you want :)
     
  3. unnamedny

    unnamedny Well-Known Member

    Joined:
    Dec 26, 2010
    Messages:
    1,093
    Likes Received:
    162
    Have you tried different camera apps?
     
  4. Dennis384

    Dennis384 Member This Topic's Starter

    Joined:
    Jul 12, 2012
    Messages:
    11
    Likes Received:
    0
    so i deleted the app "power toggle" and still no camera flash uggghh
     
  5. Dennis384

    Dennis384 Member This Topic's Starter

    Joined:
    Jul 12, 2012
    Messages:
    11
    Likes Received:
    0
    no i havent but i will rt now hopefully it works!
     
  6. Dennis384

    Dennis384 Member This Topic's Starter

    Joined:
    Jul 12, 2012
    Messages:
    11
    Likes Received:
    0
    so i tried two different camera apps and the flash is still not working...no bueno
     
  7. Dennis384

    Dennis384 Member This Topic's Starter

    Joined:
    Jul 12, 2012
    Messages:
    11
    Likes Received:
    0
    im wondering....if i cant fix it should i re-install the os through the steps in the unbrick guide? or can i unroot it and go back to the metro store and try to get a new phone? i know i technically cant return it because i am not a new customer, but i got the phone only 4 days ago and if i channel the italian side of me i always get what i want lol if anyone can give me advice that would be greatly appreciated. thanks!
     
  8. Diego1593

    Diego1593 Well-Known Member

    Joined:
    Jun 3, 2012
    Messages:
    491
    Likes Received:
    46
    The unbrick guide looks like the only option left if you dont wanna return it
     
  9. Dennis384

    Dennis384 Member This Topic's Starter

    Joined:
    Jul 12, 2012
    Messages:
    11
    Likes Received:
    0
    ok thanks for the response
     
  10. ninjasinabag

    ninjasinabag Well-Known Member

    Joined:
    Jun 21, 2012
    Messages:
    537
    Likes Received:
    164
    If your phone is rooted, why not use the pimp my ROM app and see if the flash tweaks will help?
     
  11. Dennis384

    Dennis384 Member This Topic's Starter

    Joined:
    Jul 12, 2012
    Messages:
    11
    Likes Received:
    0
    ok i tried that and it didnt help...who knows maybe it was screwed up out of the box...if i cant figure it ill just reinstall the os. thanks for the input
     
  12. chip hazzard

    chip hazzard Active Member

    Joined:
    Oct 4, 2012
    Messages:
    35
    Likes Received:
    1
    Happend to me to but when i unbricked to download new firmware then re rooted it came back. .....
    NOTE when i originally rooted i lossed camera. The screen was just black until i deleted that hello world file from chains that i accidentally opened. hth
     
  13. doctor90250

    doctor90250 Member

    Joined:
    Dec 24, 2011
    Messages:
    9
    Likes Received:
    0
    I have the same issue. LG motion, non rooted.
    Suddenly, my cameras, flash and flashlight apps won't work,and any application that uses these will force close, as will any hardware diagnostic apps as soon as I select the camera or the flash led. I've run virus scans, gone through all my apps and uninstalled all the one that the permissions say take pictures, & videos and control flash, (downloaded apps, not system ). I just can't figure this one out.
     

Share This Page

Loading...