Camera is draining battery!General


Last Updated:

  1. ekyle

    ekyle Well-Known Member This Topic's Starter

    Joined:
    Jan 5, 2010
    Messages:
    1,773
    Likes Received:
    108
    I've noticed that for the past few days I have been experiencing lower than normal battery performance with my Eris. I checked the battery sonsumption and it says that it is the camera that is doing it. OK. So I force kill everything (reinstalled a task killer) and opened the camera and closed it again. I always exit an app with the back button, not the home button. Still the problem persists. I noticed that while it was charging last night that the camera was using 100% of my battery. So my conclusion is that whenever I charge my Eris the camera runs in the background even after I take it off of the charger. Is anyone having this problem?
     

    Advertisement
  2. cableguynoe

    cableguynoe Well-Known Member

    Joined:
    Mar 30, 2010
    Messages:
    2,030
    Likes Received:
    264
    You are not going to get a true reading of anything while the battery is charging.
    That's why it says 100%... because the battery is full. So 100% of whatever has been drained from the battery, which is almost nothing, was done by the camera.
     
  3. ekyle

    ekyle Well-Known Member This Topic's Starter

    Joined:
    Jan 5, 2010
    Messages:
    1,773
    Likes Received:
    108
    Understandable, but it stays over 90% after i unplug it unless I kill everything. It didn't do this before, only in the last few days and I am definitely seeing a decrease in battery performance.
     
  4. TTupa

    TTupa Well-Known Member

    Joined:
    Apr 30, 2010
    Messages:
    69
    Likes Received:
    9
    That battery reading (Settings > About Phone > Battery > Battery Use) is useless. Several applications will distort its reading including: Maps/GPS, Camera, and the 50% without signal bug. Basically, if you use Google Maps/Navigation or the camera, that status area will show those apps as using 90+% of your battery when they're really not.

    Use the application called "Spare Parts" from the market if you want a true reading.
     
  5. ekyle

    ekyle Well-Known Member This Topic's Starter

    Joined:
    Jan 5, 2010
    Messages:
    1,773
    Likes Received:
    108
    Spare parts gives me similar readings. And I'm not using the camera prior to when I check it.
     
  6. TTupa

    TTupa Well-Known Member

    Joined:
    Apr 30, 2010
    Messages:
    69
    Likes Received:
    9
    This is not a normal problem, so if it's easily reproducible bring the phone to a Verizon store and show them. They should be able to swap it out for you. I've seen the strange battery use in the settings area, but Spare Parts has always shown what I perceive to be the correct use (without huge camera or maps usage.)
     
  7. WineJones

    WineJones Well-Known Member

    Joined:
    Apr 19, 2010
    Messages:
    55
    Likes Received:
    3
    I've seen this with my camera application/battery consumption a couple times. It doesn't happen every time I use the camera, nor does it happen every time I charge the phone.

    The few times that I've seen the camera get "stuck on" I've had to power down the phone to turn it off. That has always cleared it up for me.
     
  8. BCEagle

    BCEagle Active Member

    Joined:
    Dec 29, 2009
    Messages:
    28
    Likes Received:
    1
    I was actually about to create the exact same thread last night, but my battery ended up dying completely. When I charged it and turned it back on, the camera was no longer using 90% of the battery, it wasn't even on the usage screen (which is correct, because I hadnt used the camera in days). I had thought originally that it was due to Camera360, but an uninstall of that didnt help. Not sure what it was, but powering off and turning back on seems to have fixed it.
     
  9. ekyle

    ekyle Well-Known Member This Topic's Starter

    Joined:
    Jan 5, 2010
    Messages:
    1,773
    Likes Received:
    108
    I'm wondering if it was an update to an app I use. I talked to VZ tech support yesterday and they suggested that I do a hard reset on the phone. I was hoping to avoid having to reinstall all my apps. :( If that is what it takes though I'll try it. Also I hesitate to get it swapped out due to all the silent bug issues, etc. that people are having. My Eris is not doing that... yet. Thank you for the suggestions everyone :)
     
  10. Bswartz95

    Bswartz95 Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    1,101
    Likes Received:
    41
    I've had my camera "stick" a few times and drain the battery. Google Maps has done the same a couple times. I just turn the phone off and back on, then it's all good again (after I do the airplane mode trick for the 50% bug).
     
  11. ekyle

    ekyle Well-Known Member This Topic's Starter

    Joined:
    Jan 5, 2010
    Messages:
    1,773
    Likes Received:
    108
    Yea turning it off seems like a temp fix.

    Sent from my Eris using Tapatalk
     

Share This Page

Loading...