Camera stopped working after a drop? >>FIXED<<Tips


Last Updated:

  1. sharxbyte

    sharxbyte Member This Topic's Starter

    Joined:
    Dec 30, 2010
    Messages:
    7
    Likes Received:
    3
    So, About 6 months ago, My camera stopped working after I dropped the Evo. It would just go to a black screen, and either freeze, or crash to desktop. I recently spent $20 on a new camera module, and once installed, the problem was fixed. Earlier this week, I dropped the Evo again, and it took a hard fall, and the camera stopped working. This morning, I noticed that the camera module was *****ing. The lens would click open and closed repeatedly. I pulled the battery and restarted it, and the same thing happened. This got me thinking that it could be a loos connection. The module is held to the motherboard by a thin sheet metal clasp that must be popped off to replace the camera. Apparently what happened when I dropped it (at least this time, probably last time) was that the module was shaken loose of its setting, JUST enough to stop working. To test my theory, I popped off the outer lens face and pushed firmly on all four sides, and sure enough, it popped back into place. When I turned it on it worked again. Hopefully this helps someone else who has had this happen.

    Now (I think) I have an extra camera module that I payed $20 for... O well.
     

    Advertisement
    runningdevil, 9to5cynic and Rxpert83 like this.
  2. saywhatt

    saywhatt Well-Known Member

    Joined:
    Aug 16, 2011
    Messages:
    193
    Likes Received:
    21
    get it checked on the service center bro :O that sounds some serious hardware problems

    -if this helped, hit thanks! :D
     
  3. tube517

    tube517 Well-Known Member Contributor

    Joined:
    Jun 7, 2010
    Messages:
    2,891
    Likes Received:
    1,238
    That is a common issue w/the EVO camera. Usually if you push it back in, it fixes it. Good to hear it's working again.
     
  4. gbuffum

    gbuffum New Member

    Joined:
    Dec 27, 2010
    Messages:
    2
    Likes Received:
    0
    Pushing the camera in definitely worked for me. Thanks for sharing this great info! :)
     
  5. runningdevil

    runningdevil New Member

    Joined:
    Sep 8, 2012
    Messages:
    1
    Likes Received:
    0
    Thank you! That totally worked!!!
     

Share This Page

Loading...