Can anyone get this to mount on a Mac (OSX))Support


  1. rainierez

    rainierez Well-Known Member

    I have tried and tried. Got it to mount once with USB debugging turned on. but that was just once and I haven't gotten it to work again. anyone have any ideas?

    Advertisement
  2. johnhazelwood

    johnhazelwood Member

    I can't get it to mount either. I got it to mount once, but it said it wasn't readable.
  3. dman27

    dman27 New Member

    Yes,

    Make sure phone is unplugged from USB cable

    Go to home screen, hit menu key and select Settings (can also access from applications tab)

    Click on applications> select Development > and turn on USB DEBUGGING. Click OK to the message.

    Connect phone to USB cable and plug it into the MAC USB. Pull down the drop down the notification menu at the top and select USB connected> then select Mount.

    Drive or drives will show up in Finder under MAC.

    Long post to say "TURN ON USB DEBUGGING UNDER SETTINGS>APPLICATIONS>DEVELOPMENT" , THEN SELECT USB CONNECTED AND CLICK MOUNT.
  4. rainierez

    rainierez Well-Known Member

    I have done this. and that is how it mounted once. but since then these steps NEVER work.
  5. SeriousBizznass

    SeriousBizznass Well-Known Member

    Make SURE YOU EJECT IT OR YOU WON'T BE ABLE TO REMOUNT ON A MAC.

    I found that out the hard way, I had to reboot the laptop to get it to mount again.
  6. macshield

    macshield Active Member

    Have you tried rebooting your system and phone? That might get it to mount again.
  7. tcv

    tcv Well-Known Member

    I think there were some people that had problems with mounting on macs after applying certain roms. If you do use any roms, I'd check out the respective threads here and on xda for an easy fix.
  8. johnhazelwood

    johnhazelwood Member

    Oddly enough I plugged mine in, after applying Mac OS updates, and I see the phone.
  9. rainierez

    rainierez Well-Known Member

    OK well maybe a reboot will help. I'll try that out tonight and report back.
  10. kylec

    kylec Active Member

    This is what i do and it works everytime on my mac. Go to settings>applications>usb settings> and select MASS STORAGE. Then go back to applications>development> and select usb debugging. At this point connect the usb to your mac directly to the back or a main usb port on your mac. Then on your phone mount your device. You should see the icon pop up on your mac. Make sure you eject the item on on your mac when finished, then unmount from your phone. This should solve all your problems. If you can't remount at a later time just repeat the process. I hope this is helpful.
  11. NewDruid

    NewDruid New Member

    I've had challenges with USB cables. The stock cable supplied with the phone is the only one that I can get to work. Other cables that I have, one from a BlackBerry and another from AT&T, the Zero I believe, don't work. They appear to allow for charging but not mounting. Wonder it the pin placement is different between cables.
  12. kylec

    kylec Active Member

    Maybe the pin placement is different. When i use my buddy's ally phone charger, my usb device shows up in the status bar and my phone thinks it's a computer mount. Ofcourse i don't mount the phone to the outlet. Lol. Anyway the phone doesn't recognize the other cable. Come to mention it i think it does the same thing when i use my car charger. Oh well. You could prob google it and see the pin layout.
  13. pricej636

    pricej636 Member

    I havent had a problem yet mounting to my mac. When I turn on mass storage on the phone I see both SD cards mounted, the internal and external. For that matter I am able to transfer files over bluetooth as well.
  14. ComradeQuestion

    ComradeQuestion Well-Known Member

    +1 to the fact you have to turn on the debugging or it wont see it then click mount and it works great. im running 10.6.4 on an imac no issues.
  15. magnusalpha

    magnusalpha New Member

    The normal mount procedure used to work without fail, but now it nor Debug mode causes the phone to appear in the Mac finder. The android version is stock Froyo (I did a reinstall a few months back after mucking around with some ROMS), and Mac OS X is standard 10.7.1.

    Normal procedure is plugging the phone into my USB port, selecting Mass Storage mode, and a couple seconds later it mounts and appears in Finder. In spite of a few people saying it in the thread, Debug mode is not required unless there's something funky going on...the method I described has worked since I got the phone in December.

    I did try mounting in Debug mode after it stopped mounting normally the other day, and it did mount for me, but now neither method works. I'm hoping someone has a suggestion. I'm a bit baffled since nothing was altered on either end of the equation, but it magically stopped working.
Loading...

Share This Page