Can I delete my ALL my contacts and start over?Support


  1. LizRobitaille

    LizRobitaille New Member

    Can I delete my ALL my contacts and start over?

    Advertisement
  2. chibucks

    chibucks Well-Known Member

    Yup. I did this since google synched everything. I edited which contacts to synch, deleted all contacts and synched again.
  3. LincKraker

    LincKraker Well-Known Member

    i found the easiest thing to do to fix your contacts is to edit them on the computer. since they sync with google, you can edit you gmail contacts which are the same ones on your phone. edit your contacts in gmail and sync them.
  4. agent0014

    agent0014 Well-Known Member

    Does anyone have any opinions on best practices when you're also syncing to an exchange server? I feel like my contacts are quite bloated, and am unsure what to do about it.

    I have all my contacts in exchange, coming from WinMo... but for the last year or so I had Exchange and google contacts syncing, in case something ever happened regarding my employment, so I'd still have all my contacts. Now of course I have duplicate contacts in my phone due to the same contacts from both Exchange and Google. I know that I can filter the default to show only Exchange contacts, but that's not a total solution for me since I feel like I still have a disconnect regarding which contact caller ID is going to recognize, etc.


    I feel like I have the following options, none of which are really perfect:

    - Stop syncing Gmail and Exchange and delete all my Exchange contacts from Gmail. This would easily take care of dupes, but doesn't satisfy my concerns about having a copy of all my exchange contacts in case I no longer have access to my work account for whatever reason.

    - Stop syncing as above, but remove all contacts from Outlook/Exchange.
    This might be a better solution since my contacts will be maintained purely via the cloud, but honestly Outlook's PIM interface is MUCH more mature than Google's, and I'd severely miss the comprehensive and easy-to-use data entry and organization that Outlook provides (jeesh, who ever thought I'd be saying that about a Microsoft product??)



    I guess what I REALLY need is a "don't sync (google OR exchange) contacts if it is a perfect match to a contact already synced from (google OR exchange, whichever wasn't picked for the first one)." That would really solve everything. Any ideas? I don't know how many users out there are using exchange and find themselves in the same quandary as me.

    Hmm... maybe I should have started a new thread for this, although it's quite on topic for this one. Maybe I will if I don't get any responses :)
  5. chibucks

    chibucks Well-Known Member

    had the same problem - duplicate contacts in both exchange (outlook) and google contacts... to make matters worse, i synched exchange with last name first, so it got pretty messy. i ended up:

    1) backing up all my contacts from exchange,
    2) deleting all my contacts from exchange
    3) manually synching exchange (to remove all those contacts)

    and leaving as that... i'm no longer synching with exchange contacts and strictly sticking to google... (in your case, if your google and exchange are synching, doesn't that help?)
  6. agent0014

    agent0014 Well-Known Member

    yeah you're right... somehow I didn't think of that, or thought of it and dismissed it for the wrong reasons. That probably would be my best bet... I'd retain constant backup of my exchange contacts, but wouldn't have so many dupes because I'd ONLY see google contacts on my phone.

    I'm sure I'll find out myself soon enough, but does anyone know if google retains contact pictures from an exchange sync? Not that it matters too much I suppose, since I'm using an app to sync my facebook photos to my contacts through the phone itself.
  7. dmz

    dmz Member

    I figured out how to delete all my contacts - I had duplicates of everything due to my phone syncing with two sources containing the same data. I went to Settings / Applications / Manage Applications / Contact Storage and clicked "Clear Data." Then I went to Settings / Data Synchronization and removed the check next to Contacts, then rechecked it to force a new sync with my online Google account. Now I have one entry for each contact and no duplicates.
    Billamero and kjjb0204 like this.
  8. srikumarvg

    srikumarvg New Member

    After reading all these, I found the following worked best.
    I exported all contacts to SD card. Then took the .vcf file out/edited to my liking.

    My problem was the google sync was creating duplicates.

    Downloaded Contact Remover version 4 (using Market). This is a beauty - it shows a check-mark against each contact and you can either select subset or select all (button provided). Then delete button wipes out all selected. All contacts are deleted.

    Then I removed the google contact sync (unchecked it).

    Then I imported contacts from the modified file.

    Now I only have single set of contacts.
    arunkott likes this.
  9. kjjb0204

    kjjb0204 Well-Known Member

    I'm very new to Android and I thought this might benefit one or two other new users, so I'm quoting and bumping thread. I've had this issue since last week. There should be one big button that says "sync everything" because that's what I did and ended up with 3 of every contact from vzw ba, gmail and EAS. Searched a bunch and this method above worked perfectly and didn't require any factory reset. Now I only see my EAS contacts and that's what I want. So, thanks dmz!
  10. dmz

    dmz Member

    I am glad my post helped you, kjjb0204. By the way, I just searched for "Samsung Moment erase contacts" and found my own old post! I had forgotten how to do it - imagine my surprise when I saw that I wrote it.

    Anyway, I wanted to append my earlier post and let everyone know that, if you don't see "Contact Storage" listed under "Manage Applications," tap "Menu" and then "Filter" and then click "All." For some reason, my phone is now set to default to only show apps I have downloaded in "Manage Applications."

    :)
    Dawn

Share This Page