Can I go back to 4.1?Support

Last Updated:

  1. PortNerd

    PortNerd Active Member

    Last night, my Nexus 7 updated itself to 4.2. After playing around with it for a day, I've decided that I'd like, if possible, to go back to how it was before.

    Is this possible? If so, how would I do it?

  2. CYNICALifornia

    CYNICALifornia Well-Known Member

    Root and flash 4.1.2.

    Root instructions can be found here.

    Once rooted you can use the rootkit to flash 4.1.2 and unroot.

    It's not as bad as it sounds and you have a forum full of friendly people willing to help if something goes wrong.
    Rxpert83 and PortNerd like this.
  3. PortNerd

    PortNerd Active Member

    Well, I've been wanting to root anyway so that I can use stickmount.

  4. CYNICALifornia

    CYNICALifornia Well-Known Member

    In that case don't unroot. Be sure to take advantage of TWRP and Titanium backup to backup your tab.
  5. Bexy

    Bexy Well-Known Member

    Also wanting to do the same, downgrade from 4.2 back to 4.1.2 as I've found a few apps, ones that I use quite a bit during the day don't work yet on 4.2 :(.

    So I've been round and round in circles trying to find out how to do it and I'm still confused :(.

    I've downloaded the rootkit, first issue I have is, it doesn't have the Nexus 7 with Android 4.2 listed, so do I select Nexus 7 4.1.2?

    After that, I've worked out how to root it but, do I need to unlock it as well/before rooting?

    Lastly (for now :p), I've downloaded 4.1.2 from Google but, where do I select the file to flash?

    The guide for the app leans more towards rooting/unlocking the Nexus 7 and I couldn't find any mention of selecting the firmware to flash.

    I've gone round in circles and now just have a headache lol.
  6. Pappy35

    Pappy35 Well-Known Member

    I'm going to to do the same mainly because of removal of USB storage. I think I saw instructions here somewhere how to prevent automatic updates.
  7. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    You don't have to select 4.2 for the root kit. Just select other
  8. CYNICALifornia

    CYNICALifornia Well-Known Member

    No worries.

    Under the device selection choose the last option, Android *.*.* Any Build.

    Unlock it

    Root it with the custom recovery box checked

    Now, if you want to return to 4.1.2 stock without root click the appropriate button on the root toolkit. Don't forget to relock, if it bothers you.

    To continue rooted:

    On the bottom left side is a button to LAUNCH advanced options, click that

    Then on the top right click 'Flash Zip' and follow the instructions.

    You want the stock 4.1.2 rooted ROM, not just the update from 4.1.1.

    Any other questions should be asked in the root forum.

    Good luck!
    Bexy likes this.
  9. PortNerd

    PortNerd Active Member

  10. PortNerd

    PortNerd Active Member

    After a few false starts, I got my device rooted. (Yay me!)

    Now, I'm stuck in the "flash rom" step.

    First, I downloaded nakasi-jzo54k-factory-973f190e.tgz from google, then I unzipped it.

    I then used the Root Toolkit, Advanced utilities, Boot/Flash image, Boot (temporary) tool and pointed it to the file bootloader-grouper-3.41.img.

    My nexus rebooted into fastboot mode, and it says "booting downloaded image".

    It's said that for almost half an hour now, and I'm getting nervous.

    Should I wait longer? Would I be risking breaking something if I just unplugged it and rebooted the nexus?
  11. CYNICALifornia

    CYNICALifornia Well-Known Member

    Eek. I'm no expert but I'd pull the cable.

    If your N7 doesn't boot, don't panic. Try the flash to stock with the softbrick option selected. If that doesn't work there's really smart folks on here to help.

    Either way, to avoid not getting the right image, I'd flash stock and unroot to 4.1.2. Then, if you wanted, root from there.

    Let us know how it goes.
  12. PortNerd

    PortNerd Active Member

    Well, that seems to be working so far. I flashed it back to 4.1.2, and now my backup is being restored.

    Although, now that I think about it, doesn't it need to be rooted to restore an apps + data backup? I didn't re-root before starting the recovery.

    I guess we'll see what happens. :)
  13. carracerz14

    carracerz14 Well-Known Member

    Pulling the cable is a good way to permanently brick your device. What idiotic advice
  14. CYNICALifornia

    CYNICALifornia Well-Known Member

    What would you have advised?
  15. carracerz14

    carracerz14 Well-Known Member

    Wait it out, or use adb, but don't unplug it. A failed flash by unplugging it is horrible, especially if it's the boot loader that's a sure fire way to brick it and not be able to flash anything.

    To the poster with problems, are you in the boot loader still? If so you can try adb to flash it. I am strongly against the use of toolkits
  16. CYNICALifornia

    CYNICALifornia Well-Known Member

    Thanks for the correction. Was just trying to help. Glad things didn't go bad.
    carracerz14 likes this.
  17. wtherrell

    wtherrell Well-Known Member

    Toolkits are great when they work. They are a pretty good starter kit to the world of unlocking, rooting, roming. When I use ADB it's like copying a recipe or letter to the exact degree at first but I am able to start getting an idea of what is really going on. Had it not been for rootkit I would probably still be stuck in the mundane and boring world of stock Verizon. (Ugh, what a thought.)
    No it's (cable pull) exactly what I had to do on my gnex. It went all night stuck like that and in the morning had completely gone dead. Had to charge several hours with original cable to bring it back. Next time it did it I pulled the cable and started over, it worked the next time--no brick. Maybe I was just lucky. :)
  18. Nateonator

    Nateonator Well-Known Member

    You people do realize that all of the apps we love/need will soon work with 4.2,if not already... Every time there is an update it's mad hysteria and doom and gloom. I suppose we'll never learn.
  19. carracerz14

    carracerz14 Well-Known Member

    I agree, I used wugs on my GNEX. It was okay.. More trouble than it was worth though. I used adb for my 7 and it was SO much easier for whatever reason.

    If it is truly frozen, you might get away with a cable pull. It might have not even started the flashing process.. I would try closing the tool kit and then reopening it and trying to flash it again and if it freezes again just say screw it and look up how to do it adb there's a great video from android Central on YouTube showing you step by step how to.

    But as a general rule, any time you are flashing, especially if it's the boot loader and you pull the cable, with either by accident or on purpose and it causes it to fail you may be screwed. If the bootloader does truly get corrupted then there will be no way to boot into it to fix it..
  20. PortNerd

    PortNerd Active Member

    That's nice, but not really germane nor helpful to my situation . I've been meaning to learn how to root my device so that I can use stickmount for months. This gave me a good excuse.


    I rooted it, flashed it back to 4.12, and then re-loaded the backup I made first. It worked just like I wanted, and now I have stickmount working.

    So, now that I've dipped my toes into the wonderful world of rooting, what else can I do with it?
  21. jmiked

    jmiked Active Member

    If you're referring to the USB Debug mode, it's still there, you just have to enable it.
  22. Bexy

    Bexy Well-Known Member

    Thank you sooo much :D. Worked perfectly. Downgraded mine then my partners :). Ironically I then had to return mine to the store as I found a fault with the screen and my new one had 4.1.1 on it lol. My partner is very happy and loving her Nexus again. Her most used app just wouldn't work on 4.2.
  23. kristinalaska

    kristinalaska New Member

    I am a newbie at this, so please forgive my dumb questions. I did successfully root my new Nexus 7 Wi-Fi 3G tablet, with the 4.1.2 system on it. I used Chainfire's CF-Auto-Root procedures, since I couldn't seem to get the Wug Nevus Root toolkit v1.6.2 to work for me, no matter how many times I tried. I was happy when it finally worked perfectly with the CF-Auto-Root.

    But then I agreed to the update prompts to 4.2, and as others have mentioned, my tablet is now unrooted again. I nervously was ready to follow the same directions again, and suddenly my tablet went black and stayed that way. All I had done was unplug from charging, power off, both went well, and then tried to press the power and volume keys together as I did before, and nothing! I was afraid I had a brick on my hands! But I read somewhere about holding the power key down for 30 seconds, and voila! The tablet powered up again.

    Unfortunately, even with USB debugging turned on, the power-volume key action does still not work. Can someone offer me suggestions? I am kicking myself again and again for allowing the OTA update.

    PLEASE HELP! At least I have my tablet again, but apparently unrooted so I can't use the OTG cable for external drives! Now I'm more nervous than ever!

    Thanks in advance for any advice, or even calming kind words!

Share This Page