Can I turn off notifications in the top bar but keep the message tone?General


  1. discostu73

    discostu73 Member

    This may be an S2 problem, it may be an Android problem, I'm not entirely sure.
    Is there a way I can switch off the visible SMS notification in the top bar of the screen but still get a message sound when one arrives?
    So sound only, with no onscreen notification? You know, like the old days? ;)
    I can only find the option in message settings to turn off notifications, but that also turns off the message tone which I don't want to happen.
    Is there a setting I've missed, or an app that'll do it?

    Advertisement
  2. matttye

    matttye Well-Known Member

    Have you actually tried that option in the messages app? It seems like it should still play a sound even when you untick notifications, as that option only relates to "display message notifications in status bar"

    If it stops sounds too, that's a bug.
  3. discostu73

    discostu73 Member

    In message>settings I can untick the option for 'Notifications' (display message notifications in status bar). But when I do that it also removes the 'Select ringtone' option underneath, which results in no status bar message, no message tone and no vibration. So it's all or nothing.
    A girl at work just got an S2 as well and was the one who brought it up as she has the same problem.
    It doesn't seem beyond the realms of possibility to be achievable, but I just cannot work out how.
    I doubt it's a bug if two separate handsets are doing it.
  4. matttye

    matttye Well-Known Member

    It's a software bug, or the option needs to be re-described. The way it has been worded makes it sound like that option only applies to statusbar notifications when it clearly applies to notifications as a whole.

    It doesn't look like you can achieve it using the default messages app so you might want to install one from the market. I use Go SMS Pro but that can't do it either. You could try ChompSMS or Handcent, both of which are good apps, but off the top of my head I'm not sure if either of them can do this.
  5. discostu73

    discostu73 Member

    In messaging settings, with status bar notifications switched ON I get this:

    [​IMG]

    But when I switch it OFF, it also ghosts out the 'select ringtone', which in turn switches the sound off too.

    [​IMG]

    It doesn't make sense! Is it too much to ask to get a message tone when a new text arrives, without everyone seeing who and what it is as a result of the status bar being active?
  6. Riche101

    Riche101 VIP Member VIP Member


    Just use a better msg app Like Handcent etc then yo will be able to do it
  7. johnb7

    johnb7 New Member

    Hi,

    Did you ever find a solution? For the record, I completely understand why you'd want to do this and I'm having the same problem. It's really frustrating. You either have everyone see your messages, or miss your messages because there's no tone. I'd appreciate any feedback.

    Thanks.
  8. Remeniz

    Remeniz Well-Known Member

    I run ADW launcher and have my notification bar hidden from the home screen. If I want to see it I either pull it down, as if it was actually there, or flick upwards to enable/hide it.

    All these features you can set in ADW.
  9. seatexeo

    seatexeo Member

    I apologise for this re-issue seeing as i am a new member,but i have searched high and low for this answer all weekend,your msgs are displayed on the taskbar but no msg alert ringtone,untick the display notifications in taskbar and the 'select ringtone' ghosts out.This only started a week ago,i have uninstalled twitter,whatsapp,viber as they are all 'notifications' but to no avail. i have had the phone seen Sept 12.Anybody have any idea ????????????

Share This Page