can i use any 64gb microsd card?General


Last Updated:

  1. JohnB47

    JohnB47 Well-Known Member

    There I was thinking I had this all clear in my head and now I'm confused all over again.

    James, your recent posts seems to contradict what Szadzik has said in reply to me - that the card you purchased should work 'as is' in your tab.

    So perhaps I should ask the question again, as clear as I can make it:

    If I buy a 64GB microsdhc or 64Gb microsdxc card and plug it directly in a galaxy note 10.1, will it be recognised and work correctly without any formatting or playing around (on the tab itself or on a seperate PC)?

    Szadzik has said 'yes' but your experience suggests 'no'. The fact that you're having to play around with formatting using a PC and card reader is a distraction - the 64Gb card should either work in the tab straight off or it shouldn't - which is it?

    Thanks for any help.

    Advertisement
  2. james_uk

    james_uk Well-Known Member

    my experience up to now is, these 64gb cards do not work straight out the box, i tried both in the 10.1 before i even tried them in my laptop, both were not readable in the 10.1 and did not show when i went to settings > storage.

    i have tried 2 cards, the sandisk 64gb ultra sdxc and the same one but says its made for android devices.
  3. Szadzik

    Szadzik Well-Known Member

    It should work on the Note 10.1 ok, unless you use an incompatible card reader to format it and make it a 32GB card.

    I did not touch my card and i nthe Note 10.1 it worked just fine as it was straight out of the blister. Then I tried it on my laptop and it was causing problems so I reformatted it to FAT32 and it has been working great since.

    The only downside with FAT32 is that you cannot put files larger than 2GB, if I remember correctly, onto it, but I am not planning on watching full HD movies on a 10" screen anyway.
  4. james_uk

    james_uk Well-Known Member

    It seems strange that different people seem to be having differences when trying to do the same thing.

    I have tried both my cards straight out the box and neither have worked, my unit simply showed a notification at the bottom with both saying can be safely removed and when i went to storage neither showed as being in the unit (both showed as mount card) which when i said yes it would say blank card or unknown format.
  5. Szadzik

    Szadzik Well-Known Member

    Maybe your Note is broken then, who knows. Myine came exFAT bought from Amazon.de and worked just fine.
  6. james_uk

    james_uk Well-Known Member

    well, i have an 8gb microsd card which i use in my samsung galaxy s2, i put that in my note 10.1 and it shows fine. :(
  7. Loren

    Loren Well-Known Member

    I got the same Sandisk 64 GB card that I posted in the link to above.
    It did not work out of the box (card as it were).

    I formatted it in my old phone - a Samsung Captivate running Gingerbread. It formatted fine and the Note 10.1 could read it after that.

    I also formatted in Windows to exFAT - again it worked fine.

    I was lucky enough to get the firmware upgrade that now allows formatting in the Note 10.1 - I tried that and that worked fine too.

    So it DOES work.

    [​IMG]
    JohnB47 likes this.
  8. JohnB47

    JohnB47 Well-Known Member

    Thanks for clearing that up.

    So, if you have the latest software for the tab, you can put one of these 64Gb cards in it and then use the tab to format the card.

    If that doesn't work, there's a problem with the card or you don't have the latest software for the tab.

    I hope that's correct.

    Thanks all.
  9. Loren

    Loren Well-Known Member

    That is correct.
    As I recall before the firmware upgrade it did not even offer to format the 64 GB card.
    After the update that option shows up
    [​IMG]
    JohnB47 likes this.
  10. JohnB47

    JohnB47 Well-Known Member

    Excellent. Thanks.
  11. james_uk

    james_uk Well-Known Member

    i must have the correct version then as when my 10.1 has reconised the card, but only as 32gb and not 64gb i have had the option to format.
  12. JohnB47

    JohnB47 Well-Known Member

    So, James, did you format the card? Reading through your posts suggests you still have a problem. Did you try formatting and it didn't work?

    Or perhaps the old and new software releases both offer a format option but it only works on 64Gb cards using the latest software release?

    Let us know how you get on.
  13. james_uk

    james_uk Well-Known Member

    well i have just bought a sdxc reader as my current reader was old and didn't support sdxc, i am in the middle of doing a full format with sdformatter 3.1, i will let you know how it goes, i think it formats the card in exfat format.
  14. JohnB47

    JohnB47 Well-Known Member

    Yes but my question is, did you make sure you had the latest software for the tablet and then try formatting the card while plugged into it? Surely it should work - no need for card readers or worrying about what format it uses (as per Lorens post)?
  15. james_uk

    james_uk Well-Known Member

    i still seem to be having some issues, i am on android 4.0.4, as far as i know that is the latest version isn't it?

    i have tried formatting my card in different ways, exfat, fat32, using guiformat and sdformatter 3.1 and my unit keeps showing 'mount' in storage, and in the bottom right i get a msg saying you can safely remove card.
  16. Loren

    Loren Well-Known Member

    Find someone with a newer phone to format it for you.
    ExFAT is only correct format if you want use the whole 64 GB (formats to 59 GB).
  17. JohnB47

    JohnB47 Well-Known Member

    Or maybe, Loren, you could quote all of the firmware details from your tab and James can check if he has the latest that should allow him to format his card in the tab?
  18. james_uk

    james_uk Well-Known Member

    Is it possible i may have actually broken my card by originally formatting it in a non sdxc card reader?
  19. Szadzik

    Szadzik Well-Known Member

    Highly unlikely. Make sure, however, that when you format it again with the new reader, you format it to 64GB, GUIFOmrat has an option somewhere.
  20. Loren

    Loren Well-Known Member

    He likely has a different model in the UK.

    My model GT-N8013
    My (firmware) Build Number is IMMD76D.N8013UEALH2
    My update came via Kies.
  21. james_uk

    james_uk Well-Known Member

    mine is:

    model GT-N8010
    fw build no IMM76D.N8010XXALGC
  22. JohnB47

    JohnB47 Well-Known Member

    I don't have a tab 10.1 yet (waiting for a grey/black version from Amazon.co.uk or John Lewis) so I'm not sure if this is the latest build. So James, did you actually download a later version of software after buying your tab? If not, why not go through the process for doing that on the tab (or using kies, whatever). If you already have the latest ICS verson, you'll be told I'm sure.

    I've just read the manual that I downloaded - it suggests going to 'Settings', then 'About Device', then 'Software Update' then 'Update'.

    Edit: I've tried searching the internet for the latest version of ICS - you'd think that would be readily available but I can't find anything. All the 'hits' my search produces are old news about ICS release. Anyone know where to get that sort of info?
  23. james_uk

    james_uk Well-Known Member

    I have tried doing s software update, it tells me mine is the latest, I have not updated it anytime, what is on mine is what it came with.
  24. JohnB47

    JohnB47 Well-Known Member

    Fair enough, although I would have thought that a lot of units being shipped might still have the 'old' software and would only get updated by the user downloading it.

    So I wonder why you're having such a problem. Seems very odd. I suppose you could have a second dogey card???

    I've just gone back to one of your posts, where you said:

    "i exchanged that card for basically the same one, but it said made for android on it.

    I put that straight into my unit when i opened it and that said the same thing on my unit, can now safely remove card, and when i went to settings > storage, there was no sign of a card, it just said mount card, and if i did this, it would say preparing card then a little after say i can safely remove it again and still show nothing.

    i have now put this card back on my laptop and formatted it as fat32 ......."

    So it doesn't seem that you initially tried formatting the 64Gb card in the tab and instead put it in your PC and formatted it there. Could that be the problem? Can't figure out why, but maybe??
  25. Loren

    Loren Well-Known Member

    Samsung pulled the update - without stating why.
    Why don't you open a ticket with Samsung.

Share This Page