Can Not Install Drivers / Win 7 64bitSupport


Last Updated:

  1. BillS22

    BillS22 New Member This Topic's Starter

    Joined:
    Nov 27, 2010
    Messages:
    4
    Likes Received:
    0
    I have a Captivate. Can't install the USB drivers in Win 7 / 64bit.

    I have tried the Samsung USB drivers, Kies minni, and the Galaxy S drivers.
    None work.

    help :confused:
     

    Advertisement
  2. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Joined:
    Jan 19, 2010
    Messages:
    22,479
    Likes Received:
    9,225
    Welcome to the forums, BillS.

    I've moved your question to the Captivate Support sub-forum for you.

    Please give some detail as to what error messages you're getting, and the method(s) you've tried unsuccessfully so far.

    That will help Captivate users who've installed the USB drivers to zero in on your problem. ;)
     
  3. BillS22

    BillS22 New Member This Topic's Starter

    Joined:
    Nov 27, 2010
    Messages:
    4
    Likes Received:
    0
    I get two problems.

    1. With Kies - Windows Device Manager lists the Captivate installed under USB Devices, but it won't work with any app. And I get an incomplete device install message, yet, Device Manager shows a clean install.

    2. at other times the Microsoft driver takes over and is listed as the "Best Driver for the Device" but the device is not listed in Device Manager.
     
  4. bolts2

    bolts2 Member

    Joined:
    Oct 18, 2010
    Messages:
    18
    Likes Received:
    1
    Regarding problem number 1: When I got my Captivate about 6 weeks ago I was having the same problem with Windows 7/64 bit. I saw on another thread somewhere in this forum that you couldn't plug in to your front panel USB connector on your desktop computer, and that you instead need to use one on the back. Sounds dumb, I know, but when I did that everything worked. Give it a shot.
     
    purespin likes this.
  5. kcau

    kcau Active Member

    Joined:
    Nov 11, 2010
    Messages:
    42
    Likes Received:
    0
    I am using Vista 64bit but had a similar issue.

    I was so pissed off with Kies last weekend i uninstalled it .... but that appears to either delete or corrupt the Captivate stand alone driver. I had no success trying to update/replace the driver from the device manager window.

    I had to go to the windows program install/uninstall window and uninstall Kies and the Samsung driver from there. Then reinstall just the phones drivers.

    FYI ..... itunes seems to conflict with Kies, as pointed out by others in this Forum .... i was never able to see the phone in Kies until i uninstalled iTunes.

    KC
     
  6. purespin

    purespin New Member

    Joined:
    Dec 15, 2010
    Messages:
    2
    Likes Received:
    0
    Wow, that really solved my problem!!! It does sound dumb but it worked!
    Thank you, Bolts2!!!
     

Share This Page

Loading...