Can someone help me with LGNPST?


  1. Cbelflower321

    Cbelflower321 Well-Known Member

    When I turn on LGNPST and plug in my phone, none of the information of my phone shows up. the model is unknown and the s/w version is ms690zv4. The version, file name, and compiled date are all blank.

    Advertisement
  2. Darnell0216

    Darnell0216 Well-Known Member

    - Did you turn on the phone's USB Debugging in Menu -> Settings -> Applications -> Development?
    - Did you drag the MS690.dll file onto reggie.exe?
  3. Cbelflower321

    Cbelflower321 Well-Known Member

    Yes I've done both of those things, but none of the information shows up.
  4. TechSys

    TechSys Well-Known Member

    Did you get the skin.dll worked out?

    Get out of LGNPST. Plug phone into computer. Go to menu > settings > applications > development. Make sure there is a green check mark on USB debugging.

    Load LGNPST. It "should" find the phone now.
  5. Cbelflower321

    Cbelflower321 Well-Known Member

    Yes I resolved the skin.DLL issue. I have had my phone in USB debugging while trying to use lgnpst, but ill try what you said.
  6. Darnell0216

    Darnell0216 Well-Known Member

    This should be what the root folder of C:\LG Electronics\LGNPST\ looks like:
    Code (Text):
    1.  components 1.0
    2.  Components 2.0
    3.  Components 3.0
    4.  Components 4.0
    5.  Components 5.0
    6.  Help_General_Lab
    7.  image
    8.  Model
    9.     HardLock.dll
    10.     Hldinst.exe
    11.     instMLockDrv.exe
    12.     LGNPST.exe
    13.     LGNPST_General.exe
    14.     LGTreeView.ocx
    15.     license.rtf
    16.     license.txt
    17.     MegaLock.dll
    18.     PhoneSetting.ocx
    19.     PhoneSetting2.ocx
    20.     Skin.dll
  7. jrocivxx

    jrocivxx Well-Known Member

    Are you sure you didn't start the upgrade then unplug in the middle of the upgrade
  8. Cbelflower321

    Cbelflower321 Well-Known Member

    No I didn't even start the upgrade bc none of the information shows up. All of those files were in my folder as well.
  9. Cbelflower321

    Cbelflower321 Well-Known Member

    So here are the steps that I have done. If I am missing anything can someone tell me what I missed?

    1. unzip the lgnpst folder onto my desktop.
    2. Install the drivers that are downloaded from the link on the root 2.2.1 and get data working page (LG Optimus M MS690 Cell Phones & Mobile Phones - LG Electronics US).
    3. Install those drivers
    4. Install LGNPST_General_v.1.2_Lab_Version
    5. Install LGNPST_Components_ver_5_0_12_0
    6. InstallLGNPST_GenericModels_Ver_5_0_10_0
    7. Restart the computer.
    8. Copy the LGNPST program to the LGNPST folder on the C: Drive
    9. Create a desktop shortcut from that file.
    10. Copy the model folder tot he LGNPST folder on the C: Drive
    11. Delete the files except for Reggie, MS690.dll, MS690ZV3_36, and Setup
    12. Drag MS690.dll onto Reggie (get the registration successful box)
    13. Unzip the MS690ZV4-root zip file to the C: Drive.
    14. Then I open the LGNPST shortcut from the desktop and plug in my phone which is set to usb debugging on
    15. The program doesn't show any of my phones information except for the s/w version.
  10. Darnell0216

    Darnell0216 Well-Known Member

    Odd. The only reasons for it not to read your phone info is usually not doing reggie or turning on USB Debugging. If you've installed the LG USB Drivers from LG, you should be good to go.

    Can you connect to the phone with USB Mode enabled and access the SD card?
  11. Cbelflower321

    Cbelflower321 Well-Known Member

    Yes I can access the sd card. After installing the drivers when I plug in my phone it searches for the drivers in preconfigured folders. Did they install incorrectly, or maybe in the wrong location?
  12. Darnell0216

    Darnell0216 Well-Known Member

    If it has to search for drivers each time you connect it, I'd guess they did have an issue installing. Might be your whole problem right there.
  13. Cbelflower321

    Cbelflower321 Well-Known Member

    How could they have installed incorrectly? I clicked install and it ran through the wizard.
  14. killa57

    killa57 Active Member

    okay i had the same problem i figured it out after hours i was running windows vista and for some reason the shortcut i created on the desktop was set on compatibility to win xp sp2 so i unchecked compatibility and ran the program again and it read everything like it should :)
    hope it helps others out
    reilus likes this.
  15. mikekelso421

    mikekelso421 Well-Known Member

    OK so i successfull rooted cbelflower321's phone via remote desktop!! the problem was windows vista!!!! no phone info was being read by LGNPST.so i had him install on a computer with XP and viola! success..2.2.1 optimus ROOTED! problem solved!! ;)
    Darnell0216 likes this.
  16. mrast

    mrast Well-Known Member

    OK so i have a stupid problem here that's driving me nuts. I bricked my phone. I know how to fix it on my PC. But my PC got zapped in a storm so i have to resort to my netbook however, when i open up lgnpst on it it only shows 90% of the interface. So i can see the interface down to the choose DLL option and that's it. There is no maximize button. So i can't make it full screen. IM not sure if there is a newer interface out or what it could be. I have tried switching resolutions, i even tried extending my desktop to my 70" dlp projector and still just the same problem. Like i said, stupid problem. The answer is probably in front of my face but i am obviously blind to it. Please help trying to switch my optimistic m to boost cdma

Share This Page