Cannot access Samsung App Store on TelusSupport

Last Updated:

  1. MergatroidOne

    MergatroidOne Member

    I have had my Galaxy S 4G (Fascinate on Telus) since last October. Love the phone even without dual core.

    Everything has always worked perfectly. No problems. I just picked up a Galaxy Tab 10.1 and again, no issues. Everything works perfectly.

    Last week, I tried to access the Samsung App store on my phone, and I got a window saying there was an update. I clicked OK, the window showed a green progress bar that ran up to 100% quickly, then showed the alternating green/black progress bar, but just exited. This was the start of my first headache with the Samsung Android products I have.

    I removed the battery and restarted but same result.

    I uninstalled all previous updates (to the Samsung App Store), but after one update it tried to update a second time...same result.

    I performed a factory reset and tried the Samsung App Store...same result.

    Setting>>applications>>Samsung Apps Notification Off ....same result.

    Setting>>applications>>Unknown Sources (Allow non-market apps) ON (Green Checkmark) ....same result.

    Samsung has washed their hands of me. They give up trying to help because they say everything that can be done has been done. I feel this may be an issue with the last app store update. Is anyone else with a Galaxy S 4G (Fascinate) having a problem getting into the Samsung App Store? They have told me to contact Telus, but I highly doubt they will be able to do anything since they don't control the Samsung App Store and its updates.

    Anyone have any ideas?

    Please, no "what do you need the Samsung App Store for" responses. I have already made use of it several times for things that were not available in the Android play store (or whatever the heck they're calling it now).

    If anyone has an idea I'd be happy to try it out. After the weekend I'm going to contact Telus once, then I'll try the Samsung help one more time. I'll factory restore the phone once more after that before, if no further help is available, demanding a replacement phone free of charge. If I'm the only one having this problem, then a factory restore should have fixed it. Since it didn't, I have to wonder if perhaps many people are having the same issue and either don't realize it or don't care because the Android store still works.

    All the rest of the phone functions perfectly. I doubt it's a phone defect since I think if it was there would be another symptom other than the Samsung Store not working.

  2. antaios256

    antaios256 New Member

    I have a Galaxy S1 Captivate 3g, and am actually having the same issue, the google play store works fine, but the samsung apps store prompts for an update to a partiuclar file then crashes on completion creating a loop.

    Any information would be helpful, additional details can be provided as required.

    I should also mention I am on Rogers Wireless Canada, so its not just affecting one network.
  3. MergatroidOne

    MergatroidOne Member

    Still having the same problem. Cannot find a solution.

    Now I have another problem. When I'm using WiFi everything is great, but when I turn it off the phone refuses to go back to 4G. The little icon that normally says 4G does not show up, and I cannot access the data network. The only way I've found to correct the problem is to remove the battery.

    I really hate to be without my phone while Telus makes up their mind what to do, or even worse have them ship me back some refurbished phone that's all scratched up and has someone's boogers all over it.

    So basically I'm trying to decide if I can do without it long enough for the problem to get solved.
  4. mlavoi2

    mlavoi2 New Member

    I do not use Samsung Apps often, I tried last week and I have the same issue. I did the same steps without luck and wait a complete week without any change. If someone get a fix I will appreciate.
  5. mlavoi2

    mlavoi2 New Member

  6. MergatroidOne

    MergatroidOne Member

    First clear your RAM. Click the Samsung store app again, but while it's loading keep tapping the menu button. If it doesn't work, clear the RAM again and launch the Samsung app store icon again. Keep tapping that menu button. Eventually, I can either get it to say the update failed, try again later but the store will work, or it just won't try to update and the store will work.

    As for the 4G problem, I took "auto" off in the settings and left it set to 4G. Now it seems to be working OK.

    Now there's a third problem, although not as serious.

    My weather/news app stopped working this week. It's the one that came with the phone, so I cannot remove it. I liked this app a lot as it has weather AND news.

    Now, it will no longer find my location. Even if I enter a city name (any city in Canada or the U.S.) it says it's unable to find that location. If I enter my postal code, same result. If I turn on GPS, same result.

    It went from working fine one day to not working the next. It's been like this for a week now. It's like whatever server the weather app used is gone. I have reset, and removed battery but nothing gets it working again. I really liked that app to because it has great news options.

    So, now I've installed a separate weather app, and I've installed News360 (I use it on my tablet and it's awesome, but it's not so hot on a phone). It's available for the phone from the Samsung app store.

    I have to be honest. I'm not so impressed with Samsung. My phone is still under warranty, and so far there are two unsolvable problems on it. I love the phone, but I have to wonder why I pay so much money for a phone that doesn't seem to have the best reliability. To be fair, the phone and texting and web always seem to work, but these little naggily problems are going to drive me nuts.

Share This Page