cannot adb remove "Read only file system"

Discussion in 'Android Devices' started by tannerw_2010, Jul 23, 2010.

  1. tannerw_2010

    tannerw_2010 Well-Known Member
    16

    May 23, 2010
    57
    2
    16
    Title says it all. For whatever reason this has been happening a lot to me in the past couple of days. I have never had this problem before. I can get it to work but it seems like I have to reset my phone every time in order to regain access. This is really frustrating because I have been altering the framework and resources files to theme. Any solutions?
     

    Advertisement

  2. tannerw_2010

    tannerw_2010 Well-Known Member
    16

    May 23, 2010
    57
    2
    16
    And just in case anyone asks, Unknown sources is checked and USB debugging is enabled.
     
  3. tannerw_2010

    tannerw_2010 Well-Known Member
    16

    May 23, 2010
    57
    2
    16
    Okay, now restarting my phone doesn't even fix the problem. XD
     
  4. dpeeps74

    dpeeps74 Well-Known Member
    36

    Dec 18, 2009
    138
    5
    36
    Austin
    did you lose root? if you go into an adb shell, can you do su? or from a terminal can you do su? If that gives you permission denied, you've lost root. If that's the case, then you will have to re-root. If su is working, then perhaps it's just that the file system has become read-only in fact. I am not sure what the command(s) would be, but i'd be surprised if there's not a way to make it read-write again.
     
  5. tannerw_2010

    tannerw_2010 Well-Known Member
    16

    May 23, 2010
    57
    2
    16
    How do I check if I can su?
    I just typed in:
    "su", then
    #su popped up.

    I also checked out apps the require root in order to run, such as wireless tether, and it seems to work just fine. I don't know whats going on
     
  6. rockstar420

    rockstar420 Active Member
    16

    Jun 21, 2010
    38
    1
    16
    im having the exact same problem. im trying to push a new htc.resource.apk to the framework. it takes a sec then it tells me failed to copy read-only.
     
  7. Joehunni

    Joehunni Well-Known Member
    128

    May 27, 2010
    1,001
    77
    128
    BAMF
    Texas
    I've found that using the Android Mate app is the easiest way to remove anythimg from /system, you should try it.
     
  8. tannerw_2010

    tannerw_2010 Well-Known Member
    16

    May 23, 2010
    57
    2
    16
    Android mate doesn't work for com.htc.resources and similar files. Anyone else have any ideas?
     
  9. rockstar420

    rockstar420 Active Member
    16

    Jun 21, 2010
    38
    1
    16
    you can remove the com.htc.resource with it. but everything shuts down. im gonna try doin the ADB commands after i remove it via android mate
     
  10. Kelmar

    Kelmar Done by choice
    VIP Member
    823

    Nov 28, 2009
    11,820
    4,751
    823
    Tanner - what exactly are you typing in cmd... One line at a time.

    rock star - link? Just did one myself earlier today that I made... Want to make sure I give you correct directions.
     
  11. tannerw_2010

    tannerw_2010 Well-Known Member
    16

    May 23, 2010
    57
    2
    16
    Weird... I tried removing it with android mate, and it says successful, but nothing happens. It doesn't delete it. This is so frustrating
     
  12. rockstar420

    rockstar420 Active Member
    16

    Jun 21, 2010
    38
    1
    16
    im still tryin to get those annoying ass bubbles off when i change modes. on zen when you push menu>my modes>change theme and switch to any theme, the bubbles go back do default.

    Directions here.
     
  13. rockstar420

    rockstar420 Active Member
    16

    Jun 21, 2010
    38
    1
    16
    long press on the app you want to remove dude.
     
  14. tannerw_2010

    tannerw_2010 Well-Known Member
    16

    May 23, 2010
    57
    2
    16
    oh I am typing the following:

    adb shell

    cd /system/framework

    rm com.htc.resources.apk

    then it gives me the error message.

    Alright, this is really weird. I just downloaded a terminal emulator and tried to remove it with the emulator, and it actually worked. I then plugged my phone in to my PC and pushed com.htc.resources.apk and reset my phone and it worked! I'm going to try reinstalling my android-sdk stuff and maybe that will fix it, because I now know the problem lies within adb.

    I think the reason you keep getting the bubbles is because each theme overwrites the file back to it's "stock" settings. So it is overwriting the bubble file and essentially adding it back in. I am sure you knew this, but I don't know if there is a way around it short of editing the apk which has the bubble in every single theme. Good luck though!
     
    rockstar420 likes this.
  15. rockstar420

    rockstar420 Active Member
    16

    Jun 21, 2010
    38
    1
    16
    Got it woooooooooo :d:d:d:d
     
Tags:

Share This Page

Loading...