cannot add new contacts - desire won't save them


Last Updated:

  1. belso

    belso Member This Topic's Starter

    Joined:
    May 18, 2010
    Messages:
    23
    Likes Received:
    1
    Hi,
    can you help me please?
    I cannot manage to add and save new contacts on my phone. When I add a new contact and fill in all the info, I hit "save", a message says "contact saved". Right after this the new contact shows in the list of all contacts, but if I go out of the list, go to home or do something else with the phone then go back to the contacts' list, the new contact has gone.
    I tried several times, and the new contact always disappears even though it was previously saved.
    If anybody can help, I'd be grateful.
    Thanks for reading.
    Isabella
     

    Advertisement
  2. junkiepilot

    junkiepilot Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    154
    Likes Received:
    52
    when in contacts press menu>view and tick all the groups you want to see e.g phone, sim, facebook. there probably in there but not in your default view.
     
  3. belso

    belso Member This Topic's Starter

    Joined:
    May 18, 2010
    Messages:
    23
    Likes Received:
    1
    I already tried that, the new contact doesn't show in any of the groups.
     
  4. Hardcore

    Hardcore Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    238
    Likes Received:
    12
    When you add a new contact you must specify where you want to save that contact...
    In the view of your list of contacts you have selected that list, phone/sim/google..?
     
  5. belso

    belso Member This Topic's Starter

    Joined:
    May 18, 2010
    Messages:
    23
    Likes Received:
    1
    I normally select "google", and I noticed later that the new contact disappears when the phone syncs with the google account, somehow when I added the new contact on the phone, it didn't get added to the online google account (at gmail.com) and next time it synced it found that the contact wasn't in google's account so removed it from the phone.
    Is there something to be done to prevent it from doing that again? or maybe it's something I'm doing wrong as I'm still very new to this.
     
  6. TheHansTheDampf

    TheHansTheDampf New Member

    Joined:
    May 31, 2010
    Messages:
    1
    Likes Received:
    0
    I am having the same issue. I am located in China btw.

    Cheers
     
  7. belso

    belso Member This Topic's Starter

    Joined:
    May 18, 2010
    Messages:
    23
    Likes Received:
    1
    And a friend of mine that just bought the desire now has the same issue too....I am wondering if this is a bug in the software.
     
  8. sylvansight

    sylvansight New Member

    Joined:
    Jun 4, 2010
    Messages:
    1
    Likes Received:
    0
    I was having same problem.

    After 5 mins of unscientifically messing around with it:

    I think it works better if, rather than pressing the grey box with + contact, you press the box further down with three horizontal lines.

    Then press + contact on the next screen and then enter the details.
     
  9. belso

    belso Member This Topic's Starter

    Joined:
    May 18, 2010
    Messages:
    23
    Likes Received:
    1
    Ok thanks for the info, I'll try that.
     
  10. iv.raziel

    iv.raziel New Member

    Joined:
    Jun 22, 2010
    Messages:
    1
    Likes Received:
    0
    Having the same issue.wasted so much time on this and still wasting time to put my contacts again and again....
    if any one find any solution plz plz let me know as well

    iv.raziel@gmail.com

    Regards
    Shahzad ilyas
     
  11. jred7469

    jred7469 Well-Known Member

    Joined:
    May 14, 2010
    Messages:
    182
    Likes Received:
    23
    I found that doing things in the following manner worked best,

    1. make sure background data and autosync and switched on first and you are connected to mobile data/ wi-fi

    2. add the contact to people and select the type of google

    3. when you press save it should sync with google and add the contact to your google account then be available in both places

    works for me!
     
    faithcry likes this.
  12. Clarky_X

    Clarky_X New Member

    Joined:
    Oct 18, 2010
    Messages:
    2
    Likes Received:
    0
    Hi Sylvansight, what boxes are you referring to. I've had this problem since about June time, roughly since the time that Google changed from name field to first name and last name fields. I thought it may have been that, but I also rang HTC support who were no help and didn't have the issue logged and felt it was a Google issue. I am now on Android 2.2 and hoped it would fix it but it doesn't. When I open people, there are 4 icons at the bottom of the screen, the two with 3 grey lines on are contact card icons and are for All contact and groups. When opening People, it defaults to All contacts anyway, so selecting that icon makes no difference, so I assume you mean select groups, then select the plus icon, but that adds a new group, not a contact.

    A similar issue is that when adding a contact sent to you as a vCard in an MMS it automatically adds it as a phone contact rather than giving the option to create a google contact and as per another post which I thought was on this site that I can't find any more, you can't change contacts from phone to google, which is a bit nonsense. However, while looking for the other post, I came across a post that asked if you've recently changed from googlemail to gmail, which I had, so I looked at accounts on the Desire and sure enough, my original account was set up as googlemail, so I added a new account for gmail, turned off the sync for google mail and added a contact. While I type this it was syncing. So I checked the phone and the contact is still there, checked my gmail on the mac and hey presto, my new contact is there too.

    Brilliant. A simple fix, I guess HTC never thought that googlemail and gmail are the same account, that said, I don't know why google don't just treat login attempts for googlemail and gmail as the same login.
     
  13. sepideh71

    sepideh71 New Member

    Joined:
    Oct 10, 2014
    Messages:
    2
    Likes Received:
    0
    Hey guys! I found the solution:
    On the main page click the people ( phone book) then On the upper right side of the screen (phone book) choose: Viber, Sim, whatsapp, phone and google. from now on, whenever you decided to add a contact, on the first grey page check the contact type... if you are seeing 'Google' click on it and change it to phone( That's what I did since my SIM is full).Now you can add the name and click on save. make sure that u r getting the answer:"contact is saved". And each time pay attention to that option while saving a contact and choose 'phone' .You'll get a dialog box mentioning that "htc is synced with outlook only"that's OK never mind... be careful: never choose Google. that's a hell. That's the end of the story... Goodluck
     
  14. Hadron

    Hadron VIP Member VIP Member

    Joined:
    Aug 9, 2010
    Messages:
    17,801
    Likes Received:
    10,722
    Phone contacts are of course not backed up.

    Never had a problem with Google contacts on the Desire.
     
  15. sepideh71

    sepideh71 New Member

    Joined:
    Oct 10, 2014
    Messages:
    2
    Likes Received:
    0
    Your not having problem , is not my concern.l've typed the solution for those who need it. You woud better check the thread.
     
  16. Hadron

    Hadron VIP Member VIP Member

    Joined:
    Aug 9, 2010
    Messages:
    17,801
    Likes Received:
    10,722
    The last post before yours was 4 years ago, and the fixes others reported refer to what was a feature of gmail at that time. I had read the thread before responding. I don't know whether you had fully appreciated this.

    Let me expand on my point though: the overwhelming majority of people using the Desire, or other android device, store their contacts as Google contacts and have no problems. Speaking as someone who has put a lot of time into supporting people, we have more trouble here with people who store their contacts phone only and lose them with no backup. So blanket advice never to store as Google contacts is actually not helpful for most people, even if you personally have had problems when using them.
     
  17. Hadron

    Hadron VIP Member VIP Member

    Joined:
    Aug 9, 2010
    Messages:
    17,801
    Likes Received:
    10,722
    The last post before yours was 4 years ago, and the fixes others reported refer to what was a feature of gmail at that time. I had read the thread before responding. I don't know whether you had fully appreciated this yourself.

    Let me expand on my point though: the overwhelming majority of people using the Desire, or other android device, store their contacts as Google contacts and have no problems. Speaking as someone who has put a lot of time into supporting people, we have more trouble here with people who store their contacts phone only and lose them with no backup. So blanket advice never to store as Google contacts is actually not helpful for most people, even if you personally have had problems when using them.
     
  18. JasonPZ

    JasonPZ New Member

    Joined:
    Nov 12, 2015
    Messages:
    1
    Likes Received:
    0
    So I think I found the way as my phone Lg G Stylo had the same problem and its brand new. Well there is an app that it automatically in the phone called "Smart Contacts".

    Click on this app follow the instructions to use it with a yahoo account and not only will it save the contacts you now add, but they will be backed up in your mail in case your phone loses everything for some strange reason.

    It worked for me let me know if this helps.
    A bit late but sure
     
  19. Ungati

    Ungati New Member

    Joined:
    May 20, 2016
    Messages:
    1
    Likes Received:
    0
    I know this is frustrating.. One solution can be tried. I am also victim of the same problem.

    Problem: When we save the contact, it saves with out any error/warning. But when you come back and check, it disappears.

    Possible Solution:
    1. Make the Wifi, Mobile data, Sync ON
    2. Store the contact on the phone (instead of Outlook/Facebook/Sim/etc)

    This might work
     

Share This Page

Loading...