Cannot Apply SDK location in preferences in Eclipse


  1. knetter3

    knetter3 New Member

    Hello,

    Im trying to install the SDK, so I downloaded and installed eclipse and the SDK, and I installed the ADT plugin.

    But now I cannot load my location of the sdk in the preferences window in Eclipse.

    Im using windows Vista and Eclipse Ganymede

    I hope you can help me

    Attached Files:


    Advertisement
  2. markb

    markb Well-Known Member

    Hi knetter3 ,

    You need to point it at the right folder in the SDK.

    The path you specify should have these other folders under it:
    • add-ons
    • docs
    • platforms
    • tools

    (Based on the 1.5 SDK I'm using)

    A bit of trial & error will usually find the right folder quite quickly.
    Keep choosing a different one until the preferences dialog shows some targets.

    Mark
  3. knetter3

    knetter3 New Member

    Thanks, but unfortunately that's not working, because when I do that, I get an error: "Could not find folder 'tools' inside ...(map I had chosen)"

    So you have to give the root location of the SDK. But when I do that and I click on apply, I see nothing happen. :S
  4. markb

    markb Well-Known Member

    Hi,

    I'm a bit out of date and am still using the 1.5 SDK.

    I just downloaded the latest SDK for windows so I can see what you're seeing.
    (I can't use it directly, as I'm using Linux)

    It looks like things have changed a bit! And my previous post should probably be ignored.

    There's a read-me file in the SDK, and it starts with this:

    Code:
    Welcome to the Android SDK!
    
    The Android SDK archive now only contains the tools. It no longer comes
    populated with a specific Android platform or Google add-on. Instead you
    use the SDK Manager to install or update SDK components such as platforms,
    tools, add-ons, and documentation.
    
    In order to start developing applications, you must install at least one
    version of the Android platform using the SDK Manager.
    ...
    
    I haven't used the SDK Manager myself yet, so I'll have to do some reading up.
    (But I'm quite happy with my SDK as it is, so don't want to use the latest just yet.)

    I imagine that might have something to do with the problem you're seeing.
    I probably can't help much until I use the SDK manager myself. Sorry.

    Mark
  5. KeithG

    KeithG Well-Known Member

    Open a command prompt, navigate to your sdk location \ tools directory.

    Run:

    android list target

    ^^ this should produce a list of targets that the sdk has installed. If you have no targets installed you need to run tools\android and install / update the packages for the build targets you want to develop against.
  6. knetter3

    knetter3 New Member

    thanks, but when I trie to update it gives an error:
    Failed to fetch URL https://dl-ssl.google.com/android/repository/repository.xml, reason: HTTPS SSL error. You might want to force download through HTTP in the settings.

    ???

    Edit: I think I got it, it's now downloading (i changed it to http in settings)

    Thanks, that did the trick!
  7. efdeel

    efdeel New Member

    on eclipse:

    window > preferences > Android > Browse ...


    find:

    c:\Program Files\Android\Android-sdk-windows

    click Apply

    DONE!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :)
  8. Arbutus

    Arbutus New Member

    Same problem using Windows 7 x64. The default installation directory for the Android SDK is "C:\Users\YourUserName\AppData\Local\Android\android-sdk\"
    Put that in the "SDK Location" field without the quotes and it will detect in a few moments.
  9. thegiants2008

    thegiants2008 New Member

    Hi, try this. It worked for me after pulling my hair. I have a Mac and the folder name was:

    blahblahblah/android-sdk-mac_x86

    I removed the "x" and it worked! So rename the folder name to:

    blahblahblah/android-sdk-mac_86

    Joe
    www.hourdrinks.com
  10. mdsaleh

    mdsaleh New Member

    pls help me out...i tried all ur method but still...am pulling my hairs pls help....am windows user
    am not geettin target even i put \ or any above methods
  11. erusa

    erusa New Member

    What I noticed that even though I was copying+pasting the correct directory, it still wouldn't accept it. But when I hit "Browse" and re-picked the same location it finally took it!
  12. qaMobileTester

    qaMobileTester New Member

    I was getting the same error until I realized Eclipse was looking for \tools and my folder was named \platform-tools. Once I renamed the folder to \tools, I was able to apply all my targets.
  13. jonbonazza

    jonbonazza Well-Known Member

    You need to make sure you have the latest version of the sdk,as well as the latest version of the eclipse ADT plugin

Share This Page