1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Cannot connect on wifi... Galaxy TabSupport


  1. vorost

    vorost Member

    I had the very same problem with the Galaxy Tab (Linksys wrt54g router). This is what helped me:
    1) Set a static IP address on router (assign an IP to your phone/tab mac address e.g. 128.128.1.110)

    2) Download Wifi Static (free) from Android Marketplace

    3) Use your computer / mobile device / router info page via browser to get the following (on Windows prompt, type ipconfig /all):

    A) IP address: this is the address you set on the router as static
    B) Gateway: this is your router as gateway, usually your router IP (eg 128.128.1.1 for me)
    C) Netmask: set on the router, usually 255.255.255.0
    D) DNS1, DNS2: domain name server values, your provider assigns them, router and ipconfig lists these values
    E) WIFI network SSID
    F) Your router MAC address (called BSSID)

    4) Start Wifi Static and enter all the information above. When you give all this, at the bottom of the screen you have "APs that use the above info" (Access Points). Tap it, usually it offers the WIFI network SSID (name) immediately, if not type it in. Same with BSSID (this is the router MAC address)

    5) dont forget the save the info (menu: add). quit & go back to wifi android screen

    6) select your (on Galaxy, probably right now says disabled) wifi network. Click to forget, then re-enter the password

    7) a transparent box will appear to signify that this connection is going to use the static settings. if this does not appear, you got something wrong

    8) connected :) hopefully.

    Took me 2 hrs to figure this out, no problem since then. Gone crazy with refreshing router etc etc etc. Good luck!
    Eedjut likes this.
  2. vorost

    vorost Member

    Btw I have 4 different WIFI networks I am connecting to: this way, you can leave the ones working on default/automatic & set the problematic ones to different static settings. Hope this helps!
  3. soprano

    soprano New Member

    Thanks for your suggestion. The problem in my case is that I've no direct access to the router which I cannot connect. It's something related to the android stack, as the kernel is exactly the same I'm using in my ubuntu system (2.6.32) and I have never problems to connect to ANY wifi network with my laptop.

    This device bases all of its functionality on the ease of connecting any network and this bug/error needs to be solved ASAP.
  4. astanton

    astanton Member

    Hi--Well, this is at least very validating.

    As mentioned earlier, I am not a techie but I guess a semi-intelligent 'user.' Just got my Samsung Galaxy tab at the end of November, then got sick so didn't get it activated etc. til recently. Was able to use wifi at home with no problems til last night. At some points, something indicated I wasn't even on the 3g but on something called the EDGE?!, then it went back to 3G but now even when it indicates wifi is on, I get the 'searching for IP' message; have input the WEP password several times with no luck.

    In my case, I set up the unlimited data plan so I guess there's no advantage for T-Mobile in thrwarting my home wifi connection ;'], but it still bothers me that it's not working.

    I've read through the messages here and had a couple of thoughts:


    --is this only happening with people trying to use wifi with (in my case) Verizon FIOS?

    --has there been a recent update to froyo 2.2 in which case, could that have thrown in a glitch? (Are these updates automatic?)

    --could this have anything to do with my recently setting up an exchange e- (to my work Outlook, using Touchdown) ?
    Anyway, I'm hoping either that one of the involved parties listens in and fixes this or that Ralph (my tablet :') will simply burp quietly one day and it will be as if this never happened...but in the meantime, I'll be trying some of the suggestions here--thank you!

    Arlene
  5. MasterRy88

    MasterRy88 Member

    I had trouble getting mine up and running too, and it was because I was getting bad info from my router. It had given me 2 very different DNS server addresses and it required BOTH of them for my tab to connect properly. Since this set up (about a month ago) I havent had a single problem at home.

    Dont know if it matters but this is on a verizon fios router.....
  6. astanton

    astanton Member

    Embarrassed...how do I find that information..sounds promising...thank you...:D
  7. vorost

    vorost Member

    Well, I am from Hungary on T Mobile, so its not Verizon issue for sure. I have searched on various forums & tech supports, & as the others said it seems to be an Android 2.1 & 2.2 issue (I have updated to 2.2 & have the same problem). Note that I have been using linksys routers for years and it also seems to relate to the router model. Linksys wrt54g didnt even connect without the static solution. Wrt610n worked well for a long time & one day it just stopped (like astanton described) & I had to set up a static ip there as well. I hope this is going to be fixed soon. Based on my search on this topic, lots of people are having similar problems with different devices (droid etc). At the same time, at least up till now, i did not have a problem at my univ (non linksys router), and will really need a different fix there if the problem occurs as i do not have admin rights to assign a static ip to my tab. So if anybody knows a different solution, please post.
  8. MasterRy88

    MasterRy88 Member

    This is such a weird and annoying problem. As far as I can tell this is a problem that is specific to samsung devices (which sucks cause I absolutly LOVE samsung products). Also to the best of my knowlege you NEED to have admin priveleges to your router in order to obtain the information you need.

    Like I said before the problem exisits when the router gives the galaxy tab an IP address and it usues it like normal, as it should. Wehn other people enter and leave the network eventually the router tries to give the galaxy tab a new IP address, which is completly normal. The galaxy tab disagrees, saying that it was already given an IP address and it wants to use that one. And thats it the router and the galaxy tab constatnly fight over which IP address it should use.

    Now the poeple who are saying that it was working, stopped and then like a week later started working again. This is becuase the correct amount of people are on the netrwork again so the router gives the galaxy tab the ORIGINAL IP address that it was given and the galaxy tab is now happy again and connects. But as soon as the number of people on the network changes the problem happens again.

    Only other problems I can think of is that when you assign a static IP it has to be within the range of the DNS server you are using, and make sure that you use an IP address near the end of this range so that the DNS server doesnt try to assign that IP address to someone else.

    And finally finding all that info is a matter of usually loggining into your router and just reading all the info in it. Unfortunatly that part is different for every single router so I cant really do generic help with that.

    Good luck everyone I was happy when I got it fixed and I hope you all get the same joy!!!
  9. Turbo II

    Turbo II Active Member

    this worked for me
  10. fardroid

    fardroid New Member

    Same problem with me my Galtab wouldn't reconnect to my home wifi (tp link extended) and will do after some time alone despite all my desperate maneuvers.
  11. Eedjut

    Eedjut New Member

    This fix also worked for me (also using the Linksys WRT54G), but didn't need the WiFi static program.

    Thanks :cool:

  12. King_cdr

    King_cdr New Member

    Guys,

    I think i solved the mystery. At least for my set up (using a linksys WAG320N).

    I tried all the proposals listed here (static ip, application etc etc), and in some cases it worked fine, but was disconnecting some times; was not steady.

    In parallel, i was a bit annoyed from the fact that had to have a static ip configuration, and change it when going elsewhere etc etc; was a pain in general. So I tried several different configurations, and finally got it.

    The problem is the N standard of WiFi. Our litte toy Galaxy Tab is not cooperating correctly with it. So I did the following:

    Step 1: downgraded my set up in my router to G standard. (In my router you can choose if you want it to work on all standards b/g/n etc, but you can also choose a specific one. So i chose something in random, making sure that it should nevel play on the N standard which is the objective. I chose G.

    Step 2: I played with the channels, meaning that I was selecting several channels to check which is the best. For me it worked perfectly on channel 6. (for you maybe something else will work too). The important thing is the previous step 1. Step 2 is just fine tunning the connection.

    the end result is that, i dont need to have any static IP configuration and its working perfectly. For the time being this solution is perfect for me. in the future I hope that Samsung will solve their problem on the N standard, so eventually we could go back to it.

    Please try it for yourself, and kindly let me know if it works for you too.

    I am extremely happy i managed it.
    chriswue likes this.
  13. rcoups

    rcoups New Member

    My Galaxy Tab wouldn't connect to my wireless network (Netgear WNR 2000) unless I changed to a static IP address set-up and even that was intermittent at best. It would connect to wi-fi at 2 different friends homes and that led me to suspect the router. Hooked up a Linksys E1000 and all is well. Hope this helps someone. :)
  14. trainerkel

    trainerkel New Member

    Yes, this is the solution! To clarify, assign the galaxy it's own ip on your router site.
    (example 192.168.1.20)
    The gateway is the router ip, not the broadband ip, mine was 192.168.1.1,
    input the netmask and dns1 and dns2 from the router info into the advanced wifi settings on the tablet, click static ip and it will finally work!
  15. karenjennifer

    karenjennifer New Member

    i have the same problem with my tab? the first week was ok then it stopped working yesterday. i can't connect anymore
  16. vorost

    vorost Member

    Try the static wifi solution detailed above. If you mostly use your home network, you can just go to the wifi settings, click the menu button and access Advanced to set a static address on your Tab. However, this is a generic setting which will apply to all networks (at least on my Tab) and thus you would have to keep switching it off whenever you want to connect to another network. That is why I have recommended the Wifi static program that allows setting non-system wide wifi settings.
  17. VideoGuy

    VideoGuy New Member

    Encountered the same problem after I rebooted my router to secure a new primary address from my internet provider.

    I do not think the problem has anything to do with the wireless standard (a,b,g or n) being used. Changing the standard must force the Tab to secure a new address from a remembered access point in a way (via firmware) that simply forgetting and logging in again does not. I say this because my access point has only the G standard available, and everything worked fine until I rebooted my system, as mentioned above. After that, no amount of "forgetting," rebooting, and reconnecting would negotiate a connection.

    I tried the Wifi Static program mentioned above but could not get it to work. After much fiddling with it, I got it to pop up the little transparent window mentioned in that post, but my Tab would still not stay connected. Same continuous connecting/scanning loop.

    Finally, the only way I could get reconnected to my access point was to setup the Tab with a fixed IP address in my router, setup the Tab for fixed IP addressing, and then reboot both the router and the Tab. The procedures for setting up the Tab are well noted in posts above. The procedure for your router will vary with your router.

    Since I travel extensively and use the Tab for that purpose, I'm now stuck in the mode of having to turn off the fixed IP address on the TAB every time I leave the house. What a pain.

    I believe this is a Samsung bug (in their "look & feel" layer that they impose on Android), not an Android Froyo bug. As noted in posts above, other Android Froyo devices do not exhibit this behavior, and rooted and re-flashed Tab's do not either. Makes a good case for me to root and re-flash mine!
  18. vorost

    vorost Member

    Agree, it is not a network type error. It does seem a more generic issue, seems that not only Tabs are affected. Have rooted the Tab, didnt have time to flash. Would be interested if a specific rom solves the issue. Give another go to the wifi static application i found it very reliable. Sometimes i do have to switch the wifi off & back on when entering a static network, but overall it works very well and still a lot better than having to swich the static off all the times as you noted. Good luck!
  19. govols

    govols New Member

    i tried this and it worked. thanks!!
  20. steb0ne

    steb0ne Member

    This is definitely a bug on my Galaxy Tab (Sprint).... I noticed the same thing recently myself. I've tested this with more than 3 routers. All were WEP protected, not sure if that matters, but my Tab was connecting fine at home, then go to work can connect on one router, but another (where the settings were saved) wouldn't connect. Then I go and connect to a different router that the Tab has never connected to and it connected no prob...but when I got home it couldn't connect to my home router.

    I reset the router just to make sure it wasn't the router, but mainly for another reason...and erased the settings in the Tab from my home network then tried reconnecting to it, but still wouldn't connect... I tried Airplane mode Off/On; rebooting, turning wifi Off/On but nothing worked.... It seems like I can only connect to my wifi at home when I open the AllShare app, lol! I just recently even reset my Tab b/c I couldn't get rid of some missed call notifications and the problem still exist. I hope this gets fixed.
  21. QuickDraw

    QuickDraw Well-Known Member



    Something else you could try is if your router supports DHCP Reservation, then you could just reserve the IP Address that the router assigns to your SGTab and be done with it. This should work IF the problem is actually as described above. I personally am not experiencing this. A benefit of doing it this way would be "Avoiding" having to enable/disable STATIC IP Addressing whenever you're home/connecting while mobile.
  22. ang3

    ang3 Active Member

    omg this worked! thanks
  23. nator

    nator New Member

    I also just went to the Allshare app that is pre-installed on the tab and wifi started working again. I have no idea why it started working and if it will stay that way. Hope they build a real fix before this one stops working.
  24. rodfreitas

    rodfreitas New Member

    Hi everyone! I know the fix for this! I’m Brazilian, so i can't write right!
    I had the same problem. My Samsung Galaxy Tab - (GT) P1000L - connected to WI-FI first and after that never connect.

    What happen is that the GT first take an ip number (example: 192.168.1.102)
    Than we turn off the router and turn on again and GT try to take the same ip address.
    And you have a notebook and other things that connect to the router too. And they sometimes take the same ip that the GT is trying to take.

    I have a TP-Link router WR642G. This can work with another TP-Link or other routers.
    Enter in your browser (in a notebook that is connected to the router) 192.168.1.1 (sometimes is another number. the number is usually under the router, and the Username and Password too) if the password does not work, reset the router (push a clip on the hole) try again.

    Turn off other things that are connected to the router.
    Now we have to know which ip your GT took first.
    Go to you GT and write down the MAC: example: 40:1F:E0:4R:Q3:7A (go to Wi-Fi configurations than click on Menu – Advanced)
    (Menu is the first button below in the black border)

    Now return to the router (browser in your PC)
    Go to the DHCP Settings. Look the Start IP Address (mine is 192.168.1.100)
    Go to DHCP – Address Reservation. – Add New.. In MAC Address input the number you see in GT, but input with this (-) example: 40-1F-E0-4R-Q3-7A
    Now in “Reserves IP Address” input the IP you saw in DHCP Settings.
    Try to connect your GT.
    If don’t work, input the next IP, example (192.168.1.101) until it CONNECT!
    I hope you enjoy!
    Rodrigo (Brazil)



    the easy way is to restore fabric your GT.
  25. Robertxn

    Robertxn New Member

    I too suffered this same error on my home network this week after I purchased my Galaxy Tab. This was my approach that seems to have corrected the problem for good.

    1. If your GT will not reconnect to your wifi network (you know your settings, password etc. are good) take your GT down the street far enough away so that you are no longer in range of your wifi network.

    2. Go into Settings, Wifi, locate your problem connection by its SSID, select it and tell your GT to delete it and forget it.

    3. Before you go back in range of your network go the the Android Market and download "WiFi Manager" by Kosta Vasilyev it is free. This app will tell you your IP address when you reconnect to your wifi network.

    4. You have now deleted the problem wifi network and you have downloaded "WiFi Manager" now power off your GT. Hold the power button down until it asks you if you want to power down. Power it down and then restart it.

    5. Take your GT back to your problem network, go into Settings, WiFi you should see your problem network SSID. Ask your GT to connect, enter the password etc. It should now say "connected" after a moment.

    6. If it is now connected go to the new app "WiFi Manager" open it. It will show you the network SSID you are connected to. Click on it and you will see the IP address that you have now been assigned. Write it down. Go into settings "About Tablet" you have to scroll down to see it. Open "About Tablet" now open "Status" look for your Wi-Fi Mac Address, write this down too.

    7. Go to your PC and log into your router (I hope you have done this before, otherwise you may need some further help here) find the location in your particular router that allows you to reserve IP addresses by device. Enter the MAC address of your GT and the IP address that has been currently assigned, be sure to save these settings etc.

    You are now done; Your GT should never again have issues connecting to your network.
    dsquared51 likes this.

Share This Page