Cannot connect on wifi... Galaxy TabSupport


Last Updated:

  1. Vivar

    Vivar New Member

    My brother was able to help me connect to our home wifi through a static IP. However, despite my GT's being connected to a WiFi (strong connection at that), I cannot browse/surf the internet! It always says, "No connection"! Has this happened to any of you? How did you solve it? Help please!

    Advertisement
  2. SunilKaul

    SunilKaul New Member

    Thank you Jeffff... this really worked for me, after an R&D of one week... thank you again.....
    astro_boy likes this.
  3. DeeLine

    DeeLine New Member

    I had this problem and the whole dueling IP address makes sense... not sure why this would happen... the Galaxy Tab can "see" my home WiFi and shows a full signal - it just won't connect. I thought I'd do the static address change but instead I just "rebooted the router"

    1) turn off router
    2) turn it back on
    3) Connected!
  4. djlonboy

    djlonboy New Member

    This worked for me! Took about a minute but now it's connected, hooray! Maybe just luck though :confused:
  5. tonixe

    tonixe New Member

    Tried Allshare App connection and it worked for me !

    Super simple and effective ! Stroke of genius by jeffff !
  6. QuickDraw

    QuickDraw Well-Known Member

    I'm not sure if this will help anyone with their current problem, but here goes anyway. I've found that for some reason, not sure why, these android devices (this is not a put down .. just fact) have trouble connecting/reconnecting IF and only IF, your SSID is not being broadcasted. I've seen this almost from day one of my purchasing my EVO and it also happens with my SG Tab. If you have your Router set up to NOT broadcast SSID, then you might want to reverse that and broadcast it and see if that helps in your situation. ALL of my other wifi connective devices do not have a problem with this broadcasting issue, and believe me I have a ton of them connected. Only the Android devices have this problem (it seems like).
  7. ghady_n

    ghady_n New Member

    Guys i have the same problem on my galaxy tab, i cant connect on wifi at home because i have obtain ip address from wifi and i have the same router tplink, please guys if someone has resolve the poblem send me email on this: ghady_n@hotmail.com thanks all :)
  8. Stela

    Stela New Member

    Thank you so mach that worked for me also!:)
  9. schuster

    schuster New Member

    Hi, when you say "find the location in your particular router that allows you to reserve IP addresses by device" do you mean MAC address filtering? Would I then need to do manually add the MAC address for all of the devices that use this router? Or is there some other way of reserving IP addresses by device? BTW, I have a Belkin router.
    Thanks
  10. marbill

    marbill New Member

    I don't know if anyone still have this problem. I got my tab 2 weeks ago and ran into the same problem that it suddenly refused to connect to my home router. It could find the ssid but could not obtain an ip address.

    I searched on the net and found a work around and would like to share it with who ever is having the same problem. It seems that the tab log the ip address it last connected in the dhcp_list file and refused to accept a new address. So if you are using a router at home with a non-fix ip, it will change the ip every time its reconnect to the modem after a reset or power off or what ever other reasons. Just simply remove that file and it resolve the problem

    You would require root access and terminal emulator for this to work however.

    1. Install terminal emulator from market.
    2. Install Superuser from appbrain to gain root access.
    3. start emulator and type the following text in red:
    su (to be root)
    rm /data/misc/dhcp/dhcp_list (to delete the ip address log in the tab)

    I also install Scripter and made a script to save me typing it over and over again since it happen very often to me.
  11. OBGYNE

    OBGYNE New Member

    I have the same problem with my galaxy ace phone. Have you solved your issue? I tried all the suggestions in the forum to no avail...
  12. jeffkyle

    jeffkyle Member

    The Allshare App worked for me. I had it happen two times today... (left and came back)... And both times got connected by opening the Allshare after it would not connect... I am using Fios...
  13. olivergrovez

    olivergrovez New Member

    PERFECT! Exactly the solution I was looking for, many thanks :)
  14. dotty p

    dotty p New Member

    Can I ask please, is this information the same for a Galaxy Apollo phone....received it yesterday and it will not connect to home WiFI. :mad:

    Many thanks.
  15. dave_f_n

    dave_f_n New Member

    Accolades to Jeff... Allshare App worked for me
  16. Sjengie

    Sjengie New Member

    Roberttxn pointed me in the right direction !

    i deleted all connections to my linksys wrt54G2 router
    then switched off all devices (BB, laptops, etc) connected to the router
    then switched off the wrt54G2
    told GT to forget this network
    next switched on router
    et voila the GT was the first to connect and now it is working again !

    so yes it must be something with the GT accepting only his first IP adress despite DHCP on the router

    good luck all
  17. vhei

    vhei New Member


    i am new on this and doesn't know how to execute the things u said. can u give me a step-by-step instruction on how to do this? i believe this is the best solution on the said problem. thanks for your quick response.
  18. vhei

    vhei New Member

    i am new on this and doesn't know how to execute the things u said. can u give me a step-by-step instruction on how to do this? i believe this is the best solution on the said problem. thanks for your quick response.
  19. abredt

    abredt Member

    What do you mean you deleted all connections to the router?
    Did you just pull out the cables attached to it?

    Sounds easier than doing the Static IP stuff all the time.
    cb
  20. faizal005

    faizal005 New Member

    already connected thru Allshare, but still can't browse the internet. Mine is stock SGT anyway. Sigh...
  21. babylonking

    babylonking New Member

    Dude you are awesome !!! i got my new Galaxy s i9000 yesterday and it worked fine last night ( my laptop was offline) at home. This morning i started my laptop then tried to connect the Galaxy without luck for 8 hours ... till i read your solution and its now working perfectly fine !!!! many thanks.
  22. babylonking

    babylonking New Member


    you are awesome !!! worked very well for me. many thanks !
  23. knapp

    knapp New Member

    ok guys
    this prob is really pain in my a**

    thanks for the info before me

    but i have solutions worked for my galaxy tab
    my step should be;

    1. disable connection to all machines/computers from your routers
    2. go to setting-wireless and network-wifi setting and forget your existing wifi (if you have connected your galaxy tab before)
    3. using Allshare, connect your wifi again

    and woootttt.... it works for me
    good luck
  24. Tabluvr

    Tabluvr New Member

    All share=nope
    Static IP=nope
    Delete all connections and reboot=nope

    Galaxy Tab is a POS

    Never even a glitch with my Viewsonic Android Tablet so it is NOT an Android Issue! The Tab has never left my home, this is my second Galaxy Tab as the first one was returned to Sprint. I am so disgusted...
  25. Jim1348

    Jim1348 Member

    I just got one of these last week. I can connect fine and home, but intermittently at work. Should I try "All Share" first?

Share This Page