Cannot connect S2 to new PC via USBSupport


Last Updated:

  1. shaz68

    shaz68 Member

    I've just replaced my PC, and my SII will no longer connect via USB cable.

    The PC I had previously is a PRYON running Windows 8 on 32 bit. When I plugged the phone into it, I got the USB Connect in the notifications bar, could connect to USB and view it as a device with removable storage, then drag and drop files.

    With the new PC (a PRYON running Windows 8 on 64 bit), I don't get the USB Connect in the notifications bar when I plug it in. Instead, I get the KIES MTP application. If I hit home to close it, there's no way to connect. If I go to USB Utilities and hit Connect storage to PC, it tells me to remove the cable. When I remove the cable and hit Connect storage to PC, it tells me to plug in the cable. It just sends me in circles. At one point I got a message telling me to close all open applications after I plugged in the cable, but the only open application was KIES trying to connect because I'd just plugged it in. When I closed KIES, I was back at square 1.


    What I would LIKE is for it to behave exactly as it did with the previous PC - I want to plug in the cable, get the notification, tell it to connect, and be able to treat it like a device attached to the computer. I don't want to use KIES, FTP, or any other "utility" program to connect them.

    The threads I've already found either involve using KIES or other third-party programs to transfer data, or rely on sequences that either aren't showing up for me or give me different results to what the threads say they should. I've searched for drivers, but what I find has KIES written all over it. Do I need to install that even though I don't want to use KIES?

    The phone seems to detect that it's plugged in (since MTP runs and the battery starts charging), so I don't THINK it's an issue with the cable or the USB port.

    Advertisement
  2. kelis32

    kelis32 Well-Known Member


    Hello

    You will still have to install the Samsung USB drivers, these are usually installed alongside KIES, you can get them from here and install them separately

    SAMSUNG USB Drivers for Mobile Phones v1.5.16.0

    Your post seems to indicate you already have KIES installed but then states that you dont want to install it, do you already have KIES ?
  3. shaz68

    shaz68 Member

    I say it's using KIES because that's what the phone comes up with when I plug it in. However, it hasn't been installed on the computer, and I don't really want it there.

    Thanks for the link for drivers without KIES. I'll give it a go and come back :)
  4. kelis32

    kelis32 Well-Known Member


    Ok that makes sense now :)

    Heres an alternate link if the other drivers dont work, these are newer

    http://www.samsung.com/uk/support/model/GT-I9100LKAXEU-downloads
  5. shaz68

    shaz68 Member

    Unfortunately, neither of those made any difference :(

    Is it possible to just turn off KIES/MTP on the phone so it doesn't take over as soon as I plug in the cable? I looked through Applications but couldn't find it there.


    I don't think it should matter, but I'm still on Gingerbread. I'm updating now - HOPING my photos aren't deleted in the process - and will see if it changes anything.
  6. kelis32

    kelis32 Well-Known Member


    Ok go to menu / settings / applications and enable USB debugging without the cable plugged in then try and connect

    or

    settings / wireless and network / USB Utilities and enable mass storage from there
    shaz68 likes this.
  7. shaz68

    shaz68 Member

    No, neither of those work. Just doing exactly the same thing as before, even after the software update.

    Edit ... I found the problem. I was plugging it into a USB port on the front of the computer. Even though the phone detected that there was a connection and the battery was charging, that's about all I could do. I plugged it into a port on the BACK of the computer instead, and now it works perfectly.

    I don't really understand why it's made a difference. The two ports on the front are labelled with SS and a networking type icon (three-pronged) - maybe they're not USB ports at all?

    Thank you for all the time spent trying to help me Kelis32 :)
  8. ironass

    ironass Well-Known Member

  9. shaz68

    shaz68 Member

    thanks ironass, I'd had a look through that already. I did find the problem and solution. We'll put this one down to user error :)
  10. ironass

    ironass Well-Known Member

    Glad you have got it sorted shaz68. It's surprising how often, on this forum, that just switching USB ports has proved to be the solution to Kies connection problems.
  11. kelis32

    kelis32 Well-Known Member


    Ok no problems, glad its sorted :)

Share This Page