Cannot connect to the Marketplace from my phone

Last Updated:

  1. mani99

    mani99 New Member

    I've just got my G2 Touch and cannot connect to the Marketplace in order to download some new apps. Here's what I do:

    From the menu select 'Marketplace'
    I get prompted to sign in to my Google account, which I do
    Get the error message "Cannot connect to server"

    And that's it. Anyone else experienced this?

  2. MartinS

    MartinS Well-Known Member

    I got a couple of error like that over the weekend but generally it's OK. I thought that it was a problem of the Marketplace or maybe maintenance rather than my Hero.
  3. mani99

    mani99 New Member

    Thanks for the reply, but I dont think it is anything to do with the Marketplace as I got that same error since Friday and all weekend. It only happen once it tried to sign me in, at which point it errored something along the lines of "Cannot establish secure connection..."

    Apologies, I cannot give the exact message right now as I am unable to try to connect.
  4. murrayalex

    murrayalex Active Member

    Found this on Google which I hope helps, someone else had your problem..

    Yay.... I have the answer. After hours of searching I phoned HTC. Very helpful people. It appeared I exited the set up of my new phone too early and did not set up a Google account when I first turned phone on. This means it will not work! You have to do a factory reset. Yes I know you have just spent hours customising phone and transfering files and numbers etc. I did it, it works, but with one issue, I had too set up a new Google account not use my existing one. This works and I am now surfing for apps happily. To perform a factory reset go to Menu> Settings > Security > Factory data reset. It was a pain and I am now looking forward to my coffee. Good job there is a Starbux Locator app. ;-) So do this and follow all the instructions on screen as they come up, bear with the set up as it did drop me once or twice and I was starting to think it was the same old problem..

Share This Page