Support Cannot connect to win PC via USB


  1. etxdobe

    etxdobe New Member

    Hi, i have a Sony Ericsson Xperia Neo. A few weeks ago i could no longer connect the phone to my PC (win7). It worked fine before. I have the same issue with the two different computers i have tested. In the Device manager the error says "This device cannot start. (Code 10)". Searching the internet i understand that it has something to do with MTB USB driver. If i first unmount the SD card i can connect via USB. But that is not a solution since i usually want to transfer files to the SD card when i connect the phone to the PC.
    Someone talked about that it can be due to mp3 files on the SD card but i deleted the folders that contains mp3 files and the problem still exists.
    The phone is not rooted or changed in any way.

    What can be the problem ?
    /Dennis

    Below are the 2 errors in the Event Viewer:
    "A problem has occurred with one or more user-mode drivers and the hosting process has been terminated. This may temporarily interrupt your ability to access the devices."

    "The device Xperia neo (location 0000.0004.0001.005.000.000.000.000.000) is offline due to a user-mode driver crash. Windows will attempt to restart the device 5 more times. Please contact the device manufacturer for more information about this problem."


    The text from the Error reporting tools says this:
    Description
    The Windows User-Mode Driver Framework detected that a driver host-process did not complete a critical operation within the allowed timeout period.
    This report contains information about the process and the drivers running within and will be used to improve the quality of these drivers.

    Problem signature
    Problem Event Name: WUDFHostProblem
    EventClass: HostProblem
    Problem: HostTimeout
    DetectedBy: 2
    UMDFVersion: 6.1.7601.17514. (win7sp1_rtm.101119-1850)
    ExitCode: 103
    Operation: 3
    Message: 11b00
    Status: ffffffff
    HardwareId: USB\VID_0FCE&PID_5156&REV_0226&MI_00
    OS Version: 6.1.7601.2.1.0.768.3
    Locale ID: 1053

    Advertisement
  2. Try to switch to mass storage mode instead of using the media transfer mode just to see if this makes any sense or difference.
    If you just want to transfer files to/from the SD card I suggest you use the mass storage mode regardless of this issue as it's the easiest and best way to do it in my opinion.

    -Markus
    Sony Ericsson Answers Team
  3. etxdobe

    etxdobe New Member

    Mass mode worked (MSC). But why does not Media mode (MTP) work ? Is there something i can try to do ? Something to check ?
  4. We're working on a new software and I checked with my colleague yesterday (before answering on this) and he said that this was something that had been reported for investigation since earlier.
    If it turns out that the phone's software is causing the issue, it will hopefully be solved in a coming update.
    If you want to find out if the problem lies in the PC or not I suggest you first of all try to run Windows Update and make sure you have the latest Windows Media Player update since this also affects media transfer and digital rights in the PC.
    Trying on a different PC might also be worth a shot.

    -Markus
    Sony Ericsson Answers Team

Share This Page