Root Cannot force move apps to SD card [Titanium Backup]

Discussion in 'Android Devices' started by stewart1champ, Jun 13, 2010.

  1. stewart1champ

    stewart1champ Well-Known Member
    68

    Not sure exactly what the issue is.

    I am trying to move a couple of apps onto my SD card. I know you long press the app you want to move, and select the choice to move it. My problem, is TiBu shows the notification of it being moved. I then go back into setting, look at the apps on SD card, and they do not show up.

    I am running NexBeast FRF57 V0.1.1
    My Titanium Backup is at version 3.2.4

    I can reboot, still doesnt work. Superuser shows Titanium has permissions, so I am not sure what the deal is.

    Any help would be appreciated.
     

    Advertisement
  2. stewart1champ

    stewart1champ Well-Known Member
    68

    Nothing?

    No ideas.... Man, this sucks. I am almost to the point of being tired of trying.
     
  3. G.Armour

    G.Armour You know you want to.
    VIP Member
    173

    Jan 11, 2010
    4,534
    306
    173
    Truck driver/ driver mentor. I train people to dri
    Georgia
    Ok, after reboot, go to settings, applications, and force launcher pro to stop.. all your apps should show up
    Sent from my Droid using Tapatalk
     
  4. FUCCO

    FUCCO Well-Known Member
    36

    Jan 20, 2010
    122
    6
    36
    not all apps can be moved to sd card. the developer when makin the app has to allow this. since froyo is very new not many apps have been updated to do this.
     
  5. stewart1champ

    stewart1champ Well-Known Member
    68

    No, Titanium Backup has the support to do it. We all know, and there are a couple different threads about it.

    Its not an application showing up thing. Please read.

    1. I open Titanium, long press, select the move to SD card.
    2. Notification pops up, showing it has been moved.
    3. Go into setting, it does not show the app on the SD card.
    4. Go back to Titanium, long press same app, it gives option to move to SD card again.
    5. Go to settings, APPS, it still not listed on SD card.

    I can reboot, power off, throw phone off wall, etc., nothing moves ANY apps to the SD card except the ones inside setting that give you the original option.

    Its like my edition of Titanium Backup acts like it is moving them, but really doesn't.
     
  6. G.Armour

    G.Armour You know you want to.
    VIP Member
    173

    Jan 11, 2010
    4,534
    306
    173
    Truck driver/ driver mentor. I train people to dri
    Georgia
    Try uninstalling and reinstalling TiBu. If that don't work, maybe reformat your SD card, and then try it..
    But the other person was right, not all apps can be moved, even with TiBu.. try adobe flash because I know that one can.
    Sent from my Droid using Tapatalk
     
  7. stewart1champ

    stewart1champ Well-Known Member
    68

    I know which apps can be moved. I have tried to move Flash many times. I have tried to move my games, which earlier, I was able to move all of them. Actually, when I did a restore, I could still no longer move apps back and forth with Titanium. I had moved a couple onto the SD card. Changed ROM's, changed back again, and it hasn't worked since.

    Hmmm.
     
  8. G.Armour

    G.Armour You know you want to.
    VIP Member
    173

    Jan 11, 2010
    4,534
    306
    173
    Truck driver/ driver mentor. I train people to dri
    Georgia
    It will only work on froyo roms.
    Try reformatting ur SD card.

    Sent from my Droid using Tapatalk
     
  9. stewart1champ

    stewart1champ Well-Known Member
    68

    I have only been using Froyo roms since they were leaked.

    Your tapatalk must not work, or you don't read all of what is said... haha.
     
  10. G.Armour

    G.Armour You know you want to.
    VIP Member
    173

    Jan 11, 2010
    4,534
    306
    173
    Truck driver/ driver mentor. I train people to dri
    Georgia
    I seen you say u switched roms. I thought u may have switched back to 2.1 but guess not. Have you tried reformatting ur SD card? If that don't work, I am out of ideas.
    Anyone else got any ideas?
    Sent from my Droid using Tapatalk
     
  11. stewart1champ

    stewart1champ Well-Known Member
    68

    I was kidding btw.

    Anywho.

    The ROMS I had...

    One had FRFxx
    and the other FRF57

    Not sure if that changed anything or not, both are 2.2. But when I first flashed, I could move them with Titanium. Now since going up to 57, I cant. I will reformat when I get home, and see what happens.
     
  12. stewart1champ

    stewart1champ Well-Known Member
    68

    Ok, solution.

    Came home, copied files to PC.

    Formatted card, everything back to working again.

    I did notice. On the FRFxx test keys ROM, the folder to hold the app was inside the SDCard folder, under ".android_secure"

    Now, with FRF57, the folder is listed beside the SD card [when viewing in astro], and all the backups are being sent to the folder "asec".

    Just giving a heads up, if anyone else had/has this issue.
     
  13. benzmar

    benzmar Well-Known Member
    16

    May 1, 2010
    47
    1
    16
    I purchased titanium pro for 5.99 USSR and when I long press an app, still I see the button of move to sd is in inactive mode.
    I use xperia x10i.
    Can I move apps to sd or should I uninstall and get it refunded?
    Please advice.
     
  14. djqwikcut

    djqwikcut Well-Known Member
    16

    Dec 22, 2010
    68
    5
    16
    I have this problem as well on my EVO. I had TB PRO working and I was able to use the MOVE APP TO SD option to force the apps to the SD card. Now, I can press the command and it looks like it is working but I dont get any notification that it did anything and the button is still there to MOVE THE APP TO SD. I can, however move ANY APP DESIGNED for SD using the APP2SD program.

    So, I am thinking it is a TITANIUM BACKUP PRO issue.. anyone with any ideas??
     
  15. Lock-N-Load

    Lock-N-Load Well-Known Member
    143

    Feb 8, 2010
    2,309
    195
    143
    won the lottery
    WestSiiiide
    FYI to some of you guys... I have been able to move every non system app I have ever wanted to my SD card with TiBu.

    until recently. I came across the first & only app I could not move (the "move to SD card" button is dimmed) and emailed the dev and he explained it this way to me

    "The reason my app cannot be moved is because it is copy-protected. This was Google's initial solution to anti-app-piracy and for security of user's data within an app, so I turned this on for my app. It prevents copying to SD card because the app/data is stored within an encrypted area on the phone's internal memory.

    Google now how licensing verification that lets an app verify that the person using it actually bought it. I am working on integrating this into my app and will have it in a future update."


    so, it looks like there is a method, for purchased apps, that can stop TiBu from moving it IF the dev codes it as such but a method seems to be coming/is available to get around it if the dev codes it as such
     
  16. djqwikcut

    djqwikcut Well-Known Member
    16

    Dec 22, 2010
    68
    5
    16
    BUT what about my issue where I used to be able to move APPS TO SD with TB and now I can no longer? I posted on the TB FORUM and was told the developer will look at it but nothing yet...
     
  17. djqwikcut

    djqwikcut Well-Known Member
    16

    Dec 22, 2010
    68
    5
    16
    anyone? I am stuck with this issue.. I reformatted the card and copied everything back onto it. still can not use the MOVE APP TO SD in TB PRO. HELP!
     
  18. johnlgalt

    johnlgalt Antidisestablishmentarian
    VIP Member
    333

    Oct 28, 2009
    9,416
    1,920
    333
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Even if the app could be moved before, if an update has taken its place, and it is a purchased app, and the app dev has incorporated the new copy-protection, then it will no longer work. Even if it did before.

    Read Lock's post again.
     
  19. Shadowtech

    Shadowtech Well-Known Member
    53

    Dec 29, 2009
    434
    36
    53
    Male
    Driver
    Ohio
    Yet another annoyance with paid apps. Not only are they overpriced for the most part, but just imagine if every developer adds in this switch. You will be limited yet again to your internal storage for all apps, and have this nice big sdcard going to waste. It's all pointless anyway, even with that new code apps get cracked and many people run them from sdcard anyway without buying them.

    Just throw in some type of lame encryption to keep developers happy (like having the app tied to the ESN via the OS itself when installed), while still allowing people to move to sd. If their app is on the phone, it doesn't matter where it is stored because anyone can copy the file and crack it anyway. But no, people are stupid and like wasting money on irrelevant anti-piracy protections that have been proven time and time again to be completely useless.

    The only people being inconvenienced are the honest people who actually pay for stuff.
     
    johnlgalt likes this.
  20. johnlgalt

    johnlgalt Antidisestablishmentarian
    VIP Member
    333

    Oct 28, 2009
    9,416
    1,920
    333
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Amen.

    I've put over $100 into apps thus far on my DROID, in a little over a year. And this kind of thing makes me madder'n hell....
     
  21. Timewarp

    Timewarp Member
    15

    Feb 15, 2011
    10
    0
    15
    I had the same problem and this page came up first on Google.

    Managed to fix it though, open a terminal and run this

    Code (Text):
    1.  
    2. su
    3. rm /mnt/secure/asec/smdl2tmp1.asec
    4.  
    found here: TB - Troubleshooting : Titanium Backup - Wiki
     
  22. leland

    leland New Member
    15

    Aug 27, 2010
    3
    0
    15
    USA
    This is probably a dumb question, but when you say open up a terminal does this mean doing something on your computer with adb or is there an app that allows commands like this to be entered?
     
  23. Timewarp

    Timewarp Member
    15

    Feb 15, 2011
    10
    0
    15
    I used the Terminal Emulator app.
     
  24. samc690

    samc690 New Member
    5

    Jun 20, 2011
    3
    0
    5
    On my tablet nothing appears on SD card when I try move my apps.
    But I've notice in Applications > Manage apps the option is to move back to device memory so I'm thinking my tablet internal memory is for some reason set to the SD card space :thinking:
     

Share This Page

Loading...