Cannot get Apps2SD to work.


Last Updated:

  1. jduval43

    jduval43 New Member This Topic's Starter

    Joined:
    Nov 9, 2010
    Messages:
    1
    Likes Received:
    0
    Hey Everyone,

    I have searched and read and followed all steps I could to the T. I cannot seem to get Apps2SD to work. I am using Drellisdee's recovery as well as Trident's Velocity 3. I have formatted the SD card to 0mb swap with 512mb Ext.3 and FAT32 for the rest. I have an 8GB class 2 (I know it sucks) SD card. I tried using Drellisdee's recovery and the one included with ROM Manager. I have verified I have the Ext partition through Titanium backup. it shows that I have 102 out of 159MB free on my internal storage and 220 out of 480MB free on my A2sd partition. If I long press on an app on Titanium backup I am not allowed to move it to the SD (The option is grayed out) and when I install an app the internal space goes down. It doesnt seem to matter if I install the app from a backup or directly from the market.

    I have tried re-flashing the recovery and ROM multiple times with no luck. If anyone could help me I would be VERY great full.

    Ps. Sorry for the long post just wanted to give as much info up front as possible.
     

    Advertisement
  2. jake_harv88

    jake_harv88 Active Member

    Joined:
    Sep 14, 2010
    Messages:
    38
    Likes Received:
    10
    I dont believe that titanium backup should be able to do that. I think that's a feature that would be available in a froyo build. Froyo handles apps2sd a little differently than Raptor or Velocity do. All of your apps (except system apps) will automatically go to the ext partition.

    This is expected. Currently the dalvik-cache for an app will get saved on internal storage. Its not a good idea to move dalvik to the sd card especially for lower class cards. For reference I have 70+ apps on my phone and am down to abot 40 MB of internal.

    To test if a2sd is working try this from a terminal:

    Code (Text):
    1. ls /system/sd
    you should see a folder called "app" and "app-private" there

    Also do:

    Code (Text):
    1. ls -l /data
    you should see a symlink /data/app --> /system/sd/app

    If you are still having issues, pop into the LG Ally IRC channel.
     

Share This Page

Loading...