Cannot import contacts on 2.1Support


Last Updated:

  1. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    I recently upgraded to 2.1, before which I used "Backup & Restore" to .... well .... backup everything. I thought.

    Now when I go to "Backup and Restore", the file is there as I named it, and all my photos, texts etc restore as planned.

    But not my contacts. Although I can see the 300+ contacts being restored with a progress bar, when I go to my phonebook it is completely empty.

    Where the hell are my contacts? What am I doing wrong????
     

    Advertisement
  2. rosered

    rosered VIP Member VIP Member

    Joined:
    Jul 4, 2010
    Messages:
    2,129
    Likes Received:
    317
    Backup and Restore has been quirky to be very kind about it! However it doesn't back up contacts that have been synced - so any chance that you previously synced with Google or Sony Ericsson?

    The other thing that I have heard is to run it a few times and this may work.
     
  3. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    No I'm pretty certain I've never synced. But just in case I have is there a way to "un-sync"???
     
  4. rosered

    rosered VIP Member VIP Member

    Joined:
    Jul 4, 2010
    Messages:
    2,129
    Likes Received:
    317
    If you log on-line with your google account you used on the phone, if there are contacts there you can get them back on your phone.

    Don't suppose you ever took a copy on the SD card via the phonebook.
     
  5. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    I've logged into Google Mail and as expected the contacts list is empty (Google Mail isn't something I've ever used). I last backed up the phone book to the SD card about 6 months ago, so all those contacts can be restored from the vCard file, but all the ones I've added since obviously can't. It's very frustrating because it appears that "Backup and Restore" is working fine - it's just that wherever it's restoring my contacts to, it isn't the phonebook. Grrr !!!
     
  6. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    ... and another thing. Since upgrading to 2.1 I've reset my ringtone and notification tone to the ones I wanted - these are correctly shown under Settings - sound & display. Yet when I get a call the ringtone is just some weird bleeping, and a text just makes the phone vibrate, with no ringtone at all. Any suggestions? Thanks
     
  7. D3sRtH4mmR

    D3sRtH4mmR Well-Known Member

    Joined:
    Nov 12, 2010
    Messages:
    60
    Likes Received:
    11
    I found Backup & Restore problematic and didn't restore my contacts properly. What I did (I had backed up my contacts from within phonebook: Phonebook-menu-backup contacts) and got them all back by importing from the backup: phonebook-menu-import contacts.
    Look for a contacts backup file in sdcard/system/PIM/PIMXXXXX.vcf where X is the number of the backup.
     
  8. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    D3sRtH4mmR - using "import contacts" from the phonebook works absolutely fine, though as per previous posts it only restores the contacts from the last time I backed up using this method, which was about 6 months ago. I have a backup on my SD card which I created using "Backup & Restore" prior to updating to 2.1, as per the instructions, but there are 2 problems with it:

    1. When I restore using "Backup & Restore" the contacts are all restored to ..... God knows where. It certainly isn't the phonebook.

    2. When I use "Import contacts" from the phonebook it does not recognise the file created by "Backup & Restore". The only one that works is the one that is 6 months old..

    I really am open to any helpful suggestions as to HOW to recover my lost contacts, when I have followed the SE upgrade instructions to the letter :mad:
     
  9. xx_raj_xx

    xx_raj_xx Well-Known Member

    Joined:
    Apr 19, 2010
    Messages:
    88
    Likes Received:
    4
    I just updated my phone to 2.1, laptop was out
    I am on voda UK ~

    the first thing I did was to update the backup and restore apps, downloaded the new on from the SE site, did the backup and then updated the phone and then restore and they were all back.. I know it doesnt help you guys but for the future updaters.. make sure to download the updated backup app from SE...
     
  10. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    OK just to throw another question to the floor:

    I know I backed up my data correctly on 1.6. I then upgraded to 2.1 and was unable to restore my contacts, although everything else restored absolutely fine.

    So is it an option to "roll back" to 1.6, restore the contacts and start again??? If so how????
     
  11. hellsrage619

    hellsrage619 Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    255
    Likes Received:
    24
    You can downgrade to 1.6 but i cant tell you for sure that will fix it.As rosered said back up and restore is very problematic and your most likely SOL.

    I can only tell you to if you do go back to 1.6 and it fixes it to save your contacts either to your SIM or SD as backup and restore is useless with all the bugs it has.
     
  12. Smokey_Barr

    Smokey_Barr Well-Known Member

    Joined:
    Nov 22, 2010
    Messages:
    106
    Likes Received:
    4
    I spent many hours trying to sort this problem out (I could have manually written them out about 3 times over) and your latter option will probably be your best. Down grade to 1.6, see if that restores your contacts, update the backup-and-restore, backup your contacts again, then go for the 2.1 update...

    I really wish Sony would have had the courtesy/nouse to advise customer to update their backup-and-restore before this update. I for one, didn't even know backup-and-restore could/should be updated!
     
  13. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    It doesn't sound like I've got anything to lose by temporarily downgrading to 1.6.

    OK ........ how do I do it???

    Thanks
     
  14. hellsrage619

    hellsrage619 Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    255
    Likes Received:
    24
    If im correct you just use 1.6 firmware and flash down to it.I dont know what method you used so i cant tell you were to get the firmware.

    The guide i posted has both 1.6 and 2.1 firmwares already installed if you want you can give it a go.
    http://androidforums.com/x10-all-things-root/233013-step-step-flahing-1-6-2-1-a.html#post1972447

    Simply go threw the process but when you select firmware select a 1.6 firmware for your phone.Then when your done just flash back to 2.1.

    Hope this helps you feel free to ask any question should something not work.
     
  15. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    Thanks hellsrage619,

    Followed the link and made a start. Downloaded the first file no problem, however when I try to follow the second link I get the following:

    Download not available

    The following download is not available:

    http://rapidshare.com/files/432485556/X10-Multi-Pack.part2.rar

    Any idea where this file is now? Thanks

     
  16. hellsrage619

    hellsrage619 Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    255
    Likes Received:
    24
    Did you try any other options i used megaupload for both.
     
  17. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    I think you credit me with technical skills that are way above my pay grade !!!

    All I have done so far is follow the link you supplied, which starts off with downloading two files from "YouTube" links - which are then re-directed. The first one worked and the second one didn't. That's as far as I've got. Can't find any references to "mega upload" anywhere.
     
  18. hellsrage619

    hellsrage619 Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    255
    Likes Received:
    24
    Ill make this easier here it is
    MEGAUPLOAD - The leading online storage and file delivery service

    Tell me if it downloads :)
     
  19. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    OK that worked - can you also send me a working link for the part 1 (whatever I downloaded wasn't the right file - just something that fills my screen with adverts then crashes !!) Thanks
     
  20. hellsrage619

    hellsrage619 Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    255
    Likes Received:
    24
  21. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    First link - no. Second one - yes.

    So I've now got both files downloaded. I'll continue with the rest of the procedure and see how I get on. Many thanks for the help
     
  22. hellsrage619

    hellsrage619 Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    255
    Likes Received:
    24
    No problem if you run in to any problems post them on the guide thread.
     
  23. DonQ

    DonQ New Member

    Joined:
    Dec 11, 2010
    Messages:
    1
    Likes Received:
    0
    Uhhhmmmm.... I ran ito the same problem as Matt43. If "down-flashing" is the only option, I will have to CAREFULLY read this thread!!! As we say here in RSA Eish! It's not Ayobha!
     
  24. Matt43

    Matt43 Well-Known Member This Topic's Starter

    Joined:
    Jun 24, 2010
    Messages:
    47
    Likes Received:
    0
    Didn't work at all. I'll post a full reply on the guide thread
     

Share This Page

Loading...