1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Cannot install apps anymoreSupport


  1. SoWhy

    SoWhy Active Member

    Hi there,

    recently, my Desire started to refuse to install new applications or update old ones. They would download fine but then I'd get a message saying "Installation unsuccessful" but not give me any further information as to why that is. When using .apk files, I get "Application not installed" but no further information as well.

    I have enough space on both the phone and the SD card and I am running a rooted 2.2 original ROM.

    So I'm stuck and I need your help. Why does this happen and how can I find out? :confused:

    TIA
    SoWhy

    Advertisement
    :
  2. CarsnGadgets

    CarsnGadgets Well-Known Member

    you say you have enough space, but just to check, you need more than 15mb free on the phone to install any new apps, even if they are smaller than that.

    have you canged your googlemail address to gmail at all?

    have you tried uninstalling an app from /settings/applications/manage applications, and then see if you can re-install the same app again from the market or from a backed up apk using astro or similar?

    have you rebooted the phone?

    Have you tried on wifi as well as 3G?
  3. SoWhy

    SoWhy Active Member

    Yes, it's 53 MB at the moment.

    No, I haven't (and that would only affect the market, would it?)

    Yes, I did. Same problem.

    Yes.

    Yes, WiFi downloads never worked for me anyway.
  4. SoWhy

    SoWhy Active Member

    Maybe this helps, it's a CatLog extract about the file I tried to install:
  5. CarsnGadgets

    CarsnGadgets Well-Known Member

    i asked the googlemail question as the app market is tied to your google account and some people have had issues once they have changed from googlemail to gmail.

    The log makes no sence to me, but it mentions:
    "WRITE_EXTERNAL_STORAGE android.permission.READ_PHONE_STATE
    W/PackageManager( 2094): Failure retrieving text 0x7f060000 in package application.lmuapp"

    not sure what it means but 'external storage' is the sdcard, maybe try a different sdcard in the phone?

    sorry, thats me all out of ideas...
  6. SUroot

    SUroot Well-Known Member Developer

    Have you added a2sd+ or done mod install location?
  7. SoWhy

    SoWhy Active Member

    I considered that but it's the same when I plugged the phone to my PC and set it to disk drive (i.e. disabling the SD card for phone use). Strangely enough, it only happens when I had the app installed once, as far as I can see. Could it be related to having transferred all of them to the SD card?
  8. SoWhy

    SoWhy Active Member

    Sorry, I didn't see that post. Yes, I did change the install location once, a few weeks ago via PC I think. I can't find the "mod install location" in the Android Market.
  9. jimeller

    jimeller Well-Known Member

    Do you use a task killer and have one of the system apps be killed??

    Just a suggestion
  10. SUroot

    SUroot Well-Known Member Developer


    Yeah the mod install location you do via PC... Theres a thread about it here:

    http://androidforums.com/htc-desire/174345-how-move-apps-sd-card-unrooted-device-noobs-guide.html

    If you did this, your internal memory doesn't matter as its installing on SD card. There may be a problem with the card.
  11. SoWhy

    SoWhy Active Member

  12. SUroot

    SUroot Well-Known Member Developer

    You need to do it using that method to reverse too, yeah.

    Have you a spare SD you can test?
  13. Fatwaz

    Fatwaz Well-Known Member

    i had this problem.what i had to do was go into settings and all apps then for every google app on the phone(including market and download manager i think) i had to clear cache and data.this cured it

    heres the post that cured it for me

    Originally Posted by CuppaChoc [​IMG]
    Well, I finally found a cure. After trying all the various workarounds on the web (including the clear cache and data on market), I went through the following:

    Went into airplane mode (just to stop any sync issues)
    Cleared all possible cache/data on the following:

    Market
    Market updater
    Download manager
    Google Mail + Google * (i.e. any other google apps)
    HTC Checkin Service
    Talk

    Then I turned off phone. Turned back on. Then took out of airplane mode. Then market started working. Must be an issue with one of the other google apps which uses my creds.

    BTW, I had previously just cleared cache/data for the market app (and force closed it) and market updater and download manager and chat. Those didn't work by themselves. When I cleared out anything which pulls on the google account it all started working again.
  14. SoWhy

    SoWhy Active Member

    Yeah, at home but here at work I'd hoped I could fix it another way. I'll try reversing the effects and see if that fixes it. Thanks for your help so far :)
  15. SUroot

    SUroot Well-Known Member Developer


    Of course that means all apps will install on your precious internal memory.
  16. SoWhy

    SoWhy Active Member

    Unfortunately. The only thing that annoys me about the Desire is that some brainiac thought that 512 MB internal memory is enough. xD

    I currently assume that the problem is the default install location and not the SD card itself. If that's the case, I can still manually transfer those apps after they have been installed. But I'll have to wait until I'm back home to test that theory. I'll be back if that doesn't fix it ;)
  17. SoWhy

    SoWhy Active Member

    Okay, my guess was correct. Once I set the Install Location back to "0", I can install everything again. :)
  18. SUroot

    SUroot Well-Known Member Developer

    That was always a given. What you have yet to ascertain is whether the problem was the installation location modification or the location (SD card) itself.

    Unfortunately without swapping teh SD card you will never know.
  19. ritanguyen167

    ritanguyen167 Member

    Hi
    I also changed the install location to SD card and got the same problem. I no longer can install apps from Android Market (e.g. Google+, some games, etc.). Maybe I have to reverse the install location to default to install them. And after that, will change the install location to SD card again to move installed apps to SD card :D
    Thanks for your sharing!
  20. Grouch

    Grouch Active Member

    Old thread but top hit on google and I was able to resolve this.

    I pulled the SD and put it back and pulled it and put it back again, no luck.

    Then I got tired of switching SIM between phones.
    With no SIM you have to log into Blur and my password is a pain.
    But when I logged in, everything was working again.
  21. Hadron

    Hadron Well-Known Member Contributor

    Blur won't be part of the solution here - this is the HTC Desire forum :)
  22. Grouch

    Grouch Active Member

    BLUR was not mentioned as part of the solution, rather as an annoyance, a side issue. :D

    The issue is common to Android, not reserved for a specific phone.

    Since posting the SIM died and was replaced today.
    Not sure if a bad SIM could have anything to do with this.
    Maybe it lead to erratic behavior in the phone?
    I'm guessing separate issues.
    -noob

Loading...

Share This Page