Cannot make calls.Support

Last Updated:

  1. Hi all,

    I have tried to make a call on my S3 this morning but when I press the call buttton (the green phone symbol) on the phone I hear a beep and 'call ended' comes up in the display immediately, it returns me to the 'home screen' and I cannot make the call.

    I am on the Giffgaff mobile network, i have a full mobile signal, can send texts and access the internet/facebook etc using my mobile network connection.

    Does anyone know what the problem is or what the problem might be? I hope there isn't a problem with the phone. If you need any more information please let me know.

    Thanks in advance,


  2. jamsterdm

    jamsterdm Well-Known Member

    Ive had this problem before i had a dodgy application that stopped me making phone calls, it was some sort of a facebook contact sync app so any apps that you have related to calling/contacts remove and try calling to see if that sorts the problem, hope this helps.....

    Of course if this doesnt sort the problem you could always do a factory reset :D (i feel like samsung saying that haha)
  3. sleeco

    sleeco Well-Known Member

    it's a Giffgaff problem, it's resolved now
  4. Ok, thanks for letting me know sleeco. I have since tried to make calls again and I can now make calls no problem.


Share This Page