1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Cannot remove Game Demos from rooted phone


  1. JC1988AD

    JC1988AD Member

    Hi there

    I'm aware that there are a few threads about this around this here forum, but none of them actually go far enough to answering my particular conundrum.

    My Huawei Ideos X3 came with two game demos already installed on it which could not be uninstalled using the normal method. So, I rooted the phone (successfully, getting SuperUser and stuff - all as it should be).
    The game demos are "TBloxxNY" and "BrickBreaker"

    I proceeded to install Root Uninstaller (By a developer of the same name) and attempted to remove the game demos. This constantly threw back a message about not being able to remove due to an error.
    I then uninstalled the Root Uninstaller, and got a different one, but I ended up getting the same results - cannot uninstall. I got rid of that Uninstaller as well.

    So I downloaded the free version of Titanium Backup + Root and attempted to uninstall through that method. Again, this failed, but the experience told me that the "error" from the previous attempts was that it "Could not locate APK file"

    Keeping the Titanium app, I downloaded Android Mate (Free) and went to physically look for the files. Sure enough, there were no APK files for these demos in the main folder for all the APK files. Checking the Demo Game properties I found the location of both the APK files, and their accompanying packages:

    BrickBreaker Location - /data/cust/app/trial_brickbreake.apk
    Package - /data/data/com .digitalchocolate .androidwall

    TBloxxNY Location - /data/cust/app/trial_tbloxxny.apk
    Package /data/data/com .digitalchocolate .androidgotham

    I successfully managed to delete the packages.

    However, when I tried to delete the APK files, I selected them, picked delete and the message came up telling me the files had successfully been deleted.
    What's the problem here then? Oh, only that the files remained exactly where they were!

    I've even tried moving the files out of their current location and into the normal APK location, and into the SD Card to no avail!

    lolwut.

    I've tried looking all over the internet for answers, but I'm getting fed up of finding nothing.
    I turn to you, Android forum users I have never had the pleasure of meeting before!

    How do I remove this troublesome bloatware?
    (I want to remove it, not just freeze it, because it's taking up internet memory space I could be using for other apps)

    Advertisement
    :
  2. JC1988AD

    JC1988AD Member

    I guess no one can answer my question then.

    A little bit of an update, I've tried using ES File Explorer to mount the system as r/w and then go to delete the apk files, but it just says "the file cannot be deleted"

    I found out that the full path to the actual apk files is /cust/tesco/gb/app/

    So I tried using a Terminal Emulator to remove them, but the message about read only file system got thrown back at me.

    I realised I didn't have busybox installed, so I installed it and tried everything over again, but still didn't work. I tried running the mount r/w script from within the busybox installer app and it STILL didn't work.

    This bloatware appears to be just locked into the system and not even mounting the system as r/w can remove the read-only access to the /cust/tesco/gb/app path.

    How has Tesco managed to do this? and is there any way to get rid of it without just flashing a new ROM (an alternative that is increasingly becoming more attractive to me)?
  3. JC1988AD

    JC1988AD Member

    Okay nevermind

    I'm just going to go about flashing a new ROM

    I accidentally used "fix permissions" in Clockworkmod just now and it's buggered my phone up... I have a nandroid backup, but it's not recent. I have no lock screen, everything FCs constantly, and my physical home button does nothing but wake the phone from screen timeout... Even my launcher is screwed.

    As soon as I get home I'm going to boot into recovery, recover from the backup and then flash a new ROM

    Probably CM7, unless anyone knows any other ROMs that are compatible with the Ideos X3?
  4. JC1988AD

    JC1988AD Member

    Just flashed Eclipse ROM for the phone

    ... my word

    Even that doesn't get rid of Tesco's bloatware game demos

    And I used clockwork mod to Wipe Data, Wipe Cache & Wipe Dalvik Cache before flashing it

    I feel I must congratulate Tesco at this point, they've really stuck those in there >_>
Loading...

Share This Page