Support Cannot send/receive special characters in SMS

Discussion in 'Android Devices' started by moshemoshe, May 28, 2012.

  1. moshemoshe

    moshemoshe New Member
    5

    May 28, 2012
    2
    0
    5
    When ever I try to text ANY special characters, the character itself comes up as a ? and a space is placed between each character in the entire text, even when I text other androids or myself. Like, when I text myself

    Hablo Espa
     

    Advertisement
  2. benslgdroid

    benslgdroid rockstar
    213

    May 18, 2011
    2,567
    834
    213
    Male
    production assistant (pa), graphic artist
    Magrathea
    Are you stock or rooted?
     
  3. Thorsten

    Thorsten Well-Known Member
    53

    Mar 19, 2011
    427
    90
    53
    This is due to longstanding limitation of the U.S. implementation of SMS (Short Message Service; the texting-by-phone protocol), going back to those times when bandwidth was really expensive/limited, even for the big telcos.

    The thinking apparently was something along those lines: since U.S. residents can speak or write absolutely no language other than English (riiiiiiiiiiiiight? :D:D:D), it would save some space if text messages would only use 7 bits per character, just like the ancient ASCII standard. Since absolutely no letters beyond the basic A-Z are covered by ASCII, it is impossible to use it to properly write Spanish, French (Hello, Quebec!) or most other Latin-based languages. (And you can completely forget about Cyrillic, Arabic, Hebrew, Chinese etc. etc.)

    So there you have it
     
    AndyOpie150 likes this.
  4. Britt47

    Britt47 New Member
    6

    May 31, 2012
    2
    1
    6
    I've been experiencing this issue since I bought my phone. I'm not sure if additional language packs are needed, so I wish to clarify any information here on this forum.

    I am unable to successfully send and receive special characters in my text messages. When I attempt to send a special character (e.g.
     
    Encerspay likes this.
  5. Petrah

    Petrah Psychotic Female
    323

    Jun 13, 2011
    4,085
    1,439
    323
    Female
    Annoying my X-Husband
    Hanover Park, IL
  6. moshemoshe

    moshemoshe New Member
    5

    May 28, 2012
    2
    0
    5
    I'm rooted, benslgdroid, but I feel like, because of what Thorsten said, it doesn't really make a difference....
     
  7. benslgdroid

    benslgdroid rockstar
    213

    May 18, 2011
    2,567
    834
    213
    Male
    production assistant (pa), graphic artist
    Magrathea
    Threads are of the same issue so they have been merged to have all info in one place.
     
  8. Britt47

    Britt47 New Member
    6

    May 31, 2012
    2
    1
    6

    The answer in that topic at the time seemed more of an opinion than an accurate reason. It also spikes many more questions. However, if it's true and there isn't a fix for such a small issue, then there's nothing I can do. English is my native language anyhow so it's no biggie. :)

    Thanks for your help!
     
  9. benslgdroid

    benslgdroid rockstar
    213

    May 18, 2011
    2,567
    834
    213
    Male
    production assistant (pa), graphic artist
    Magrathea
    It's all the same topic now ;)
     
  10. eirikurr

    eirikurr New Member
    5

    Feb 5, 2013
    1
    0
    5
    This problem is easily fixed. Open the Messages app, go to Settings and select Input Mode - Unicode. Fixed!
     
  11. Thorsten

    Thorsten Well-Known Member
    53

    Mar 19, 2011
    427
    90
    53
    What
     
  12. badblue1

    badblue1 * TRUCKS ARE BEAUTIFUL *
    VIP Member
    163

    Nov 18, 2011
    1,094
    375
    163
    Male
    truck driver
    ~ the "burgh" ~
    I am rooted and have a lot of choices under settings, but no input mode?
     
  13. MacFett

    MacFett Well-Known Member
    213

    Mar 28, 2011
    3,236
    740
    213
    Male
    Worshipping Cthulhu
    Sietch Tabr
    This isn't an app issue this is because in the united States there are very few special characters used so SMS will not send with special characters. If you are able to send one chances are you have a 3rd party messaging app and it is sending the message via their servers and not your carrier.
     
  14. jazzman06

    jazzman06 New Member
    5

    Jun 14, 2013
    1
    0
    5

    wow!
    that fixed my cyrillic in a sec :) !
    all texts sent from Samsung Galaxy S3 mini Android 4.1.2 in Cyrillic
    were unreadable on other phones ( iphone, etc) and appeared as ???????
    the UNICODE trick fixed it !

    thanks :)

    P.S. just for the info , i am in Europe - France on Free mobile network.
     
  15. tt02002

    tt02002 New Member
    5

    Apr 4, 2014
    1
    0
    5
    cannot fix code why is that?
     
  16. MacFett

    MacFett Well-Known Member
    213

    Mar 28, 2011
    3,236
    740
    213
    Male
    Worshipping Cthulhu
    Sietch Tabr
    Could you give more info?
     
Tags:

Share This Page

Loading...