Cannot update to ICSSupport


  1. calin_lupas

    calin_lupas New Member

    Tried to update from android 2.3 to ICS, but the Kies mentions:

    Android Version: 2.3 / Baseband Version:I777UCKK6.

    Why am I not offered Android 4.0?

    I did not root my phone, just stopped using it for a couple of months, and today I re-activated it.

    Please help!

    Advertisement
  2. lunatic59

    lunatic59 Moderati ergo sum Moderator

    I do believe that the AT&T update is offered OTA only. You can't update it with Kies. As long as you are on AT&T's network you should be notified shortly of the update.
  3. dragula2012

    dragula2012 Well-Known Member

    I have a galaxy s2 I777 from at&t but I am not using an at&t network. Kies is offering me the update 2.3.6. Is it good? How long shall I wait to get ICS?
  4. SpamHater007

    SpamHater007 New Member

    2.3.6 is good. 4.x seems to be vapor ware. Those that got it said it was very buggy. I'm looking closer at the droid now. A friend has it and it is not much larger than the s2.
    dragula2012 likes this.
  5. BKDos25

    BKDos25 New Member

    OP,
    I am also having this issue. I have a friend that has the galaxy s2 as well. He was able to update his Firmware to 4.0.3 through the use of Kies when it first became official for ATT (a few months ago). I have updated the Kies software to the current version too. Kies says that my firmware is up to date, when I know there is a newer version than 2.3.6 (which is what I currently have). I have also tried the Over the Air update, and that says my current firmware version is also up to date. I have taken my phone into 3 different ATT stores in the area with the same result. They all say that I need to update my phone through Kies and that they can't do it for me. I am at a loss. Maybe ATT pulled the update recently because people were having too many problems with it? Any other suggestions from anyone else? Should we use Odin if we really want to update to 4.0.3? Anyone know of any good tutorials to take a stock unrooted 2.3.6 to the newest 4.0.3 ICS? Thanks guys.

    -BK

Share This Page