Cannot use Whatsapp when on mobile dataSupport


  1. nacoolp

    nacoolp New Member

    Hello,

    Recently bought a Nexus 5... happy with all the other stuffs but the main problem that is occuring is that I cannot use whatsapp when I am on mobile data. Have tried all sorts of settings and asked my service provider too with the same but to no avail. Also, I was able to use whatsapp on my previous phone with the same service provider.

    I can use web browser and other internet based apps when on mobile data, but can use whatsapp then and only then if I am on Wi-Fi... Is there some sort of settings needed to be done or any software crisis...??

    Please advise me the needful.

    Thanks and Regards

    Advertisement
    :
  2. richgm

    richgm Member

    It works fine on my Nexus 5.
    The only thing I can suggest to try is to uninstall it, turn your WIFI off then reinstall the app again.

    Rich
  3. diegom89

    diegom89 New Member

    I am facing the same issue. Could you solve it? Even reseting my phone didn't work
  4. DMajor239

    DMajor239 Well-Known Member

    That's so weird, maybe it's on their side?
  5. charliecc

    charliecc Well-Known Member

    Could the operator be blocking what's app because it errodes the revenue from SMSs?

    Some have blocked Skype for the very same reason. Can't blame them, they must be shitting themselves, imagine what's app with voice calling, their only revenue stream would be data.
    DMajor239 likes this.
  6. Kaat72

    Kaat72 Take a deep breath Guide

    Hi! Whatsapp is suggesting these steps if you encounter any connection problems:

    Reboot your phone (power off, power on).
    Upgrade WhatsApp to the latest version: Press Download Now - once the download is complete, open the file to initiate installation.
    Turn Wi-Fi off and back on (Android Settings > Wireless & networks > Wi-Fi).
    Try connecting to different Wi-Fi hotspots.
    Turn Airplane mode on and off.
    Make sure that data is enabled (Android Settings > Wireless & networks > Mobile networks).
    Go to Settings > Data Usage > Menu button > make sure Restrict background data is unchecked.
    Contact your mobile provider and make sure your APN settings are configured correctly.
    If you are often connected to Wi-Fi, check your Wi-Fi sleep policy (Homescreen > Menu Button > Settings > Wi-Fi > Menu Button > Advanced > Keep Wi-Fi on during sleep) and make sure it is set to "Always" or "Only when plugged in."
    Reboot your Wi-Fi Router.
    Verify that you receive your Google mail emails on time.
    Delete and re-install WhatsApp (Note: This will erase your chat history. Be sure to run a manual backup beforehand: WhatsApp > Menu button > Settings > Chat Preferences > Backup conversations).
    Upgrade your Android OS to the latest version for your device.

    If you are able to connect on Wi-Fi but not on your mobile connection (EDGE/2G/3G), double check your APN configuration with your mobile provider. You must be able to send and receive non-web traffic in order to use WhatsApp.
Loading...

Share This Page