1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Can't access Internet using WiFi tetheringGeneral


  1. AussieGuy

    AussieGuy Active Member

    My X10i is running 2.3.3, which includes an option for WiFi tethering. I have just set up a hotspot, with an SSID and WPA2 password. I can "see" this hotspot with my laptop, and connect to it. However, I can't access the Internet on my (linux) laptop through this hotspot. I'm not sure how to fix this... I've also tried connecting to the hotspot with an iPad (sorry folks, it's my wife's; I'm still waiting to buy an Android tablet), and again I can connect to the hotspot, but not to the Internet.

    I'm sure there's a very simple explanation, but I can't find it myself - so any advice would be most welcome!

    Thanks!

    - A.

    P.S. I've also just tried connecting from a windows computer, again can connect to the hotspot, but not to the Internet: computer says "No network connection".

    Advertisement
    :
  2. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    This is likely to be one of two issues, either this a function blocked/not supported by your network (this can happen with Telstra in Australia due to the proxy settings they use for data connection. if this is not the case then it is possible that you have WAP and not internet settings on your phone, you would need to speak with your current network provider to confirm this.
  3. Merolas

    Merolas Well-Known Member

    same issue here, i can '"see" the hotspot but i have no internet access... did it once but never been able to do so after...
  4. 916x10

    916x10 Well-Known Member

    Wow, my hotspot tethering works fine. Do you guys have your 3g data turned on when trying to access the net via your wifi hotspot?

    Reason I ask is because I just tried it on my phone, turned the wifi hotspot on, connected to it via my iPod Touch but was unable to connect to the net. Turned on my 3g and all was well.
  5. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    Have you checked the possible issues as I listed above?
  6. Same here, x10i, 2.3.3, t-mobile UK, worked as a hotspot first couple of times now connects to wifi but can't connect to internet. Do t-mobile UK block this?
  7. Merolas

    Merolas Well-Known Member

    3.5g (H+) networks all on,

    did not check with providers but it might be the issue because they do sell packages for internet sharing between mobiles
  8. beau420

    beau420 Well-Known Member

    To troubleshoot I would suggest using no security at all...if you get it working, then turn on wireless security.

    Are you running the stock version of 2.3.3? For the x10i or a?

    I have read other similar problems to this on XDA website, but they are usually with people who have installed custom ROMs.

    Have you tried downloading any third party apps to get the tethering working? I have heard people using Barnacle or something.

    SE guy might be right though. Could be the provider not allowing it.

    Ask your provider if you haven't. Or provide us with your carrier....maybe someone knows...or maybe your carrier has a forum where they might know.
  9. Smokey_Barr

    Smokey_Barr Well-Known Member

    I'm having the same problem myself on Orange UK.

    I put it down to having a bad reception at my flat. Will try setting up a hotspot without security, and if that fails will call Orange C/S (god help me!)

    Am pretty sure it's nothing to do with the provider though, as I used EasyTether ligh with some success a while ago. I do however, prefer to use stock apps for this kind of thing, so would love to get it sorted.
  10. FrankieGenius

    FrankieGenius Member

    Hi All,

    I upgraded from 2.1 to 2.3 over the weekend and I experienced a similar problem today when I tried to create a wifi hotspot. The Ipad would see the network and 'connect' but I couldn't connect to the internet and the 3G/H symbol on my phone was not responding. I knew the problem had something to do with upgrading, since I was using Barnacle on a rooted phone perfectly before (at the same location at work).

    Anyway, after doing some research and a couple hours of messing around with it, I finally got it working. This is what I did:

    I created a new Access Point and called it Tether (the name is irrelevant):-
    Goto Settings->>Wireless & Networks->>Mobile Networks->>Access Point Names->>Click the left button->>choose 'New APN'
    I copied all the settings from my original Access point (Rogers)
    Then I changed the APN Type from "default,mms,supl" to "default,mms,dun" on the new APN
    I then saved the new APN (this is important to ensure that the settings are saved).

    Now I made the new APN current and set up my Portable WiFi Hotspot with security.
    The first time it did not work.......so I switched of my phone and turned it back on again.
    Made sure that my new APN was set to current and then set up my Portable WiFi Hotspot.

    This time I had a gut feeling that it was going to work because I could see the 3G/H icon on my phone responding (i.e. upload/download arrows).

    I then proceeded to connect to the Ipad and sure enough, this time it connected and I could use the internet. Brilliant!!!

    Anyway just to note, that I am on Rogers in Canada using Stock 2.3 (not rooted), and I do have tethering available on this network (6G data plan).

    Hopefully, this will help some others, but again I guess it depends on your service provider and their restrictions.

    Cheers,

    FrankieGenius
    gosvaz, JAy3001, lowbee and 4 others like this.
  11. Sam-SonyXperia

    Sam-SonyXperia Well-Known Member

    Nice, thank you for that. I will see if I can replicate that here. :)
  12. arkangeluk

    arkangeluk Well-Known Member


    im with tmobile and i was having some probs with the hotspot but it was conflicting versions of busybox that was the problem. as soon as that was deleted the hotspot worked no problem. before i sussed out the problem(with the help from someone here who was having similar probs) i used open garden. before i upgraded to 2.3 i used barnacle but this didnt work with 2.3 so thehotspot was important.

    ric

    ps. tmobile dont block this as far as i know but i have read about some other carriers who do block it
  13. DARKSUN

    DARKSUN Member

    Good, I am about to buy the X10 just for Wifi Hotspot, hey $23 for unlimited Talk, Text, DATA on 3D is not too shabby.

    What type of speed are you all getting? I am on Mobilicity. I seem to get 1.7Mps on the demo, but it say should get 7.3....


    Thanks.
  14. Darknife

    Darknife New Member

  15. Darknife

    Darknife New Member

    This also worked for me
    lowbee likes this.
  16. rwinger0413

    rwinger0413 New Member

    Thanks for the help! It worked for me and I am with telus.
  17. Capt Smollet

    Capt Smollet New Member

    helped me as well. thanks man.
  18. maYYC

    maYYC New Member

    This was perfect, thanks for the help! I registered on here just to let everyone else know that this worked perfectly. I've used the awesome resource of androidforums.com far too many times to not jump in and register.

    My model of phone is the Sony Ericsson Xperia Pro on the Fido network (unlimited data, tethering allowed). I am currently looking at getting a Nexus 7 and I was hoping that I could get the Xperia Pro to act as a WiFi hotspot so I could connect to the internet on the tablet while on the go.

    Thanks again!

    - maYYC
    lowbee likes this.
  19. lowbee

    lowbee New Member

    Thank you both...Like you maYYC, I just register to say thanks.....Thanks FrankieGenius for posting this brilliant solution and thanks maYYC for putting the right keywords so Goggle can pick it up when I do a search......I have been struggling for 2 days before coming across this and now I can sell my Ipad3 and get a new Andriod tablet.....

    I tried to like the Ipad3 for which I got it as a gift but now I am free from it as I can now make any Andriod tablet tether to my Xperia Pro via Wifi hotspot....I am so relieve that I didn't have to be stuck with the Ipad3

    now if someone can educate me on what "supl" and "dun" suppose to do then that would put a perfect ending to this story.


    .
  20. JAy3001

    JAy3001 Well-Known Member

    Thanks FrankieGenius.

    Had a friend on Orange trying to tether to his Playbook (Yes his was THE one who brought it!), showed connected with full signal - yet no connection.

    Following your guide I got it all sorted and working for him. :)
  21. WazzoMartian

    WazzoMartian New Member

    This fix did NOT work for me but I'll tell you what DID!

    If you have an imported Xperia (in my case an Xperia S sourced from Hong Kong that I use in Australia) you may find that the pests at Sony have installed a T-Mobile US APN as the default APN which you CANNOT delete. As IT contains the default configuration, your real supplier's APNs will be over-ridden and they can't do what they are supposed to do and you will have no internet even though your Wifi HotSpot will connect to your computer.

    The solution is to alter the unwanted APN so that it contains the same values as your carrier's APN. Then turn the hotspot back on and hopefully you'll be fine, unless some other damn problem has intruded...

    It's disgusting that Sony see fit to try and force customers to use T-Mobile even though it's none of their business. The fact that numerous people the world over have bought a device that can't work as advertised is just tough luck as far as Sony are concerned. Do they understand the problem? Of course they understand! Are they going to fix it? No way! The fact is folks, that they DON'T CARE about the customer! What's important to them is their small minded Machiavellian scheming.
  22. pipaspt

    pipaspt New Member

    Thank you very much!!!!
    This solution was a life saver!
    ;)



  23. geixer

    geixer New Member

    FrankieGenius, YOU ARE A GENIUS!

    your solution worked perfectly and right away without even restarting my motorola razr maxx

    it was as easy as modifying the APN Type

    PROBLEM: you can connect to hotspot but not open any pages
    SOLUTION: change the APN type to default,mms,dun

    (see instructions in Frankie post above)
  24. Shizuka

    Shizuka New Member

    Hi all,

    Thanks FrankieGenius for your advice. My phone is Samsung Galaxy S2 with Lycamobile. The other phone I tried to tether and connect is Sony Xperia Z. For my plan to access the internet, the telecom staff advised me to add a new APN, with username and password set up by them but the APN type was "Not set".

    I tried tethering via Wifi to my Sony Xperia for the first few days since I changed to this new plan and it worked perfectly fine. However, I encountered the same problem as you guys recently. My Sony Xperia showed it is connected to the Wifi shared by Samsung S2 but showed "No connection" when accessing internet, email or whatsapp.

    I updated the APN type to "default,mms,dun" as FrankieGenius advised but still the problem persisted.

    I am very frustrated as I only need very limited data usage on whatsapp of my other phone. Please could anyone advise. Many many thanks!!

    Cheers,
    Shizuka

  25. gkthetechie

    gkthetechie New Member

    I have had same issue on my android. I have checked further and found that Access Point I was using was different than default one. I was only able to access internet on my android phone only and not with WIFI hotspot with any other device.
    I would suggest to check AP.
Loading...

Share This Page