Can't Access SD Card


Last Updated:

  1. rolltidedad

    rolltidedad Well-Known Member

    So my phone intermittently fails to access my SD card, and I can't fix the issue...

    I can't run certain programs...

    I'm running Liquid ROM...

    Advertisement
  2. jackdubl

    jackdubl Well-Known Member

    Last thing to try is reformatting the sd card. Last resort, though.
  3. rolltidedad

    rolltidedad Well-Known Member

    But then I lose everything...

    What can I try before that?
  4. rolltidedad

    rolltidedad Well-Known Member

    My phone shows 10GB available on the card, but I can't write to it or access it...
  5. scotty85

    scotty85 Guides Guide

    first thing i would do is flash a stock rom. if its fine there,then id try redownloading,reflashing,and getting a fresh start with liquid.

    if that does not fix,the issue,id try a different sd card completely. if that works,transfer all the stuff from your sd to your pc. reformat sd. give it a few days and if its still good move everything back.

    :)
  6. is this the card that came with the phone or one of them cheap priced cards off ebay? This sounds like those scams of selling 1 gig cards and making them read that they are larger than what they are.

    Whats the history of the card? Have you tried to put it in your computer and see if it reads and you can write to it?
    scotty85 likes this.
  7. rolltidedad

    rolltidedad Well-Known Member

    Scotty I do have a sense rom that I can flash, but how can I backup everything before flashing if I can't access my card?

    And it is the card that came with the phone?
  8. scotty85

    scotty85 Guides Guide

    hmm,good point :eek: try a different card and see if it will let you make a nandroid backup

    or you might remove the card and see if it will let you backup directly to the emmc.
  9. rolltidedad

    rolltidedad Well-Known Member

    Hmm...you lost me on that one...what's emmc?

    According to my settings, my SD card has 29.71GB total space and 10.31GB available space...

    My internal storage has 2.58GB total space and 1.78GB available space.

    I can't hook it up to a computer and somehow back it up to there, could I?
  10. scotty85

    scotty85 Guides Guide

    emmc=internal storage. i do not believe there are any settings to force any of the recoveries to move the backup folder location to the internal storage. thats why id take the sd card out and see if it will let you make a backup(thus putting it on internal storage).

    i think you will just get an error message,but its worth a shot :)

    the only ohter way i can thing of to make a backup would be to manually make a copy of your system,data,and boot partitions with adb. the resulting images could be repushed to the phone via adb later,or possibly flashed in hboot.
  11. rolltidedad

    rolltidedad Well-Known Member

    With 1.78GB internal storage available, would I be able to do a backup internally?

    And the adb option sounds very complicated. You wouldn't have instructions on how to do this, would you?

    Is the card the issue or is it my ROM?
  12. rolltidedad

    rolltidedad Well-Known Member

    Scotty,

    You're right...I can't backup to the internal memory...I get a message that says "Can't mount to /sd card."

    How would I manually backup to a PC and then reflash?

    Also, on one of the programs I try to run I get the message: "Can't access your SD card. Make sure it isn't mounted." What does that mean?
  13. scotty85

    scotty85 Guides Guide

    if you look in sd cards and storage,there should be an option to unmount for removal,or to mount the sd if its unmounted.

    have you tried a new sd card yet?
  14. rolltidedad

    rolltidedad Well-Known Member


    I have not tried a new card yet.

    Is it supposed to be mounted or unmounted?

    If I wanted to try formatting the card first, is there a way to copy all files to my computer and then back to the card once formatted?
  15. scotty85

    scotty85 Guides Guide

    the card should be mounted to read and write to it.

    so when you check sd and storage,it should say something like "unmount for safe removal" or if its allready unmounted,for some reason,it will say the opposite- "mount sd card" or something like that.

    you can transfer all your sd cards files by puting it into your PC with an inexpensive sd card reader. meijer/wall mart should have them for arounf $10

    if you want to try a format,do a "full format" on your pc,and make sure you choose FAT32 or PG05IMG files wont be seen in hboot :)
  16. rolltidedad

    rolltidedad Well-Known Member

    Scotty, I'm baffled at what to do...

    The card is mounted...I show 10 gigs of space left, but I can't access the card...

    What should I do?
  17. scotty85

    scotty85 Guides Guide

    i would buy a 2gb sd card and a card reader. put your current card in the card reader,see if the PC can access it,read it,write it,etc. put the 2gb card in the TB,see if its accessible. if the 2gb card is good,you can try and transfer everything from the 32gb card to the PC and reformat it. assuming the PC is able to read it. if not you may be SOL and need a new 32 gb sd card... tho that is prolly better than needing a new thunderbolt.

    if the 2gb card is not accessible either,then well go from there...
  18. rolltidedad

    rolltidedad Well-Known Member

    Scotty,

    Now I'm confused...

    I decided to try your first option before buying a new card...

    I did a nandroid backup, successfully, and then I wiped everything and flashed a sense rom...I then wiped again and flashed an AOSP (Liquid Sense 3.2)...

    And now it still won't recognize the card...

    Here's what I'm confused about:

    Doesn't a nandroid backup store everything to the SD card? If so, then recovery recognizes my card.

    Then why isn't it recognized after reflashing the ROM?
  19. jackdubl

    jackdubl Well-Known Member

    Did it recognize the card while you were on the sense rom? I assume the sense rom had been previously loaded onto the card?
  20. rolltidedad

    rolltidedad Well-Known Member

    I didn't check the card on the sense rom...

    But it was already loaded on the card...
  21. scotty85

    scotty85 Guides Guide

    yes,you needed to run the stock rom for a long enuff period of time to determine if it was working there or not.

    and yes,backups are stored onthe card,so if it worked,recovery is accesing it just fine.

    if a backup worked,your sd is mounted and showing space,it all sounds like the card is working. what errors or issues are you having exactly? maybe they are with certain apps or settings?
  22. rolltidedad

    rolltidedad Well-Known Member

    That's what I thought...if recovery is accessing it, then the card probably isn't busted...

    When I go to the phone settings, I see: SD card, 29.71GB total space and 9.58GB available...then internal storage, 2.58GB total space and 1.80GB available...

    But the phone will not communicate with the card...

    Here are some examples:

    1. When I try to open Waze GPS, I get the message: "Waze can't access your SD card. Make sure it isn't mounted."

    2. When I try to move an application to my SD card I get the message that it failed to move it.

    3. When I open my camera program, the message "Please insert an SD card before using the camera" is displayed across the screen.

    And I did just borrow a friend's SD card read...I can see and access everything on the card from my computer, just not from my phone...
  23. jackdubl

    jackdubl Well-Known Member

    So recovery can read the card. Now I'm real curious if it works on another rom.
  24. rolltidedad

    rolltidedad Well-Known Member

    I've been using Liquid Smooth 3.2 for several months now, and it's been recognizing my card the entire time...up until about 3 days ago...
  25. scotty85

    scotty85 Guides Guide


    Me too.

Share This Page