Can't boot from USB suddenly.


  1. Prinny

    Prinny Resident Linux Nutcase Guide

    So, bit of a perplexing problem here.

    As usual, I get bored of operating systems, and was hopping back to another distro as usual.

    Anyway, to make a short story long, I'm not sure if my USB drive is fried, or what's going on here.

    Basically, I downloaded said ISO (Debian spin, Snowlinux 3.1) and I used my usual unetbootin on my Windows partition to write it to a flash drive. It sees my drive, and succeeds. Huzzah, right?

    Wrong.

    What I then do is reboot, press F9 to boot from USB....and bam, boots into windows.

    Okayyy. So I thought it was my computer. Plugged it up into another PC, F12 for startup order....Bam...Windows.

    Weird.

    So that being said, I tried an 8GB SD Card. Start up order....bam...windows.

    Hmm. I'm a bit perplexed by this...

    Any of you PC Guru's have any thoughts/suggestions? I've formatted both the SD card, and the flash drive multiple times. Tried FAT16, FAT32, and NTFS. Just to say that I tried everything.

    Any thoughts and suggestions would be appreciated!

    Advertisement
  2. Speed Daemon

    Speed Daemon Disabled

    Where is Windows coming from? Do both computers still have Windows installed?

    Have you tried flashing a fresh image onto the USB drive?
  3. argedion

    argedion The TechnoFrog Moderator

    also check to make sure you still have boot flag on the usb drives if its not there then they wont boot up.
  4. SUroot

    SUroot Well-Known Member

    unetbootin has never worked for me consistently. Hardly ever do my USB's remain bootable.

    I much prefer using YUMI from pendrivelinux. Try that...
  5. argedion

    argedion The TechnoFrog Moderator

    yummi thanks for the heads up :)

    if that doesnt work for you go command line and use dd

    dd if=/path/to/iso of=/dev/usbdevice

    WARNING
    Make sure that the usbdevice is the one you want to have the image on as dd will eliminate all data on the device.
  6. Prinny

    Prinny Resident Linux Nutcase Guide

    Yeah, I almost ALWAYS use the dd command. It's just better than unetbootin, I feel.

    Anyway, I think it's just my flash drive. Which is weird, because it works as a storage medium, but not as a bootable drive anymore. I didn't remove any boot flags, so who knows.

    Got a new 8gb one on clearance at Walgreens for $4. So I can't complain.

    Thanks for the answers, though, everyone!
    argedion likes this.
  7. justintimber

    justintimber New Member

    If you are not able to boot from USB suddenly then check your system
  8. argedion

    argedion The TechnoFrog Moderator

  9. Speed Daemon

    Speed Daemon Disabled

    Hmmm...dd is convenient, but I wish I had something that let me choose between multiple ISO images. Anybody know of a utility that can do that? It looks like most use a DOS environment and something like SYSLINUX to load the ISO image. Does anyone know if the config files can be edited to use menus?

    I have this tiny little 32GB USB drive that could hold all of my utility ISOs and a few full OS installs as well. I want that!!!!
    argedion likes this.
  10. SUroot

    SUroot Well-Known Member

    IOWA likes this.
  11. argedion

    argedion The TechnoFrog Moderator

  12. Grouch

    Grouch Active Member

    Did you try a different port?
  13. SUroot

    SUroot Well-Known Member

    Maybe you haven't drunk quite enough WINE today?

    ;)
  14. SUroot

    SUroot Well-Known Member

    Thanks for reading post 1 in full ;)
  15. Grouch

    Grouch Active Member

    I take this to mean that your flash and usb ports are separate. I use a usb flash adapter myself.

    Anyways, see if there is a BIOS update.
  16. SUroot

    SUroot Well-Known Member

    He tried it on another computer. Undoubtedly that rules out the USB port
  17. IOWA

    IOWA Mr. Logic Pants Moderator

  18. h4x0rj3ff

    h4x0rj3ff Chemist

    argedion likes this.
  19. SUroot

    SUroot Well-Known Member

    Yeah plop is great. I actually put it on yumi as a boot-to-cd option

Share This Page